LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-04-2003, 09:28 PM   #1
Spooner
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware, Gentoo, Debain
Posts: 1

Rep: Reputation: 0
Problem booting Slackware from GRUB


I cannot boot Slackware 8.1 from GRUB. Heres my grub.conf:

default=1
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-19.8.0)
root (hd1,0)
kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/1 hdd=ide-scsi
initrd /initrd-2.4.18-19.8.0.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1
title Debain
root (hd0,1)
kernel /vmlinuz root=/dev/hda2 ro hdd=ide-scsi
title Slackware
root (hd1,2)
kernel /boot/vmlinuz root=/dev/hdb3 vga=791 ro

When I use this conf it says the attempt to mount the root filesystem as rw failed. It also suggests putting a rw flag in lilo and some other options. I tried to put the rw flag in place of the ro flag in GRUB and then it says it must first be mounted read-only. A /vmlinuz link wasnt created during installation but everyone else seems to have one. Could my disk image from which I made the installation disk be corrupted I have downloaded it 3 times. Can anyone help?
 
Old 03-04-2003, 09:47 PM   #2
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Rep: Reputation: 30
My only answer to this is;
Why don't you use lilo... Lol, I don't know since you downloaded it 3 times i would think you could go for a different approach maybe you aren't doing something correctly right away i went with lilo sence it was easier and all.. I know i'm a sissy to fool with GRUB ;x
 
Old 03-05-2003, 05:47 PM   #3
Walt Dizzy
LQ Newbie
 
Registered: Feb 2003
Location: Madison, Wisconsin
Distribution: Slackware 8.1
Posts: 10

Rep: Reputation: 0
IIRC, only the latest version of Grub (0.93?) will boot Slackware properly.

Walt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Old installation of GRUB prevents me from using LILO and booting into Slackware! EThitop Slackware 6 12-12-2004 01:07 PM
Problem With Booting XP using GRUB bowb4steve Linux - Newbie 2 10-28-2004 09:25 PM
booting problem using grub tacca *BSD 3 10-23-2004 04:58 PM
problem booting other Linux OS using GRUB tuxrules Linux - Newbie 2 07-21-2004 02:08 PM
RH 9 Problem Booting with Grub scottym Linux - Distributions 1 08-03-2003 11:54 PM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration