LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-21-2013, 11:49 PM   #16
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181

Quote:
Originally Posted by gmgf View Post
Try to remove /home/you/.kde/share/config/phonondevicesrc...
Well.... it was a slow first day of Summer, so I gave it another try and installed the 3.9.5 kernel for the 3rd time.
I found that if I went straight into Xfce I had sound. Much lower volume than before, but it worked.
However, when I changed to KDE 4.10.4, the sound, at the highest possible setting, was so low that if your ears were 12" from the speakers and you were eating popcorn you wouldn't be able to hear it. Starting KDE killed the sound for everything, i.e., if I went back to Xfce without rebooting there was no sound.

So, with gmgf's suggestion in mind, which I had tried before, I went into the ~.kde configuration files and deleted everything I could find that is related to sound, e.g., kmixer.rc, etc. Upon rebooting the system the sound returned for both Xfce and KDE, however, it is at a much lower volume
than with the previous 3.8.13 kernel. The speakers are now at about 85% and software volume control at 60% to get the same sound level as the hardware level at 50% and the software level at 40% with the previous kernel.
Either way, the sound quality is still not, in anyway, as good as in, ugh, Xp.
Unacceptable.

Last edited by cwizardone; 06-22-2013 at 12:01 AM.
 
Old 06-23-2013, 10:21 AM   #17
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
Installed the 3.9.7 kernel, et al., late last night. Didn't improve the sound situation. The low remains very low.
Thinking of going back to the 3.8.13 kernel.

Last edited by cwizardone; 06-23-2013 at 10:23 AM.
 
Old 06-23-2013, 10:58 AM   #18
GazL
Senior Member
 
Registered: May 2008
Posts: 3,479

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
I had the lower volume sound problem all the way from the introduction of ALSA until somewhere around kernel 3.2/3.3 where it suddenly became louder. No amount of playing with settings (including the model= settings on the driver module) helped. One thing I did notice was that at the time it started working correctly my alsamixer gained an independent 'headphones' slider to go along with the 'Master' and 'Front'. controls.

I'd keep an eye out for subtle differences like this between what you used to have and what you have on the newer kernel.
Have you compared the output of 'amixer' between the two different kernel versions? You could also try the latest alsa-lib/alsa-utils to see if they help.

You're in a better position than I was as you at least have a known working kernel and you could bisect your way to finding the commit that breaks things for you and possibly talk with the alsa devs about the regression. As mine never worked, that wasn't really an option for me.
 
1 members found this post helpful.
Old 06-23-2013, 11:48 AM   #19
mattallmill
Member
 
Registered: Nov 2009
Location: Salina,Kansas
Distribution: Slackware64-current
Posts: 207

Rep: Reputation: 33
@cwizardone - Just for the record, if you're feeling up to it, perhaps you could go to kernel.org and download 3.9.4 and compile that instead of just using -current's kernel. I have found that the combination of the kernel, KDE 4.9.5, and the latest ALSA have made for a winning combination as far as sound goes. My sound works perfectly all the time. No fiddling with mixer settings to get the sound up to an acceptable level.

Just a thought.

Regards,

Matt
 
1 members found this post helpful.
Old 06-23-2013, 02:40 PM   #20
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
Quote:
Originally Posted by mattallmill View Post
@cwizardone - Just for the record, if you're feeling up to it, perhaps you could go to kernel.org and download 3.9.4 and compile that instead of just using -current's kernel. I have found that the combination of the kernel, KDE 4.9.5, and the latest ALSA have made for a winning combination as far as sound goes. My sound works perfectly all the time. No fiddling with mixer settings to get the sound up to an acceptable level.

Just a thought.

Thanks. I'm a bit burned out on it now, but I'll definitely consider it when my attitude improves.
 
Old 06-23-2013, 02:51 PM   #21
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
Quote:
Originally Posted by GazL View Post
I had the lower volume sound problem all the way from the introduction of ALSA until somewhere around kernel 3.2/3.3 where it suddenly became louder. No amount of playing with settings (including the model= settings on the driver module) helped. One thing I did notice was that at the time it started working correctly my alsamixer gained an independent 'headphones' slider to go along with the 'Master' and 'Front'. controls.
Interesting! Over the years, through various machines, I cannot remember seeing a headphone slider in alsamixer.


Quote:
Originally Posted by GazL View Post
I'd keep an eye out for subtle differences like this between what you used to have and what you have on the newer kernel.
Have you compared the output of 'amixer' between the two different kernel versions? You could also try the latest alsa-lib/alsa-utils to see if they help....
Thanks for the idea. I printed them out and compared them. The 3.9.7 kernel (and 3.9.5?) adds a "Auto-Mute Mode" to alsamixer. However, disabling it didn't solve the problem.

There are other differences.
Here is the contents of amixer for both the 3.8.13 and 3.9.7 kernels.
First, the 3.8.13 amixer,

Quote:
bash-4.2$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 27 [42%] [-27.75dB] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Surround',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Center',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'LFE',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 8 [57%] [12.00dB] [on]
Front Right: Capture 8 [57%] [12.00dB] [on]
Simple mixer control 'Capture',1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 0 [0%] [0.00dB] [off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Digital',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 120
Front Left: Capture 0 [0%] [-30.00dB]
Front Right: Capture 0 [0%] [-30.00dB]
Simple mixer control 'Input Source',0
Capabilities: cenum
Items: 'Front Mic' 'Rear Mic' 'Line'
Item0: 'Front Mic'
Simple mixer control 'Input Source',1
Capabilities: cenum
Items: 'Front Mic' 'Rear Mic' 'Line'
Item0: 'Front Mic'
Simple mixer control 'Mux',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 2
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'Mux',1
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 4
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control 'Rear Mic Jack Mode',0
Capabilities: enum
Items: 'Mic In' 'Line In'
Item0: 'Mic In'
Simple mixer control 'Swap Center/LFE',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
bash-4.2$

and, below, amixer from the 3.9.7 kernel:

Quote:
bash-4.2$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 80 [63%] [-35.25dB] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Front',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 127 [100%] [0.00dB] [on]
Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Front Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 2
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Surround',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 127 [100%] [0.00dB] [on]
Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Center',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'LFE',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 127
Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 8 [57%] [12.00dB] [on]
Front Right: Capture 8 [57%] [12.00dB] [on]
Simple mixer control 'Capture',1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 14
Front Left: Capture 0 [0%] [0.00dB] [off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control 'Auto-Mute Mode',0
Capabilities: enum
Items: 'Disabled' 'Enabled'
Item0: 'Enabled'
Simple mixer control 'Digital',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 120
Front Left: Capture 0 [0%] [-30.00dB]
Front Right: Capture 0 [0%] [-30.00dB]
Simple mixer control 'Input Source',0
Capabilities: cenum
Items: 'Front Mic' 'Rear Mic' 'Line'
Item0: 'Front Mic'
Simple mixer control 'Input Source',1
Capabilities: cenum
Items: 'Front Mic' 'Rear Mic' 'Line'
Item0: 'Front Mic'
bash-4.2$
I don't see the culprit, but, perhaps, I overlooked it.

Last edited by cwizardone; 06-23-2013 at 05:53 PM.
 
Old 06-24-2013, 04:27 PM   #22
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
It has been a rainy morning so I've been tinkering with 3.9.7, again, and found if I run command line audio players *outside* of X, the volume is fine. Once I go into X, be it Xfce or KDE, the sound level is cut by at least 50%. If I open a terminal and run the same command, i.e., player and sound file, the volume is reduced to almost zero. If I logout of Xfce or KDE, the volume level returns.
Go figure....

Last edited by cwizardone; 06-24-2013 at 04:35 PM.
 
Old 06-25-2013, 11:31 AM   #23
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
Another rainy morning (odd for June). Tried switching versions of X, i.e., 1.14.1 vs. 1.13.4. Didn't solve anything, but it does work very well. Tried un-installing the NVidia driver, but didn't change anything either, the problem remains.

Definitely has to be a kernel bug, as reported over at Redhat.

So, I'm back to the 3.8.13 kernel and NVidia driver, and I've left the latest kernel-firmware file and X-org 1.14.1, installed. They works very well together.

HOWEVER, after going through all of this over the last two weeks and bouncing back and forth between Linux and Xp, there is no doubt the audio and video are superior in winXp vs. Linux, at least Slackware. No doubt about it. The audio, especially, is far, far superior to Linux.

I've noticed over the years that Linux printing quality has caught up with winblows. It wasn't too many years ago I could print out the same document, with color graphics in the letterhead, and the one printed in winblows was visibly superior. Not anymore. The copy printed in LibreOffice is every bit as good.

Scanning still sucks! Just tried it, again, over this last weekend and compared it to the same thing scanned in winblows and, as before, the result done in Linux was visibly inferior in so many ways. To get around that I long ago installed Xp into VirtualBox and do all my scanning that way.

Discouraging that here we are, 12 years after the release of Xp, and we are still playing catch up. BTW, I'm not saying Linux should be like winblows, but one should be able to accomplish the same tasks with as good, if not superior results in Linux. Afterall, it is the superior operating system and Slackware is the best of the best.

Last edited by cwizardone; 06-25-2013 at 04:35 PM.
 
Old 06-25-2013, 12:55 PM   #24
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,049

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by cwizardone View Post
Another rainy morning...
Scanning still sucks! Just tried it, again, over this last weekend...and Slackware is the best of the best.
I just scanned a bunch of stuff for the first time in eons (I *was* a highly-paid DTP *expert* in a previous incarnation...) and I had no disappointments, using a cheapo canon usb unit. I don't have any windows installs to compare to tho'...so, obviously, ymmv....


cheers,
 
Old 06-25-2013, 04:28 PM   #25
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
OK. Here are two examples. Both were done at 300 dpi with no other changes to the default settings. The darker of the two was done in XSane. The lighter was done in winblows using the HP software. The winblows/HP version is a very close copy of the original.
Attached Images
File Type: jpg xsane.jpg (228.4 KB, 38 views)
File Type: jpg sw-vb-xp-01.jpg (210.7 KB, 35 views)

Last edited by cwizardone; 06-25-2013 at 04:36 PM.
 
Old 07-06-2013, 12:20 PM   #26
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
The 3.9.9 kernel does not solve the sound problem. Back to the 3.8.13 kernel.
 
Old 07-11-2013, 12:38 PM   #27
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
In the wee hours this morning I complied and installed the 3.10 kernel. It was the first time in over 10 years... probably closer to 15, that I've complied a kernel and, the thing worked (to my surprise ).

Unfortunately, it didn't solve the problem.

If I boot straight to the command line and run, "play whatever.wav vol 1" the volume is loud enough to
knock me off the chair, as the hardware volume on the speakers is set up for use in Xfce or KDE.

It would appear to be a conflict somewhere between the kernel (or kernel module) and Xorg.

Regardless, it is back to the 3.8.13 kernel.
 
Old 07-11-2013, 11:23 PM   #28
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,650
Blog Entries: 15

Rep: Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113Reputation: 1113
Just a sidenote on the audio issue... I should have remembered.

SlackBuilds.org does still carry the OpenSound drivers, so you might want to try it with them if the Kernel ALSA drivers aren't playing nice.

http://slackbuilds.org/repository/14.0/system/oss/
 
1 members found this post helpful.
Old 07-12-2013, 02:38 AM   #29
rvdboom
Member
 
Registered: Jul 2007
Distribution: Slackware
Posts: 186

Rep: Reputation: 23
What type of "sound" do you try to listen to?
alsa added channel mapping for surround sound with the 1.0.27 version that is in current since may, and I found that it's not working fairly well yet. I wouldn't be surprised that kernel 3.8.13 didn't support this while 3.9.X does.
In my case, it came out at very unequal sound in VLC with 5.1 files, since no downmixing is done and I only get the left and right front channel and not the center and surround ones.
 
Old 07-12-2013, 10:56 AM   #30
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,252

Original Poster
Rep: Reputation: 181Reputation: 181
@ReaperX7, Thanks for the idea.

@rvdboom, Volume, the lack thereof, is the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent Changes in Current (or things that go bump in the night). cwizardone Slackware 13 03-02-2013 09:30 AM
[SOLVED] Problems after upgrade to -current gmartin Slackware 1 12-29-2011 10:50 PM
LXer: Tutorial: Viewing the Night Sky with Linux, Part I: KStars LXer Syndicated Linux News 0 08-29-2008 05:00 AM
What first upgrade kernel or upgrade slack 10.0 to current Kelean Slackware 7 01-16-2005 07:54 PM
bash scripts which go bump in the night and the system resources who hate them dehuszar Programming 16 07-08-2004 04:24 PM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration