LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-11-2013, 01:23 AM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Rep: Reputation: 176Reputation: 176
Problem-Audio Bug with the 3.9.5 Kernel.


Edit in, 19:45, 15 June 2013: It's a bug. See post #15, below.
*****************************************************************
Original first post:
Did the upgrade about an hour ago and sound, for the most part, has disappeared.
Sound will work in Xfce, but the volume is very low.
Upon starting KDE it brings up a box with the message that KDE "has detected that one or more internal devices were removed.." and do I want KDE to forget about them.
It then lists two items, one for output and one for capture, and they are both the default sound device that has not been removed.
I've ran alsamixer and all looks well and it shows the Sigmatel stac9221 A1 card as the default device.

Looks to be a kernel problem or a firmware problem? Guess they are one and the same, basically.

Thanks.

Last edited by cwizardone; 06-15-2013 at 09:46 PM.
 
Old 06-11-2013, 08:09 AM   #2
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
Went back to the 3.8.13 kernel and sound has returned.
Kept the new 20130610 firmware package.
 
Old 06-11-2013, 10:48 AM   #3
zakame
Member
 
Registered: Apr 2012
Distribution: Debian, Ubuntu, Slackware
Posts: 124

Rep: Reputation: 43
I saw the KDE prompt as well, and confirmed the removal (it was capture and output for both HDA Intel and Conexant audio on my X200.) Sound still works as it should on mine, however.
 
1 members found this post helpful.
Old 06-13-2013, 12:33 PM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
Decided to give the 3.9.5 kernel another try and the results were the same. However, just for chuckles I ran "play" from the command line outside of X and could play audio files. Then, if on a fresh boot, I use Xfce I can hear audio in music or video IF I turn the volume almost all the way to the max.
However, once KDE is fired up there is no audio whatsoever. None, from the command line outside of X, or if I switch to Xfce without rebooting, i.e., no sound from any application running in Xfce.
I've tried various "fixes" and still searching for a answer.
Any ideas.. anyone?
Thanks.

Last edited by cwizardone; 06-13-2013 at 12:34 PM.
 
Old 06-13-2013, 12:47 PM   #5
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 875

Rep: Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814
I had the same thing here right after the kernel bump and removing the KDE devices upon restarting KDE (which I think is the right thing to do). Volume was up, so I hit the mixer button and found that PCM was turned all the way down. Once I turned that up, it worked. It's been fine since.
 
1 members found this post helpful.
Old 06-13-2013, 01:20 PM   #6
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by volkerdi View Post
I had the same thing here right after the kernel bump and removing the KDE devices upon restarting KDE (which I think is the right thing to do). Volume was up, so I hit the mixer button and found that PCM was turned all the way down. Once I turned that up, it worked. It's been fine since.
Thank you for taking the time to reply. It is greatly appreciated.
However, I had already checked the PCM and it was on (selected as a control) and turned all the way up. Doesnt' make a difference. The problem remains.
 
Old 06-13-2013, 01:39 PM   #7
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 875

Rep: Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814
Maybe deleting the files in /var/lib/alsa/ and restarting rc.alsa would help?
 
1 members found this post helpful.
Old 06-13-2013, 02:05 PM   #8
gmgf
Member
 
Registered: Jun 2012
Location: France
Distribution: Slackware Zenwalk
Posts: 166

Rep: Reputation: Disabled
Try to remove /home/you/.kde/share/config/phonondevicesrc

and restart kde
 
1 members found this post helpful.
Old 06-13-2013, 06:34 PM   #9
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,465

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
I saw the same thing with my hardware.
On initial boot with the new kernel, I saw messages about undefined controls from alsa. I deleted /var/lib/alsa/asound.state and did 'alsactl store'. On reboot the messages were gone.
KDE prompted about devices being removed, so I removed the devices. I also entered 'alsamixer' from a terminal window, pushed the levels up, then tested sound using mpg123. I then entered the KDE SystemSettings -> Multimedia -> Phonon -> Device Preferences and configured the device preferences after using the Test button to find the appropriate device.
More mucking about than I have had to do for a while, so a good reminder!
 
1 members found this post helpful.
Old 06-14-2013, 08:55 AM   #10
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by volkerdi View Post
Maybe deleting the files in /var/lib/alsa/ and restarting rc.alsa would help?
Some mornings I'm lucky I can remember my name but I did remember you have recommeded this procedure before for similar problems and it was one of the first things I tried. Didn't work this time unfortunately.


Quote:
Originally Posted by gmgf View Post
Try to remove /home/you/.kde/share/config/phonondevicesrc and restart kde
Thanks. Tried that, but it didn't help, but thanks, again, for the suggestion.

I tried re-installing gstreamer, phonon, X (just for the heck of it), and a few other things. Nothing worked.
Finally, I threw in the towel and did a fresh installation from a very recent ISO of -current, brought it up-to-date, installed all the multilib files, etc., and audio has returned. The volume is still not as "strong" as it use to be, but it now works. Nothing wrong with the speakers, btw, I booted over to, ugh, Xp, and they work fine.

Thanks to Mr. Volkerding and gmgf for their suggestions and zakame and allend for their replies.
 
Old 06-14-2013, 10:51 PM   #11
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
Well, I'm over here in, ugh, Xp and, well.... With the volume knob on the speakers turned up only half way, as compared to the level used in Slackware64-current, about 80%, I have to turn the XP software volume control almost to 1 or 2 to get it down to a reasonable level. Plus the overall quality of the sound (tone, richness, etc., etc.) is far superior to what comes out of the same speakers, playing the same file through the same player (VLC).
Don't know what to say, but there has to be something wrong with the audio since installing the latest kernel.
 
Old 06-14-2013, 10:59 PM   #12
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,191

Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Quote:
Originally Posted by cwizardone View Post
Don't know what to say, but there has to be something wrong with the audio since installing the latest kernel.
Interesting. I'm running 32 bit -current on three units here and all is well.
 
Old 06-15-2013, 01:15 AM   #13
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 875

Rep: Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814Reputation: 1814
Quote:
Originally Posted by cwizardone View Post
Don't know what to say, but there has to be something wrong with the audio since installing the latest kernel.
Or maybe it's got something to do with "True Multilib", or some other local customization...
 
Old 06-15-2013, 08:34 AM   #14
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
IIRC, "True Multilib" is how Alien BOB referred to the files. Other than the name, they are the "standard" multilib files, nothing customized.


Edit in: Found it, first paragraph,

"This article contains instructions on how to create a true multilib Slackware64..."

http://alien.slackbook.org/dokuwiki/...kware:multilib

Last edited by cwizardone; 06-15-2013 at 09:04 AM.
 
Old 06-15-2013, 10:03 AM   #15
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,238

Original Poster
Rep: Reputation: 176Reputation: 176
Well, well, well.... Seems it is considered a bug over at Redhat,

Quote:
Bug 974225 - No sound after reboot with kernel >= 3.9.5 or even on resume from kernel version > 3.8.11
https://bugzilla.redhat.com/show_bug.cgi?id=974225
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent Changes in Current (or things that go bump in the night). cwizardone Slackware 13 03-02-2013 08:30 AM
[SOLVED] Problems after upgrade to -current gmartin Slackware 1 12-29-2011 09:50 PM
LXer: Tutorial: Viewing the Night Sky with Linux, Part I: KStars LXer Syndicated Linux News 0 08-29-2008 04:00 AM
What first upgrade kernel or upgrade slack 10.0 to current Kelean Slackware 7 01-16-2005 06:54 PM
bash scripts which go bump in the night and the system resources who hate them dehuszar Programming 16 07-08-2004 03:24 PM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration