LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Problem-Audio Bug with the 3.9.5 Kernel. (http://www.linuxquestions.org/questions/slackware-14/problem-audio-bug-with-the-3-9-5-kernel-4175465515/)

cwizardone 06-11-2013 02:23 AM

Problem-Audio Bug with the 3.9.5 Kernel.
 
Edit in, 19:45, 15 June 2013: It's a bug. See post #15, below.
*****************************************************************
Original first post:
Did the upgrade about an hour ago and sound, for the most part, has disappeared.
Sound will work in Xfce, but the volume is very low.
Upon starting KDE it brings up a box with the message that KDE "has detected that one or more internal devices were removed.." and do I want KDE to forget about them.
It then lists two items, one for output and one for capture, and they are both the default sound device that has not been removed.
I've ran alsamixer and all looks well and it shows the Sigmatel stac9221 A1 card as the default device.

Looks to be a kernel problem or a firmware problem? Guess they are one and the same, basically.

Thanks.
:hattip:

cwizardone 06-11-2013 09:09 AM

Went back to the 3.8.13 kernel and sound has returned.
Kept the new 20130610 firmware package.

zakame 06-11-2013 11:48 AM

I saw the KDE prompt as well, and confirmed the removal (it was capture and output for both HDA Intel and Conexant audio on my X200.) Sound still works as it should on mine, however.

cwizardone 06-13-2013 01:33 PM

Decided to give the 3.9.5 kernel another try and the results were the same. However, just for chuckles I ran "play" from the command line outside of X and could play audio files. Then, if on a fresh boot, I use Xfce I can hear audio in music or video IF I turn the volume almost all the way to the max.
However, once KDE is fired up there is no audio whatsoever. None, from the command line outside of X, or if I switch to Xfce without rebooting, i.e., no sound from any application running in Xfce.
I've tried various "fixes" and still searching for a answer.
Any ideas.. anyone?
Thanks.
:hattip:

volkerdi 06-13-2013 01:47 PM

I had the same thing here right after the kernel bump and removing the KDE devices upon restarting KDE (which I think is the right thing to do). Volume was up, so I hit the mixer button and found that PCM was turned all the way down. Once I turned that up, it worked. It's been fine since.

cwizardone 06-13-2013 02:20 PM

Quote:

Originally Posted by volkerdi (Post 4971155)
I had the same thing here right after the kernel bump and removing the KDE devices upon restarting KDE (which I think is the right thing to do). Volume was up, so I hit the mixer button and found that PCM was turned all the way down. Once I turned that up, it worked. It's been fine since.

Thank you for taking the time to reply. It is greatly appreciated.
However, :) I had already checked the PCM and it was on (selected as a control) and turned all the way up. Doesnt' make a difference. The problem remains.
:)

volkerdi 06-13-2013 02:39 PM

Maybe deleting the files in /var/lib/alsa/ and restarting rc.alsa would help?

gmgf 06-13-2013 03:05 PM

Try to remove /home/you/.kde/share/config/phonondevicesrc

and restart kde

allend 06-13-2013 07:34 PM

I saw the same thing with my hardware.
On initial boot with the new kernel, I saw messages about undefined controls from alsa. I deleted /var/lib/alsa/asound.state and did 'alsactl store'. On reboot the messages were gone.
KDE prompted about devices being removed, so I removed the devices. I also entered 'alsamixer' from a terminal window, pushed the levels up, then tested sound using mpg123. I then entered the KDE SystemSettings -> Multimedia -> Phonon -> Device Preferences and configured the device preferences after using the Test button to find the appropriate device.
More mucking about than I have had to do for a while, so a good reminder!

cwizardone 06-14-2013 09:55 AM

Quote:

Originally Posted by volkerdi (Post 4971193)
Maybe deleting the files in /var/lib/alsa/ and restarting rc.alsa would help?

Some mornings I'm lucky I can remember my name :) but I did remember you have recommeded this procedure before for similar problems and it was one of the first things I tried. Didn't work this time unfortunately. :(


Quote:

Originally Posted by gmgf (Post 4971208)
Try to remove /home/you/.kde/share/config/phonondevicesrc and restart kde

Thanks. Tried that, but it didn't help, but thanks, again, for the suggestion.

I tried re-installing gstreamer, phonon, X (just for the heck of it), and a few other things. Nothing worked.
Finally, I threw in the towel and did a fresh installation from a very recent ISO of -current, brought it up-to-date, installed all the multilib files, etc., and audio has returned. The volume is still not as "strong" as it use to be, but it now works. Nothing wrong with the speakers, btw, I booted over to, ugh, Xp, and they work fine.

Thanks to Mr. Volkerding and gmgf for their suggestions and zakame and allend for their replies.
:hattip:

cwizardone 06-14-2013 11:51 PM

Well, I'm over here in, ugh, Xp and, well.... With the volume knob on the speakers turned up only half way, as compared to the level used in Slackware64-current, about 80%, I have to turn the XP software volume control almost to 1 or 2 to get it down to a reasonable level. Plus the overall quality of the sound (tone, richness, etc., etc.) is far superior to what comes out of the same speakers, playing the same file through the same player (VLC).
Don't know what to say, but there has to be something wrong with the audio since installing the latest kernel.
:scratch:

hitest 06-14-2013 11:59 PM

Quote:

Originally Posted by cwizardone (Post 4972216)
Don't know what to say, but there has to be something wrong with the audio since installing the latest kernel.
:scratch:

Interesting. I'm running 32 bit -current on three units here and all is well.

volkerdi 06-15-2013 02:15 AM

Quote:

Originally Posted by cwizardone (Post 4972216)
Don't know what to say, but there has to be something wrong with the audio since installing the latest kernel.
:scratch:

Or maybe it's got something to do with "True Multilib", or some other local customization...

cwizardone 06-15-2013 09:34 AM

IIRC, "True Multilib" is how Alien BOB referred to the files.:) Other than the name, they are the "standard" multilib files, nothing customized.
:)

Edit in: Found it, first paragraph,

"This article contains instructions on how to create a true multilib Slackware64..."

http://alien.slackbook.org/dokuwiki/...kware:multilib

cwizardone 06-15-2013 11:03 AM

Well, well, well.... Seems it is considered a bug over at Redhat,

Quote:

Bug 974225 - No sound after reboot with kernel >= 3.9.5 or even on resume from kernel version > 3.8.11
https://bugzilla.redhat.com/show_bug.cgi?id=974225


All times are GMT -5. The time now is 10:50 PM.