LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-08-2004, 09:37 AM   #1
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Rep: Reputation: 0
Problem after installing Dropline GNOME 2.8


Last night, I upgraded my Slackware box from Dropline GNOME 2.6.2 to 2.8. I followed the instructions on the Dropline webpage:

installpkg dropline-installer-2.4.9-i686-1dl.tgz
dropline-installer

After it was done, it said that some changes might not take effect until I restarted, so I went ahead and restarted.

The system then booted up to the login screen--everything looks fine there. However, when I try to log in either as root or my personal account, it just goes to a grey screen and doesn't do anything. Doesn't load up.

Ideas?

edit: I also tried the "safe" GNOME mode, but got the same result.

Last edited by wasafiri; 12-08-2004 at 09:38 AM.
 
Old 12-09-2004, 03:04 PM   #2
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Original Poster
Rep: Reputation: 0
ok, here's the error message i get when i try to log into "failsafe terminal" as root:

Your session only lasted less than 10 seconds. If you have not logged out yourself, that could mean that there is some installation problem or that you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix the problem.

The ~/xsession-errors file says:

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg - a -w /var/log/wtmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "root"
xterm: Error 14, erno 21: Is a directory
Reason: spawn: open() failed on /dev/tty

What does this mean?
 
Old 12-09-2004, 06:05 PM   #3
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
did you try deleting the entire /tmp directory (including hidden files) and see if it works? Try creating a new user and see if that works.
 
Old 12-10-2004, 05:45 PM   #4
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I just tried to delete teh /tmp through Knoppix but it won't let me delete the directory, nor will it let me delete any of the files or folders in there.

I can't seem to change permissions either.

Suggestions?
 
Old 12-10-2004, 06:47 PM   #5
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
How about instead of Knoppix, you try Slackware.

Boot up to the command line. Login as root. Then:

Code:
cd /tmp
rm -r *
rm -r .*
reboot
There should be no need to change permissions.
 
Old 12-10-2004, 07:32 PM   #6
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I tried your suggestion--booted into the CL and deleted /tmp, no effect--in X, after logging in, it will show a gray screen, then the Dropline GNOME box pops up, but at that point it freezes up and doesn't load any more. I can still move the mouse around, but 10min later there's still no progress.

So I added another user in the CL. Tried logging in w/ that new user.... no dice. "Your session lasted less than 10 seconds..."

Other suggestions?
 
Old 12-10-2004, 09:00 PM   #7
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
If I remember right, when it gives that message, it also gives you a log to check. Does it? What does the log say?
 
Old 12-10-2004, 11:01 PM   #8
sh1ft
Member
 
Registered: Feb 2004
Location: Ottawa, Ontario, Can
Distribution: Slackware, ubuntu
Posts: 391

Rep: Reputation: 31
I've had this problem before with Gentoo, when I attempted to build my own firewall. What happened is somehow I was blocking loopback connections or some such. You may want to check your firewall settings (if any).

Just a suggestion if you run out of ideas.
 
Old 12-11-2004, 01:49 AM   #9
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
If I remember right, when it gives that message, it also gives you a log to check. Does it? What does the log say?
The ~/xsession-errors file says:

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg - a -w /var/log/wtmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "root"
xterm: Error 14, erno 21: Is a directory
Reason: spawn: open() failed on /dev/tty
 
Old 12-11-2004, 09:27 AM   #10
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
Mine says

Code:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "shilo"
/etc/gdm/Xsession: Beginning session setup...
I don't know why, but that second line is different, and I'm guessing that is the problem.
 
Old 12-11-2004, 02:40 PM   #11
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Original Poster
Rep: Reputation: 0
Just noticed this.

When I run linux in the command line, it shows this error message right before it prompts you for your login/password:

Eunicity login: STOPPING server from pid file /var/run/mysql/mysql.pid
041211 16:21:34 mysql ended

Welcome to Linux 2.6.9custom (tty1)

Does this help in figuring out what's wrong?
 
Old 12-11-2004, 09:05 PM   #12
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
I don't think so. It is a separate issue. If you are not using mysql, this can be solved by a simple:

Code:
chmod -x /etc/rc.d/rc.mysql
If you are needing to use mysql, read the aforementioned file or search this site for how to fix the problem. It's really easy. Here's the short version:

Code:
su mysql
mysql_install_db
exit
reboot
Either way will get rid of that message, but I don't think that is going to solve your problem.
 
Old 12-12-2004, 02:14 AM   #13
wasafiri
LQ Newbie
 
Registered: Dec 2004
Posts: 20

Original Poster
Rep: Reputation: 0
OK, well, hopefully someone else will chime in with some ideas. I can boot into KDE just fine but GNOME keeps giving me the freeze.

I tried recompiling my kernel which fixed some things, and I tried reinstalling Dropline 2.8 but neither of these actions resolved the freezing problem.
 
Old 12-12-2004, 02:57 AM   #14
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 357

Rep: Reputation: 30
What kernel are you using?

Edit:
Nevermind, I just noticed that you're using 2.6.9.

Last edited by kersten78; 12-12-2004 at 03:02 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing dropline Gnome.... anti.corp Slackware 2 12-03-2005 01:10 AM
Gnome Dropline start problem madaerodog Slackware - Installation 2 11-01-2004 03:04 AM
dropline gnome - weird problem cb951303 Slackware 2 09-02-2004 08:02 AM
Installing Dropline Gnome in Slackware 9.1 simeandrews Slackware 3 06-01-2004 09:25 PM
Keyboard problem on Dropline Gnome hydorn Slackware 7 04-29-2004 09:05 AM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration