LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-07-2004, 07:55 PM   #1
Aman9090
Member
 
Registered: Sep 2002
Location: Connecticut, USA
Distribution: Gentoo 2004.0
Posts: 174

Rep: Reputation: 30
Exclamation Printing Probs with CUPS and Slack 9.1


Hey everyone,

Just installed Slack and love it. However, I am having a bit of a printing issue. I set up my printer through CUPS with ease, and when I go to localhost:631 and do a test page print, it goes great. However, when I try to print anything else, I get this in the command line:

Code:
bash-2.05b# lp Juliet_Maturity.sxw
Status Information, attempt 1 of 3:
sending job 'root@Flybox+456' to default@localhost
 connecting to 'localhost', attempt 1
 cannot open connection to localhost - No such file or directory
Make sure the remote host supports the LPD protocol
Waiting 10 seconds before retry
I cannot print in open office, and I believe it's for the same reason!

Anyone know how to solve this? Thanks in advance!
 
Old 03-07-2004, 08:08 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
Quote:
Make sure the remote host supports the LPD protocol
try resolving this to use lp as it may be a problem, and you can try the lpr command for use with cups ...
 
Old 03-07-2004, 08:21 PM   #3
Aman9090
Member
 
Registered: Sep 2002
Location: Connecticut, USA
Distribution: Gentoo 2004.0
Posts: 174

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by DrOzz
try resolving this to use lp as it may be a problem, and you can try the lpr command for use with cups ...
Well how do I do this is basically what I am asking.

Thanks!
 
Old 03-10-2004, 03:56 AM   #4
tims1979
LQ Newbie
 
Registered: Jan 2004
Location: Reading,PA
Distribution: Linspire 4.5
Posts: 20

Rep: Reputation: 0
Quote:
Originally posted by Aman9090
Well how do I do this is basically what I am asking.

Thanks!

It sounds like you're having the same problem I did. Here is what I just did.

First open up the OpenOffice.org Printer Administration.

Then click and highlight your printer.
Then click properties.

Then under Configure there should be a text box and a command there like lpr. Change that to lpr-cups, make sure that is highlighted, then click ok. Hopefully that will work for you, it did for me.
 
Old 03-10-2004, 05:19 AM   #5
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
This problem happens because the other print services were installed together when you install Slackware.

You have to relink the symbolic link in /usr/bin as shown below:

lrwxrwxrwx 1 root root 7 Jan 16 01:07 lp -> lp-cups*
lrwxrwxrwx 1 root root 8 Jan 16 01:07 lpq -> lpq-cups*
lrwxrwxrwx 1 root root 8 Jan 16 01:07 lpr -> lpr-cups*
lrwxrwxrwx 1 root root 9 Jan 16 01:07 lprm -> lprm-cups*
lrwxrwxrwx 1 root root 11 Jan 16 01:07 lpstat -> lpstat-cups*

You can rm /usr/bin/lp
ln -s /usr/bin/lp-cups /usr/bin/lp
as example.
 
Old 03-10-2004, 05:42 AM   #6
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 759

Rep: Reputation: 65
I think I had the same experience, check this post.

Hope this might help.

Cheers, Leon.
 
Old 03-10-2004, 04:21 PM   #7
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Linux Mint 17.1
Posts: 1,424

Rep: Reputation: 137Reputation: 137
I had this problem today with open office 1.1. I went into the printer administration area, and under generic printer added

kprinter --stdin

as the command to print, rather than lpr, works fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack 10.2 / Java 1.5 / CUPS printing rhb327 Slackware 5 04-18-2006 04:36 AM
Printing Problem (cups / cups-lpd) daleman Linux - Software 3 04-08-2005 09:01 AM
CUPS several probs help plz movitto Linux - Software 6 10-18-2004 11:13 PM
remote cups printing to a smb/cups print server? justanothergeek Linux - Networking 2 09-15-2004 09:31 AM
Slackware 9 and CUPS (CUPS=crap) - printing carboncopy Slackware 21 07-29-2003 04:27 PM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration