LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-03-2010, 02:25 AM   #1
pargoo
Member
 
Registered: Jan 2007
Posts: 39

Rep: Reputation: 0
preserving feh's LXDE wallpaper between sessions


I disliked LXDE's pcmanfm so much that I've switched over to feh and idesk but for the life of me I can't get feh's wallpaper setting to stay between sessions. Typing 'feh --bg-scale /usr/share/lxde/wallpapers/lxde_blue.jpg' immediately gives me what I want, but next login it's gone again.
I know I have to put an entry in ~/home/pargoo/.config/openbox/autostart.sh but nothing works. So far I've tried:

eval `cat $HOME/.fehbg` &
eval `cat $HOME/pargoo/.fehbg` &
eval `cat ~/.fehbg` &
eval `cat ~/home/pargoo/.fehbg` &
eval $(cat ~/.fehbg &)
sh `/.fehbg` &
...all suggestions from various forum posts, and a couple of variations on top of these. What am I missing?
.
 
Old 10-03-2010, 02:53 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I don't know about LXDE, but 'sh ~/.fehbg' (with the & if necessary, though I don't believe it is, in this case) should do. You don't need any cat or backticks and definitely no eval, as the file contains a literal command.
 
Old 10-03-2010, 03:18 AM   #3
gazj
Member
 
Registered: Oct 2010
Location: Cambs, England, UK
Distribution: Slackware 14
Posts: 33

Rep: Reputation: 6
have you made the file executable.

Code:
chmod +x ~/.fehbg
 
Old 10-03-2010, 05:28 AM   #4
Perceptor
Member
 
Registered: Jul 2007
Location: the Future
Distribution: Slackware 13.37
Posts: 104

Rep: Reputation: 52
Or if you don't want to make the file executable:
Code:
$(cat ~/.fehbg)&
withou eval?
It works for me this way.

Last edited by Perceptor; 10-03-2010 at 05:29 AM. Reason: spelling
 
Old 10-05-2010, 03:12 AM   #5
pargoo
Member
 
Registered: Jan 2007
Posts: 39

Original Poster
Rep: Reputation: 0
Well, I'm utterly, utterly stumped. I've deleted and recreated everything, re-edited all the files and made ~/.fehbg executable with every entry line I can think of that doesn't involve foreign languages. Still no wallpaper although 'feh --bg-scale /usr/share/lxde/wallpapers/lxde_blue.jpg' always produces the wallpaper I want. Next login, NOTHING but grey. At present my ~/.config/autostart.sh contains this: sh `/.fehbg` &
To make matters worse, I can't even get a wallpaper to appear in Icewm! My setup is the same as my Slackware 11 one, which has always been easy. The EXACT setup on S13.1 refuses to produce the goods, but that's another story :/
Could my gtkrc-2.0 file setting transparent icon drop boxes in xfce be causing confusion???
 
Old 10-05-2010, 04:28 AM   #6
pargoo
Member
 
Registered: Jan 2007
Posts: 39

Original Poster
Rep: Reputation: 0
Update: I was sitting staring angrily at my gray/iconless Icewm screen when for no real reason I clicked on ~/.config/openbox/autostart.sh in konqueror. Bam! Suddenly I had my wallpaper AND idesk icons(!) So that script *does* work. I just don't understand how to start it at login. Help!
I'll settle for fixing this issue for the moment. If I can't nut out the other stupid feh problem I'm going to ditch it and give rox-filer a chance...
 
Old 10-05-2010, 05:43 AM   #7
bnguyen
Member
 
Registered: Jul 2010
Distribution: Slackware
Posts: 125

Rep: Reputation: 32
You didn't get the wallpaper you want simply because you command was *wrong*.

All you need to do is changing the line for setting the wallpaper in ~/.config/openbox/autostart.sh to:

sh ~/.fehbg &
 
Old 10-06-2010, 01:11 AM   #8
pargoo
Member
 
Registered: Jan 2007
Posts: 39

Original Poster
Rep: Reputation: 0
Well, sooooorta solved...
Believe me, I had sh ~/.fehbg & inserted as precisely that, both with ` *and* ' as suggested, too, and nada!
And ~/.fehbg *was* set executable. It was still being completely ignored, so I gave up. Life is too short, so I just tweaked my /etc/xdg/lxsession/LXDE/autostart file to read:

@feh --bg-scale /usr/share/lxde/wallpapers/lxde_blue.jpg
@lxde-settings-daemon
#@xscreensaver -no-splash
@lxpanel --profile LXDE
@idesk
#@pcmanfm -d

I don't care that it sets the wallpaper in stone. I'm not after any other. The default blue one looks cool enough for me. I will try your entry: <sh ~/.fehbg &> again some time in the future. I'm just tired of playing with the thing and am happy to have it working at all...
Apologies about the 'clicking on the autostart.sh in konqueror' post. My bad. Blame tiredness. It's a different issue :/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LM 9 LXDE -> Change Wallpaper ? jv2112 Linux - Newbie 8 07-27-2010 07:43 AM
[SOLVED] Resizing VirtualBox with LXDE inside doesn't restretch wallpaper mmatt Linux - Newbie 16 07-06-2010 03:35 PM
Opensuse 11.2 lxde or PclinuxOs 2009.4 lxde damipereira Linux - Distributions 1 02-16-2010 03:51 AM
Refreshing Desktop Wallpaper - Address of Wallpaper beanus Linux - Desktop 4 07-16-2007 02:57 PM
Wallpaper: SLide show wallpaper from online pictures eponymous Linux - Software 0 11-29-2004 02:28 PM


All times are GMT -5. The time now is 12:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration