LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2006, 12:43 PM   #1
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Rep: Reputation: 0
pppsetup


Sirs:

I've been using SlackWare over 6 years now and have never been able to get "pppsetup - ppp-go, ppp-off" to work. It dials and connects to my server but doesn't put me on line (give me back the connection addresses). I've tried a lot, and read all the material I can find, to no avail. Can someone help? "kppp" under GUI works fine, and"pon/poff" under Debian GUI/CLI works fine, but not "ppp-go/ppp-off". I like command line work, but it's annoying to be able to get online only via GUI. Thanks.

dbarn

Last edited by dbarn; 02-15-2006 at 12:46 PM.
 
Old 02-15-2006, 01:34 PM   #2
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
you will have to be more specific...
it has been quite a while since i've
done ppp, but iirc the documentation
was excellent.

/usr/doc/Linux-HOWTOs/PPP-HOWTO
/usr/doc/pppsetup/pppsetup-<version>.README
/usr/doc/ppp-<version>/README.linux
man pppd
etc
 
Old 02-15-2006, 03:04 PM   #3
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
pppsetup

It's not "ppp" in general, but the "pppsetup" routine that comes with Slackware distributions. I tried emailing the author, but the address was invalid. The only thing I can think of is my password - it includes a "?" (question mark) It's accwptable to "KPPP" , but it's not returned as an error in the error log. Another thing - in the blurb explaining what transpired while generating the 'setup', there's a warning that no "PPP" was found in the kernel, nor as a module. But "dmesg" shows it as in the kernel (I changed the "ppp"for the kernel from the original'M' for module to '*' for inbuilt). When I read the literature, it says the program is looking for "PPP" at a place different from where my "dmesg" says it is. They (the author) says it's expewcted in "/usr/lib/mosules/(kernel version)/net", but in my Slackware theres no "/net" _directly_ under "/usr/lib/(kernel-version)". I don't know if that's the problem, but I dont know how to fix it if it is. The dearch is done via a "grep" in the "pppsetup" program in "/usr/sbin". I've tried enclosing the password in single and double quotes, to try to get around the password if that's the problem, but I don't think it is.

I don't know how much more specificity is needed, or in what direction to try, bu i will try if you can suggest anything.

Thanks.

dbarn
 
Old 02-15-2006, 08:32 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I have had similar experiences with ppp. No issues with KPPP. I don't know if this will help, but here is my ppp options config file. IIRC, I had to manually add my ISP user name to the options file and then ppp-go worked.

asyncmap 0
noauth
crtscts
lock
modem
noipdefault
passive
debug
defaultroute
/dev/modem
115200
name "username" <- replace username with your actual ISP login name
 
Old 02-15-2006, 08:54 PM   #5
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,605

Rep: Reputation: 142Reputation: 142
The main problem with pppsetup is that it doesn't configure DHCP. Almost everyone is running into this, because most people have dynamic IP addresses.

There's a workaround, however: Use gnashley's script ispsetup. You can download it from the Amigo Linux homepage:

http://distro.ibiblio.org/pub/linux/...nload/scripts/

And, BTW, Amigo Linux is a very interesting technical effort, by itself. Probably the smallest Slackware based Linux distro outthere.

gargamel
 
Old 02-16-2006, 09:14 AM   #6
ludist
Member
 
Registered: Nov 2005
Location: Greece
Distribution: Slackware
Posts: 129

Rep: Reputation: 16
Quote:
Originally Posted by dbarn
Sirs:

I've been using SlackWare over 6 years now and have never been able to get "pppsetup - ppp-go, ppp-off" to work. It dials and connects to my server but doesn't put me on line (give me back the connection addresses). I've tried a lot, and read all the material I can find, to no avail. Can someone help? "kppp" under GUI works fine, and"pon/poff" under Debian GUI/CLI works fine, but not "ppp-go/ppp-off". I like command line work, but it's annoying to be able to get online only via GUI. Thanks.

dbarn
I also have been in problems. Solved after I insterted those lines in
/etc/resolv.conf. I think you need this if you are not in DHCP, if I undestood you problem.

search 'MyISP'
nameserver xxx.xxx.xxx.xxx > ask your ISP
nameserver xxx.xxx.yyy.yyy
 
Old 02-16-2006, 03:48 PM   #7
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
The main problem with pppsetup is that it doesn't configure DHCP. Almost everyone is running into this, because most people have dynamic IP addresses.
Seems ppp needs some serious updating then. The ppp code also will not override any default gateway in the routing table, a serious flaw IMO. I had to write a special script to delete the LAN default gateway in order for my box to connect to the web via ppp. And that also meant modifying the firewall rules on the fly too. All because of this one glitch.

Quote:
I also have been in problems. Solved after I instated those lines in /etc/resolv.conf.
I concur. KPPP will dynamically add the ISP DNS servers to /etc/resolv.conf, but ppp maintains its own separate resolv.conf (located in /etc/ppp). Additionally, if the box is connected to a LAN, that box needs to know where to resolve domain names and the box serving as the LAN gateway might not be providing DNS services in that respect. FWIW, my /etc/resolv.conf looks like this:

# resolv.conf: used to resolve DNS server look-ups
# first query this computer's hosts file
search localhost

# then search this computer for a caching nameserver
nameserver 127.0.0.1

# then query local network server
# nameserver 192.168.1.xx

# then query outside DNS servers, usually automatically assigned by ISP
# list the nameservers even if assigned dynamically as they are needed
# for boxes on a LAN accessing a common gateway
nameserver 12.34.56.xx
nameserver 12.34.56.yy
 
Old 02-17-2006, 10:35 AM   #8
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks All:

I've tried the one suggestion referring to "ispsetup" and, after commenting out "rm -f /etc/resolv.conf" in the newly created "/etc/ppp/ip-down" file, and initializing "/etc/resolv.conf" to my known nameservers, things are working. I can't proprly shut down the "GUI kppp" connection from a "ctrl-alt-f2....ppp-off" command, but it can be corrected by shutting down properly from the GUI.Thanks again to all. I feel that refrence to a '_symbolic_link_' removal in the file '/etc/ppp/ip-down' isn't quite correct, especially the "symbolic" part, but the I'm not a Guru.

I'm not sure I know how to remove my original question, but I'm going to try.

Thanks, again.

dbarn
 
Old 02-17-2006, 04:18 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
When you start KPPP you should see an icon in your Kicker system tray. From that icon you can terminate KPPP and your dialup connection. If you do not see that icon then verify your KPPP configuration options.

From the command line you can terminate KPPP using kppp -k. If that command fails then try kill -9 $KPPP_PID, where $KPPP_PID is the process ID (PID) of KPP (KPPP_PID=`/sbin/pidof kppp`).
 
Old 02-19-2006, 06:03 AM   #10
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,605

Rep: Reputation: 142Reputation: 142
Hmmm. In my experience you don't need ispsetup when you use KPPP, actually. The modifications you did were obviously only necessary, because the two solutions interfere. But you may have found a more general solution that way, which allows users on your machine use different window managers and desktops and still be able to connect to the internet in different ways.

So let us know: Can you dial-up from non-KDE environments, without KPPP, now?

gargamel
 
Old 02-19-2006, 08:13 AM   #11
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Gargamel,

YES - I can dial-up from non-KDE (i.e command-lina on ctrl-alt-f2, 3, 4, etc., and it holds after switching back to KDE. I thiought I explained that, but my command of computer nomenclature isn't too good, I guess. Tho _ONLY_ thing I cannot do is - if I start "kppp" under GUI, I can't shut it down via "ppp-off" under a command-line "ctrl-alt f2" environment. The "CS" lamp next to the "ARQ/FAX" lamp on my 'Robotics' external modem remains lit, along with the "ARQ/FAX" lamp itself, the others going 'out.' On returning to the KDE environment, via "alt-f7', I can completely disconnect via the 'kppp' 'disconnect'command in the 'kppp' dialogue box in the task bar. I'm glad yo asked me to 'let us know' as I've felt that, since it's been a bug for me for a long time, and via your statements, for many others, I wanted to pass on the info., but the system to do so @ this web site is a bit fuzzy to me.

Thanks again for the 'steerage.'

dbarn
 
Old 02-19-2006, 05:02 PM   #12
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Gargamel,

In my last post-reply I notice that I forgot to mention that after I had gone to the tty2 CLI via "ctrl-alt-f2", run "ispsetup", altered "/etc/ppp/ppp-down", and initialized "/etc/resolv.conf" to my 2 known namserver addresses, before it worked, I had to return to the XFCE4 GUI and start/stop "KPPP", and then return via "ctrl-alt-f2" to the CLI. Then it worked. Also, as I recall, when I did the same sequence from a "reboot" (I use runlevel 3, _not_ the GUI runlevel 4), I didn't have to go to GUI and start/stop "KPPP," it worked right off the bat. (There's probably a clue there?)

dbarn
 
Old 02-21-2006, 12:06 PM   #13
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
It's usually not good to mix usage and configuration of pppsetup/ispsetup and kppp -kppp does it's own thing.

pppsetup only sets up static DNS addresses. They are stored in /etc/resolv.conf
Note that when pppd is run, if /etc/resolv.conf exists, then pppd will try to use it.

ispsetup is pppsetup which has been hacked to write config files which allow dynamic DNS addresses with pppd. If 'usepeerdns' is in your /etc/ppp/options file(done by ispsetup), then pppd will *generate* the /etc/ppp/resolv.conf file when the connection is established.
A link gets created(ispsetup) to it from /etc/resolv.conf since that's where other programs will usually look for it.
They all must be removed before trying to re-establish the connection since you are asking it to do it dynamically.
BTW ppp-on and ppp-off are the best names to use for calling it, not ppp-go,etc.

A symbolic link(ln -s) as opposed to hard link -read 'man ln'
 
Old 02-21-2006, 04:00 PM   #14
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
pppsetup

gnashly

Sir,

All you say may be quite true, but what I said and did works for me, and I only thought it might work for others. I'm not a Linux "Geek", so all you say may well be correct. 20-30 years ago I used to be a "PDP-11 assembly language geek" in 'Process Control' but that was before I retired.

Upon connection the following appears:

connect: ppp0 <--> /dev/modem
local IP address 216.107.***.***
remote IP address 216.107.***.***
Primary NSA address 216.107.*.*
Secondary NSA address 216.107.*.**

"pppsetup" & "ispsetup" both give (only)
'connect ppp0 <--> /dev/modem' when neither is modified.

No amount of modification (my attempts, at any rate) permits "pppsetup" to work.

That's all I can say.

dbarn
 
Old 02-22-2006, 11:56 AM   #15
dbarn
LQ Newbie
 
Registered: Dec 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Sirs:

The following sequence has worked for me _every_ time (well, 11 in a row)

1. Reboot

2. Check for existence of "/etc/resolv.conf"

a. If not - edit/create "/etc/resolv.conf" per se"

nameserver ***.***.***.xxx
nameserver ***.***.***.yyy

3. Start GUI (I boot up under CLI, i.e. Default run-level = 3)

4. Run "kppp"

5. Stop "kppp"

6. Exit GUI

7. Run "ispsetup"

8. Edit "/etc/ppp/ip-down" by commenting OUT the line 'rm -f /etc/resolv.conf.'

9. Test "ppp-on" (I use "ftp ftp.gnu.org" following presentation of 'nameserver addresses)

10. Test "ppp-off"

__FINIS__ - Works every time tested for me.

dbarn
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with pppsetup somnambulist Linux - Software 1 02-22-2006 02:50 PM
DNS nameserver issue - pppsetup the_rydster Slackware 2 03-04-2004 09:09 AM
pppsetup v. KPPP in dial-up use rich442 Slackware 7 04-15-2003 07:27 PM
kppp and pppsetup in Slackware hkslacker Slackware 4 02-11-2003 11:29 AM
pppsetup php Linux - General 3 12-30-2001 02:40 PM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration