LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2003, 02:53 PM   #1
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
Question PPP Support and Kernel Source Question


Hello again everyone.

I am back from my vacation and ready to start tinkering with Slackware again. For those who don't know my current situation, I have Slackware 9.0 installed successfully, but I realized that I do not have PPP support enabled (ppp-go gives me an error message). I tried many different things including downloading a newer kernel and compiling that but that just created more problems. I finally went ahead and downloaded the kernel source from the K directory on the Slackware FTP site and put that into my /usr/src directory.

My question now is... what is the next step? I tried make oldconfig, then make menuconfig to make sure everything was enabled (i.e. PPP), then make dep, make modules, make modules_install, make bzImage. I put the kernel image in /boot, set it up in LILO, and tried booting to it. When I tried to start Linux in that kernel, I got a blank, black screen. The system still worked (i.e. I could ctrl-alt-del to restart it once I got in), but the screen stayed blank. However, going back to my old, original, vmlinuz image, I noticed that now all my USB devices are being seen on startup (something that didn't happen before I downloaded the K kernel source and did the make menuconfig, etc.) I'd like to keep my display visible as well as my screen as it is with the Penguin and smaller text size (something that I wasn't able to get in the many times I tried compiling other kernels). Is there some way I can compile PPP as a module and install it without recompiling the entire kernel and pointing LILO to another file? 'insmod ppp' says that the module doesn't exist as well as the modprobe command that the error message for ppp-go told me to type. Any help is appreciated.

Thanks,
JMagi
 
Old 07-21-2003, 05:30 AM   #2
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
PPP in Slack 9

I use ppp-go in Slack 9, it worked from the default installation. Have you run ppp-setup? This should create the necessary scripts for you to dial up with ppp...

Sorry I can't be of more help, but if you can give me some more specific information?

munkeh
 
Old 07-21-2003, 06:22 AM   #3
Noryungi
Member
 
Registered: Jul 2003
Location: --> X <-- You are here.
Distribution: Slackware
Posts: 262

Rep: Reputation: 30
Yes, you should definitely use pppsetup to configure your ppp connection. This is a very simple utility and it worked every time for me...

More information on the Slackware site:

http://www.slackware.com/book/index....rce=x1100.html
 
Old 07-21-2003, 06:25 PM   #4
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
I went through pppsetup many times and entered in all the information and ppp-go still gives me the same error. When I type modprobe pppd (or whatever it tells you to do in the error message, I'm not on Linux now...) it tells me the modules doesn't exist or wasn't installed. Any reason why its not working for me? If you want the whole text of the error message I can get on the other computer and type it up.

-JMagi
 
Old 07-22-2003, 06:48 AM   #5
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
ppp in slackware

Quote:
Originally posted by JMagi
I went through pppsetup many times and entered in all the information and ppp-go still gives me the same error. When I type modprobe pppd (or whatever it tells you to do in the error message, I'm not on Linux now...) it tells me the modules doesn't exist or wasn't installed. Any reason why its not working for me? If you want the whole text of the error message I can get on the other computer and type it up.

-JMagi
Firstly we need to ascertain if you have ppp set up as a module, or compiled into the kernel. You can find this out by looking in the kernel config file in /boot, use:

grep -i ppp /boot/[name of config file]

Hopefully they are installed as modules, I think this is the better option. Check they are loaded with lsmod. If not, use modprobe to insert them. If you are unsure of the exact name of the modules, look in /lib/modules/2.4.20[or your current source]/kernel/drivers/net where there are a number of ppp modules.

depmod -a and you should be in business. I got pppsetup to work from a default install, all the modules are present if you have a standard Slackware 9 installation.

Are you trying this as root? Unless you change the permissions on pppd then normal users won't be able to run ppp-go. Any error messages would be helpful :-)
 
Old 07-22-2003, 08:06 PM   #6
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Thank you for your detailed reply. First of all, yes I am running the commands as root, yes I did a standard Slackware 9 install without doing anything special, and yes I ran pppsetup several times. I have no idea why its acting this way, I must have done something wrong somewhere along the way.

One thing at a time...

1. grep -i ppp /boot/config-ide-2.4.20 gives me:
CONFIG_PPP=m
# CONFIG_PPP_MULTILINK is not set
# CONFIG_PPP_FILTER is not set
CONFIG_PPP_ASYNC=m
CONFIG_PPP_SYNC_TTY=m
CONFIG_PPP_DEFLATE=m
CONFIG_PPP_BSDCOMP=m
CONFIG_PPPOE=m
CONFIG_SYNCLINK_SYNCPPP=m
# CONFIG_HDLC_PPP is not set
CONFIG_WANPIPE_PPP=y
# CONFIG_WANPIPE_MULTPPP is not set
CONFIG_ISDN_PPP=y
CONFIG_ISDN_PPP_VJ=y
CONFIG_ISDN_PPP_BSDCOMP=m

I assume from this that the things I need are installed as modules.

2. lsmod gives me:
uhci
usbcore
via-rhine
mii
pcmcia_core
ide-scsi

I assume from this that the module ppp is not installed.

3. modprobe ppp gives me:
modprobe: Can't locate module ppp

Note: Same message for modprobe pppd

4. I looked in /lib/modules/2.4.20/kernel/drivers/net and I do not see anything that resembles ppp. All the p's are:
pcmcia/
pcnet32.o
plip.o
ppp_deflate.o
ppp_synctty.o

modprobe/insmod for the two ppp entries above give errors and say that the module could not be inserted.

5. When I type pppsetup, I get the screen and can go through and reconfigure everything. When I type ppp-go, I get the following error message:
/usr/sbin/pppd: This system lacks kernel support for PPP. This could be because the kernel PPP module could not be loaded, or because PPP was not included in the kernel configuration. If PPP was included as a module, try '/sbin/modprobe -v ppp'. If that fails, check that ppp.o exists in /lib/modules/`uname -r`/net. See README.linux file in the ppp distribution for more details.

As I stated above, /sbin/modprobe -v ppp gives me:
modprobe: Can't locate module ppp

When I type cd /lib/modules/`uname -r`/net it tells me that /lib/modules/2.4.20/net is not a valid folder.

Any ideas? This seems like a pretty weird situation to me. I appreciate all your help so far...

-JMagi
 
Old 07-23-2003, 03:43 AM   #7
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
Quote:
1. grep -i ppp /boot/config-ide-2.4.20 gives me:
CONFIG_PPP=m
# CONFIG_PPP_MULTILINK is not set
# CONFIG_PPP_FILTER is not set
CONFIG_PPP_ASYNC=m
CONFIG_PPP_SYNC_TTY=m
CONFIG_PPP_DEFLATE=m
CONFIG_PPP_BSDCOMP=m

I assume from this that the things I need are installed as modules.
Yes, thats right :-)

Quote:
3. modprobe ppp gives me:
modprobe: Can't locate module ppp
There is no ppp module. I seem to recall (I am sat at work now) that the ppp module is actually called ppp_generic. Try a 'modprobe ppp_generic' and this should work. I would also make sure the ppp_async, ppp_deflate, ppp_sync_tty and ppp_deflate are loaded. I don't think you need all of them but if you get them all in you'll eliminate any doubt.

Quote:
Note: Same message for modprobe pppd
pppd is the ppp daemon, not a module. pppd is the program started by ppp-go.

Quote:
4. I looked in /lib/modules/2.4.20/kernel/drivers/net and I do not see anything that resembles ppp. All the p's are:
pcmcia/
pcnet32.o
plip.o
ppp_deflate.o
ppp_synctty.o
If there is no ppp_generic in there, then it looks like the module is missing! I think if you recompile the standard kernel, this should recreate your modules. I think you can recompile kernel modules without replacing the whole kernel, or you may even be able to download them.

Quote:
modprobe/insmod for the two ppp entries above give errors and say that the module could not be inserted.
No, they need ppp_generic as far as I recall.

Quote:
5. When I type pppsetup, I get the screen and can go through and reconfigure everything. When I type ppp-go, I get the following error message:
/usr/sbin/pppd: This system lacks kernel support for PPP. This could be because the kernel PPP module could not be loaded, or because PPP was not included in the kernel configuration. If PPP was included as a module, try '/sbin/modprobe -v ppp'. If that fails, check that ppp.o exists in /lib/modules/`uname -r`/net. See README.linux file in the ppp distribution for more details.
I think pppsetup must be a little out of date, or more up to date than 2.4.20, as there is no ppp.o

Quote:
When I type cd /lib/modules/`uname -r`/net it tells me that /lib/modules/2.4.20/net is not a valid folder.
No, it isn't! The correct folder is /lib/modules/2.4.20/kernel/drivers/net

Quote:
Any ideas? This seems like a pretty weird situation to me. I appreciate all your help so far...

-JMagi
No problem, happy to help. For whatever reason, your ppp_generic module seems to have wandered off! I think you have been a little thrown by the messages from pppsetup. If you can recompile/beg/borrow/steal the ppp_generic module I am sure everything will work.

munkeh
 
Old 07-23-2003, 10:33 PM   #8
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Thank you once again for your assistance. I looked around and could not find ppp_generic.o anywhere online or in the kernel source that I downloaded (since its not included with Slack 9). However, I tried to get the modules installed somwhere by going to the source directory and doing 'make oldconfig' then 'make menuconfig' and setting all the PPP options to modules. Then I did 'make modules' and, sure enough, ppp_generic.o showed up. 'modprobe ppp' failed with a bunch of errors about slhc. I tried 'modprobe slhc' 'modprobe ppp_generic' and 'modprobe ppp_async' and they all loaded successfully. lsmod listed them all as being in there and ppp-go gave me a different error message this time (getting to that). Before I get into my next problem, how do I automatically make the kernel do 'modprobe slhc && modprobe ppp_generic && modprobe ppp_async' every time it starts. I went into Windows and when I rebooted and went back into Linux I had to re-modprobe the modules to get them back in. I looked at my /etc/modules.conf file and it was empty. It would be nice if I figured out how to do this.

Ok, so ppp works, on to my next problem. I tried pppsetup and confirmed that all the information was correct one more time. My modem (which is listed as 'Hardware Modem - Will work for Linux' in big letters on the front) is listed in Windows as being in COM4. I made sure that I was doing /dev/ttys3 (I forget the exact syntax but I did whatever corresponds to COM4). Then I tried ppp-go. The computer pauses for a second or two, then gives me:
Connect script failed.

I then went into Fluxbox and ran kppp. I deleted my current account and recreated it once again making sure I had the right modem set up and all the numbers were right and I tried to connect. I get the message 'The modem is busy.' I tried selecting the right modem again and clicking on 'Query Modem...' and again I got 'The modem is busy.' I restarted the computer entirely just in case the modem had got messed up somehow and I get the same errors in the shell and in X. Any ideas as to what is causing this.

Again thank you,
JMagi
 
Old 07-24-2003, 07:41 AM   #9
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
Quote:
Originally posted by JMagi
Before I get into my next problem, how do I automatically make the kernel do 'modprobe slhc && modprobe ppp_generic && modprobe ppp_async' every time it starts. I went into Windows and when I rebooted and went back into Linux I had to re-modprobe the modules to get them back in. I looked at my /etc/modules.conf file and it was empty. It would be nice if I figured out how to do this.
If you look in /etc/rc.d/rc.modules, the ppp modules should all be listed in there. Remove the #'s for the modules you want to load. Any that aren't there, either add to /etc/rc.d/rc.modules or /etc/rc.d/rc.local if you want to keep rc.modules as it is. Use:-

/sbin/modprobe ppp_[whatever]

Quote:
Ok, so ppp works, on to my next problem. I tried pppsetup and confirmed that all the information was correct one more time. My modem (which is listed as 'Hardware Modem - Will work for Linux' in big letters on the front) is listed in Windows as being in COM4. I made sure that I was doing /dev/ttys3 (I forget the exact syntax but I did whatever corresponds to COM4). Then I tried ppp-go. The computer pauses for a second or two, then gives me:
Connect script failed.
If you are sure that your modem is connected to COM4, or /dev/ttyS3, make (or edit) /dev/modem to be a symbolic link to /dev/ttyS3 by doing

ln -s /dev/ttyS3 /dev/modem

Then refer to /dev/modem in your scripts. Now that you have the ppp modules installed, if you can't query the modem, then it must be that linux can't find it. Try plugging your modem serial cable into the first serial port in your PC, and try linking /dev/modem to /dev/ttyS0. This is how I have mine set up and it works like a dream. I found Minicom very helpful in testing out my modem, but don't use the initialization strings Minicom gives you in pppsetup; this prevented mine from working. Just stick with the default string offered by pppsetup. Nearly there now!
 
Old 07-24-2003, 06:35 PM   #10
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Ok, we are getting there. I tried to uncomment the lines in /etc/rc.d/rc.modules that provided ppp module support and rebooted, but lsmod showed that the modules were not added. I then realized that in the past I needed to 'modprobe slhc' for the others to work so I stuck that line in the file and rebooted but the modules still did not load. I finally put back all the comments, got rid of my slhc line, and added '/sbin/modprobe' slhc, ppp_generic, and ppp_async lines in my /etc/rc.d/rc.local and they loaded when I rebooted. Still not sure why the other one didn't work but at least they are now loading on bootup.

When I tried ln -s /dev/ttys3 /dev/modem it tells me that /dev/modem already exists. I checked /dev/modem by typing 'ls -l /dev/modem' and it showed me that
/dev/modem -> /dev/ttys3. I then went to my /etc/ppp/pppsetup.txt file and changed /dev/ttys3 to /dev/modem and it still says 'Connect script failed' when I try to logon. My modem is actually a PCI card, not an external serial modem. I go to the Modems control panel in windows and it lists the name of my modem under COM4. Should I try removing it as COM4 and replacing it as COM1 within windows (I'm not sure if it even lets you do this) and then try it in Linux. It seems to me that it should still work since all we're doing with this /dev/modem stuff is changing what looks to what but, in the end, ppp-go is always looking at /dev/ttys3 no matter what route it takes. Any more ideas?

Thanks again,
JMagi
 
Old 07-25-2003, 03:13 AM   #11
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
Linux and PCI Modems!!!

Ah, if you had told me you had a PCI modem at the start, I could of told you it wasn't very likely to work! There are some PCI modems which work in linux, but not very many. You will be much better off going out and buying an external serial modem (NOT a USB one) and using that. If its an internal modem you are trying to get to work I'm afraid I can't help.

This is most likely your best resource:-

http://www.linmodems.org

BTW, when you tried to create the link, it told you there was already a link. Delete it. You can then create the link again. Also, the correct name for your serial ports is /dev/ttyS* where S is a capital and * is a number.

Well you may not have got your modem working, but at least you've learned a lot on the way :-)

munkeh
 
Old 07-25-2003, 08:55 AM   #12
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
I'll try deleting and recreating the link. However, I already went through this problem before with a PCI modem that was a Winmodem. This time when I went out to buy another modem I specifically wanted one that would work under Linux. As I said, the box told me it was a "Hardware Modem - Will work under Linux" on a big yellow sticker on the front of the box. You're not telling me it can still be a Winmodem are you? Actually, now that I think about it, I did get online with Linux at one point in time and it can't have been with the old modem. I'm pretty sure it was using this modem when I still have Slack 8.3 (I deleted the whole partition when I upgraded because I had a bunch of junk lying around). Any other suggestions?

-JMagi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian kernel, isdn and ppp support chickuaua Linux - Networking 4 07-28-2005 03:55 AM
kernel does not support ppp filtering? l2g Slackware 11 04-30-2004 06:27 AM
Kernel 2.4.20 + ppp support Gayle Linux - General 13 01-05-2003 05:16 PM
Kernel with ppp support? mystiqa Linux - Newbie 1 06-17-2001 03:01 AM
no vfat or PPP support after kernel compile rdaves@earthlink.net Linux - Newbie 1 06-11-2001 09:52 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration