LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-04-2004, 08:40 AM   #1
gescom
LQ Newbie
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware 12.1
Posts: 25

Rep: Reputation: 15
ppp dialup problem for users


I connect to the net via an external 56k serial modem.

My problem (besides using dialup ) is that a user connects to the internet ok, its just that while connected firefox and other apps refuse to see the connection or load any pages.

Logging out and restarting gnome as root gives me no troubles loading pages in firefox.


Not sure if this is related but I originally could not run ppp-go as a user (non-root) so did the following after reading from a forums search:

Quote:
to runn commands as root without having to logout and back in use 'sudo'
just type 'sudo /usr/sbin/pppsetup'
However, you'll find that pppsetup will not give permission for users to dial out. You'll have to chmod some files after running pppsetup.
chmod 6755 /usr/sbin/ppp-on, ppp-go, ppp-off, ppp-stop, and pppd
Then chmod 644 /etc/ppp/options and /etc/ppp/pppscript
and chmod 600 /etc/ppp/pap-secrets or (chap-secrets)
This should let users dial out without sudo-ing.
By using chmod 6755 on pppd and co I was able to execute them as a normal user. I then created a link to ppp-go and put it in /usr/local/bin. Starts and connects, problem solved so I thought.

Also just a quick question about the '4digit' chmod 6755 command. I noticed it gave -rwsr-sr-x permissions? What does the 's' stand for?

Thanks
 
Old 08-04-2004, 09:02 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
s= SUID=set user ID
I'll bet you need dynamic DNS, which pppsetup doesn't have. Try going to my site to downloads/scripts and grab ispsetup. it's a hacked pppsetup that does dns and easier to setup too.
www.amigolinux.org
 
Old 08-04-2004, 09:58 AM   #3
insyte
Member
 
Registered: Jul 2004
Distribution: Slackware Current
Posts: 307

Rep: Reputation: 30
try using kppp
 
Old 08-04-2004, 11:56 AM   #4
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Rep: Reputation: 31
I went to www.amigolinux.org, tried to download the ispsetup script, and got this:

Not Found
The requested URL /download/scripts/ispsetup1.2 was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.29 Server at amigolinux.org Port 80
 
Old 08-04-2004, 01:33 PM   #5
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Thanks for the broken-link report. Are you using KDE or gnome?
 
Old 08-04-2004, 06:00 PM   #6
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Rep: Reputation: 31
You're welcome.
I'm using KDE.
 
Old 08-05-2004, 11:51 AM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
You should be able to get ispsetup1.2 now.
But, if you are using KDE why not use kppp? To use kppp you shouldn't configure pppsetup at all. In fact you'll need to clean out /etc/ppp some probably, to get it to worl now. try removing all files in /etc/ppp then reinstall the ppp pkg and KDE base or admin or whichever has kppp. the ppp pkg installs only an example options file in /etc/ppp (before RUNNING pppsetup)
I held on to using KDE for a long time just because of kpackage and kppp. Finally I studied how to set up dynDNS and hacked pppsetup to do that using PAP. it only asks for phone#, username, password, modem speed and port.
I think I never once browsed with Konqueror, I was having the same problems as you, but since I was on an old 120MHz machine with 32MB RAM Konqueror took about a minute to start so I switched to using opera which is great and worked without problems.
So, if using kppp, install ppp pkg but don't run pppsetup.
And if using pppsetup or my ispsetup then connect with ppp-on
BTW ispsetup sets up permissions by default allowing users to dial up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ppp dialup problem cch2cch Linux - Software 0 04-10-2005 03:15 PM
ppp dialup dns problem (Slackware 9.1) johnMG Linux - Networking 8 05-06-2004 11:09 AM
ppp dialup problems neo_nirvane Slackware 13 10-28-2003 05:00 PM
PPP dialup problem Xreagan Linux - Networking 8 02-20-2003 02:47 PM
ppp dialup problem xiefs Linux - General 4 05-27-2002 05:55 AM


All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration