LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-31-2013, 07:59 AM   #1
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,529

Rep: Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708
Postfix, Dovecot & Thunderbird vs. firewall + Squid proxy


Hi,

I'm running an IMAP mail server on a root server with Slackware64 14.0, with Postfix and Dovecot. There's no webmail system installed, since all users are expected to use Thunderbird (available for Linux, Windows and Mac OS X).

On most machines, everything runs fine, which means I can configure accounts OK, and users can send and receive mails. Here's how folks are supposed to configure Thunderbird for incoming mail:
  • Port: 993
  • Security: SSL/TLS
  • Authentication: normal password

And for sending mail:
  • Port: 25
  • Security: STARTTLS
  • Authentication: normal password

The server uses a self-signed certificate dovecot.pem.

Curiously enough, on some of the client machines, users can't seem to configure their account. Reception works well, but when they want to send mail, Thunderbird keeps trying to connect to the mail server, in vain.

I don't have the slightest idea why this is so. Now I vaguely wonder if this problem is either related to the firewall or proxy settings.

As far as I understand, the only ports I have to open are 25 and 993 on the server. And that's it. Nothing on the client side. Correct me if I'm wrong.

I'm also using a Squid+SquidGuard proxy on the local server which acts as a gateway. In theory this shouldn't interfere, since only requests to the HTTP port (80) are redirected to port 3128, to be handled by Squid.

Any idea what's going on here?

Niki
 
Old 07-31-2013, 08:11 AM   #2
gezley
Member
 
Registered: Sep 2009
Location: Ireland
Distribution: Slackware64, NetBSD
Posts: 495

Rep: Reputation: 207Reputation: 207Reputation: 207
In master.cf you should configure Postfix to accept mail from email clients on the submission port, which is 587. Leave port 25 for MX between MTAs only. It is possible some of your customers have ISPs who block port 25 to combat spam.

Last edited by gezley; 07-31-2013 at 08:16 AM.
 
2 members found this post helpful.
Old 07-31-2013, 09:16 AM   #3
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,436
Blog Entries: 11

Rep: Reputation: 181Reputation: 181
Or maybe those few clients have a proxy setting on their machines. I know that thunderbird can use specific proxy settings or use the system default (what ever that is).
Nother thing might be the self singed cert. Get the certificate downloaded and add an exception.
 
Old 08-20-2013, 05:43 AM   #4
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: ElementaryOS, Ubuntu LTS, Slackware
Posts: 1,529

Original Poster
Rep: Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708Reputation: 708
Quote:
Originally Posted by gezley View Post
In master.cf you should configure Postfix to accept mail from email clients on the submission port, which is 587. Leave port 25 for MX between MTAs only. It is possible some of your customers have ISPs who block port 25 to combat spam.
Sorry for the late answer, but I just found the time to experiment with this now. I did what you suggested and reconfigured Postfix to use port 587 for sending mail.

It works. You're a star. Thank you very much.

Niki
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix+mysql+dovecot mail server thunderbird clinet configuration issue Vimuth Linux - Newbie 2 01-01-2013 04:17 AM
Pulling in cronjobs with thunderbird, using postfix and dovecot Leseguenni Linux - Newbie 0 01-05-2010 09:38 AM
Postfix, Dovecot, SASL - problem with authentication in Thunderbird / Outlook dlugasx Linux - Server 2 11-19-2009 02:31 AM
postfix, dovecot - setup for Thunderbird with SASL - how ? dlugasx Linux - Server 0 11-11-2009 06:46 AM
Postfix/Dovecot - thunderbird queries server fine but finds no mail sneakyimp Linux - Server 1 10-24-2007 07:15 PM


All times are GMT -5. The time now is 02:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration