LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Postfix, Dovecot & Thunderbird vs. firewall + Squid proxy (http://www.linuxquestions.org/questions/slackware-14/postfix-dovecot-and-thunderbird-vs-firewall-squid-proxy-4175471598/)

kikinovak 07-31-2013 07:59 AM

Postfix, Dovecot & Thunderbird vs. firewall + Squid proxy
 
Hi,

I'm running an IMAP mail server on a root server with Slackware64 14.0, with Postfix and Dovecot. There's no webmail system installed, since all users are expected to use Thunderbird (available for Linux, Windows and Mac OS X).

On most machines, everything runs fine, which means I can configure accounts OK, and users can send and receive mails. Here's how folks are supposed to configure Thunderbird for incoming mail:
  • Port: 993
  • Security: SSL/TLS
  • Authentication: normal password

And for sending mail:
  • Port: 25
  • Security: STARTTLS
  • Authentication: normal password

The server uses a self-signed certificate dovecot.pem.

Curiously enough, on some of the client machines, users can't seem to configure their account. Reception works well, but when they want to send mail, Thunderbird keeps trying to connect to the mail server, in vain.

I don't have the slightest idea why this is so. Now I vaguely wonder if this problem is either related to the firewall or proxy settings.

As far as I understand, the only ports I have to open are 25 and 993 on the server. And that's it. Nothing on the client side. Correct me if I'm wrong.

I'm also using a Squid+SquidGuard proxy on the local server which acts as a gateway. In theory this shouldn't interfere, since only requests to the HTTP port (80) are redirected to port 3128, to be handled by Squid.

Any idea what's going on here?

Niki

gezley 07-31-2013 08:11 AM

In master.cf you should configure Postfix to accept mail from email clients on the submission port, which is 587. Leave port 25 for MX between MTAs only. It is possible some of your customers have ISPs who block port 25 to combat spam.

zhjim 07-31-2013 09:16 AM

Or maybe those few clients have a proxy setting on their machines. I know that thunderbird can use specific proxy settings or use the system default (what ever that is).
Nother thing might be the self singed cert. Get the certificate downloaded and add an exception.

kikinovak 08-20-2013 05:43 AM

Quote:

Originally Posted by gezley (Post 5000232)
In master.cf you should configure Postfix to accept mail from email clients on the submission port, which is 587. Leave port 25 for MX between MTAs only. It is possible some of your customers have ISPs who block port 25 to combat spam.

Sorry for the late answer, but I just found the time to experiment with this now. I did what you suggested and reconfigured Postfix to use port 587 for sending mail.

It works. You're a star. Thank you very much.

Niki


All times are GMT -5. The time now is 02:24 AM.