LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2005, 08:23 AM   #1
GATTACA
Member
 
Registered: Feb 2002
Location: USA
Distribution: Fedora, CENTOS
Posts: 201

Rep: Reputation: 32
Post KDE 3.4.1 compile annoying kate messages


Hello.

I've compiled KDE 3.4.1 from source. I followed the development instructions from KDE's website (make new user kdevel, etc..).


The compile went relatively smoothly, no problems at all. However, whenever I'm in a console and I type say: "kate textfile.txt" I get a bunch of warnings scrolling across the screen. Here is an example of the text I'm talking about:
----------------------------------------------------------------------------------------------------
kate: Inserted command:exttool-runscript
kate: Inserted command:exttool-google-selection
kio (KSycoca): Trying to open ksycoca from /var/tmp/kdecache-dfermin/ksycoca
kio (KTrader): query for KTextEditor/Plugin : returning 4 offers
kio (KDirWatch): Available methods: Stat
kate: Inserted command:indent
kate: Inserted command:unindent
kate: Inserted command:cleanindent
kate: Inserted command:comment
kate: Inserted command:uncomment
kate: Inserted command:goto
kate: Inserted command:kill-line
kate: Inserted command:set-tab-width
kate: Inserted command:set-replace-tabs
kate: Inserted command:set-show-tabs
kate: Inserted command:set-remove-trailing-space
kate: Inserted command:set-indent-spaces
kate: Inserted command:set-indent-width
kate: Inserted command:set-mixed-indent
kate: Inserted command:set-indent-mode
kate: Inserted command:set-auto-indent
kate: Inserted command:set-line-numbers
kate: Inserted command:set-folding-markers
kate: Inserted command:set-icon-border
kate: Inserted command:set-word-wrap
kate: Inserted command:set-word-wrap-column
kate: Inserted command:set-replace-tabs-save
kate: Inserted command:set-remove-trailing-space-save
kate: Inserted command:set-highlight
kate: Inserted command:s
kate: Inserted command:%s
kate: Inserted command:$s
kate: Inserted command:char
kate: Inserted command:date
kate: Inserted command:find
kate: Inserted command:replace
kate: Inserted command:ifind
kparts: found KParts Plugin : /opt/kde_3.4.1/share/apps/katepart/kpartplugins/katepartkttsd.rc
Kate (Document): [int KateFileTypeManager::fileType(KateDocument*)]
kio (KTrader): query for Kate/ProjectPlugin : returning 1 offers
kio (KTrader): query for Kate/Plugin : returning 0 offers
kdeui (KDockWidget): : KDockWidget::setHeader
kdeui (KDockWidget): KDockWidgetHeader::showUndockButton(true)
kdeui (KDockWidget): KDockWidgetHeader::showUndockButton(false)
kdeui (KDockWidget): : KDockWidget::setHeader
-------------------------------------------------------------------------------------------------

My guess is that this is debugging information.
Is there any way to suppress this output in the terminal?

It's driving me mad since I can't continue to use the terminal I called Kate from. Every time I switch between console and kate, more messages scroll across the console screwing up whatever I was working on.

Thanks in advance for any suggestions you can make.

GATTACA
 
Old 07-20-2005, 09:08 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Maybe try start Kate with :
Code:
kate textfile.txt > /dev/null 2>&1
Or recompile KDE without debug options, try ./configure --help
 
Old 07-20-2005, 09:47 AM   #3
GATTACA
Member
 
Registered: Feb 2002
Location: USA
Distribution: Fedora, CENTOS
Posts: 201

Original Poster
Rep: Reputation: 32
Well, recompiling will take more time than I have. It might be easier just download the *.tgz packages an install them instead. I don't think I'll notice a huge performance difference.

Your first suggestion worked like a charm!

Here's how I applied it:
1) create a script in my ~/bin directory called 'kate.sh'
2) kate.sh script:
#!/bin/bash
/absolute/path/to/kate $1 > /dev/null/ 2>&1

3) chmod +x ~/bin/kate.sh
4) add this line to my ~/.bashrc file
alias kate='~/bin/kate.sh'

Now the debugging messages are gone!

I know this probably isn't the most elegant solution but it works.

Thanks for your help keefaz!

BTW what does the '2>&1' part of the command do?
 
Old 07-20-2005, 10:20 AM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
2>&1 : redirect both standard error and standard output
Take a look at :
http://www.faqs.org/docs/Linux-HOWTO...tro-HOWTO.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Annoying CD-rom driver error messages dinges Linux - Software 11 02-05-2006 03:54 PM
Annoying eth0-console messages.. Laffo Debian 1 08-18-2005 08:29 AM
annoying messages from passwordless rsh kevingpo Fedora 5 08-10-2005 05:00 PM
annoying messages from rsh kevingpo Linux - Networking 2 08-03-2005 05:37 AM
Warning: this post contains annoying noob questions shmoo28 Linux - Software 5 10-25-2001 10:40 PM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration