LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Possible bug with today's glibc updates? (http://www.linuxquestions.org/questions/slackware-14/possible-bug-with-todays-glibc-updates-4175477684/)

Lufbery 09-18-2013 11:28 PM

Possible bug with today's glibc updates?
 
Hi all,

I've spent a few hours chasing this down to no avail.

I upgraded the glibc packages noted in today's changelog for Slackware 64_14 using slackpkg. After that, XFCE did not have a window manager.

The warning messages that I can see after exiting back to the console (I boot to runlevel 3) indicate some problem with glibc, but I know I'm not seeing all the messages.

I rolled back the changes to glibc by reinstalling those packages from the Slackware DVD. I also reinstalled XFCE 4, and I moved the ~/.config/xfce folder into another directory so XFCE would start with a brand new configuration.

Still no window manager.

Is anyone else having this issue?

Thanks,

tuxbg 09-18-2013 11:36 PM

This is not a problem with glibc.Try to open terminal and type
Code:

xfwm4 --replace &

Habitual 09-19-2013 12:47 PM

Did you reboot after rolling back the glibc installs?

Lufbery 09-19-2013 03:28 PM

Hi folks and thanks for the responses.

I did reboot after the glibc updates and rollbacks.

I will try the xfwm4 --replace & command this evening after work.

Regards,

-Drew

Lufbery 09-19-2013 06:57 PM

Quote:

Originally Posted by tuxbg (Post 5030439)
This is not a problem with glibc.Try to open terminal and type
Code:

xfwm4 --replace &

Okay, that worked. Thanks!

Why did it work?

-Drew

Lufbery 09-19-2013 07:33 PM

Update: it only works on the current session, and I can't log out. :-/

Here are the messages on the console (what I can capture anyway):

Code:

Current version of pixman: 0.26.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 19 20:27:38 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
resize called 1024 768
/usr/bin/startxfce4: X server already running on display :0

HP Linux Imaging and Printing System (ver. 3.12.9)
System Tray Status Service ver. 2.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


Usage: hp-systray [MODE] [OPTIONS]


[MODE]
  Run in graphical UI mode:                      -u or --gui (Default)

[OPTIONS]
  Use Qt4:                                      --qt4 (Default)
  Set the logging level:                        -l<level> or --logging=<level>
                                                <level>: none, info*, error, warn, debug (*default)
  Run in debug mode:                            -g (same as option: -ldebug)
  This help information:                        -h or --help

  Startup even if no hplip CUPS queues are      -x or --force-startup
  present:

error: option -s not recognized

(xfdesktop:2865): GLib-GIO-CRITICAL **: g_file_get_path: assertion `G_IS_FILE (file)' failed

(xfdesktop:2865): GLib-GIO-CRITICAL **: g_file_get_path: assertion `G_IS_FILE (file)' failed

(xfce4-session:2845): Wnck-CRITICAL **: wnck_workspace_activate: assertion `WNCK_IS_WORKSPACE (space)' failed

HP Linux Imaging and Printing System (ver. 3.12.9)
System Tray Status Service ver. 2.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


** (nm-applet:2896): CRITICAL **: dbus_set_g_error: assertion `gerror == NULL || *gerror == NULL' failed
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
QGtkStyle was unable to detect the current GTK+ theme.
xfce4-panel: No window manager registered on screen 0. To start the panel without this check, run with --disable-wm-check.
xfsettingsd: No window manager registered on screen 0.

(xfsettingsd:2864): xfsettingsd-WARNING **: Failed to get the _NET_NUMBER_OF_DESKTOPS property.

Any thoughts?

Thanks,

ReaperX7 09-19-2013 08:15 PM

Quote:

QGtkStyle was unable to detect the current GTK+ theme.
Check your GTK+ 2.x and GTK+ 3.x packages.

Lufbery 09-21-2013 01:31 PM

Hmm. I did that too. No effect.

I'm sort of stumped.

Lufbery 10-08-2013 09:01 PM

This is solved now. The answer was clearing out the XFCE4-related directory and files in the .cache directory in my home folder.

I've reinstalled the glibc updates from late September and everything is fine.

Regards,

-Drew


All times are GMT -5. The time now is 09:54 PM.