LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-18-2013, 11:28 PM   #1
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
Possible bug with today's glibc updates?


Hi all,

I've spent a few hours chasing this down to no avail.

I upgraded the glibc packages noted in today's changelog for Slackware 64_14 using slackpkg. After that, XFCE did not have a window manager.

The warning messages that I can see after exiting back to the console (I boot to runlevel 3) indicate some problem with glibc, but I know I'm not seeing all the messages.

I rolled back the changes to glibc by reinstalling those packages from the Slackware DVD. I also reinstalled XFCE 4, and I moved the ~/.config/xfce folder into another directory so XFCE would start with a brand new configuration.

Still no window manager.

Is anyone else having this issue?

Thanks,
 
Old 09-18-2013, 11:36 PM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
This is not a problem with glibc.Try to open terminal and type
Code:
xfwm4 --replace &
 
Old 09-19-2013, 12:47 PM   #3
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Slack14_64_Multilib
Posts: 3,079
Blog Entries: 4

Rep: Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745
Did you reboot after rolling back the glibc installs?
 
Old 09-19-2013, 03:28 PM   #4
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hi folks and thanks for the responses.

I did reboot after the glibc updates and rollbacks.

I will try the xfwm4 --replace & command this evening after work.

Regards,

-Drew
 
Old 09-19-2013, 06:57 PM   #5
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by tuxbg View Post
This is not a problem with glibc.Try to open terminal and type
Code:
xfwm4 --replace &
Okay, that worked. Thanks!

Why did it work?

-Drew
 
Old 09-19-2013, 07:33 PM   #6
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Update: it only works on the current session, and I can't log out. :-/

Here are the messages on the console (what I can capture anyway):

Code:
Current version of pixman: 0.26.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 19 20:27:38 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
resize called 1024 768
/usr/bin/startxfce4: X server already running on display :0

HP Linux Imaging and Printing System (ver. 3.12.9)
System Tray Status Service ver. 2.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


Usage: hp-systray [MODE] [OPTIONS]


[MODE]
  Run in graphical UI mode:                      -u or --gui (Default)

[OPTIONS]
  Use Qt4:                                       --qt4 (Default)
  Set the logging level:                         -l<level> or --logging=<level>
                                                 <level>: none, info*, error, warn, debug (*default)
  Run in debug mode:                             -g (same as option: -ldebug)
  This help information:                         -h or --help

  Startup even if no hplip CUPS queues are       -x or --force-startup
  present:

error: option -s not recognized

(xfdesktop:2865): GLib-GIO-CRITICAL **: g_file_get_path: assertion `G_IS_FILE (file)' failed

(xfdesktop:2865): GLib-GIO-CRITICAL **: g_file_get_path: assertion `G_IS_FILE (file)' failed

(xfce4-session:2845): Wnck-CRITICAL **: wnck_workspace_activate: assertion `WNCK_IS_WORKSPACE (space)' failed

HP Linux Imaging and Printing System (ver. 3.12.9)
System Tray Status Service ver. 2.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


** (nm-applet:2896): CRITICAL **: dbus_set_g_error: assertion `gerror == NULL || *gerror == NULL' failed
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
QGtkStyle was unable to detect the current GTK+ theme.
xfce4-panel: No window manager registered on screen 0. To start the panel without this check, run with --disable-wm-check.
xfsettingsd: No window manager registered on screen 0.

(xfsettingsd:2864): xfsettingsd-WARNING **: Failed to get the _NET_NUMBER_OF_DESKTOPS property.
Any thoughts?

Thanks,
 
Old 09-19-2013, 08:15 PM   #7
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,898
Blog Entries: 15

Rep: Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745Reputation: 745
Quote:
QGtkStyle was unable to detect the current GTK+ theme.
Check your GTK+ 2.x and GTK+ 3.x packages.
 
Old 09-21-2013, 01:31 PM   #8
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
Hmm. I did that too. No effect.

I'm sort of stumped.
 
Old 10-08-2013, 09:01 PM   #9
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Original Poster
Rep: Reputation: 119Reputation: 119
This is solved now. The answer was clearing out the XFCE4-related directory and files in the .cache directory in my home folder.

I've reinstalled the glibc updates from late September and everything is fine.

Regards,

-Drew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] today's updates on -current - exaile would not start sycamorex Slackware 2 08-28-2010 04:22 AM
LXer: Debian Etch: Three updates today, and how to find out more about them in GNOME LXer Syndicated Linux News 0 10-25-2008 04:20 PM
LXer: Memory Corruption Bug Solved, 2.6.25 Expected Today LXer Syndicated Linux News 0 04-16-2008 09:20 PM
getting updates today is IMPOSSIBLE (today)!! mtdew3q Suse/Novell 3 10-17-2007 12:53 AM
Slackware current updates today! neo Slackware 2 04-22-2005 05:32 PM


All times are GMT -5. The time now is 04:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration