LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-11-2010, 10:57 AM   #46
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16

Quote:
This looks incorrect to me:
Code:
if (( OUT_S != OUT_S_CHECK ));then
echo "OUT_S=$OUT_S_CHECK" > /boot/GSplash/output.conf.temp
fi
Shouldn't it be:
Code:
if (( $OUT_S != $OUT_S_CHECK ));then
echo "OUT_S=$OUT_S_CHECK" > /boot/GSplash/output.conf.temp
fi
Tried this but it doesn't change anything. It still says Init ID X1: respawning too fast: disabling for 5 minutes.
The thing is when I modify the inittab to use wrapper scripts, after that while rebooting I get an output on screen, something as 'ioctl error:' and then in the end it says, now using script rc.6: and then system starts showing shutdown messages.

@lumak: I use bash only and haven't changed anything to use a different shell in any case. And the code thing is something I cannot understand, so I can just give it(new code) a try! but where and in which do I need to inser that line you mentioned?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 09-11-2010, 01:06 PM   #47
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,755

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
Ah, lumak is right of course -I haven't looked at the attachments provided in order to understand what was going on. It just looked funny to me 'cause I know that syntax is 'foreign' to the standard Slack init scripts. I would suggest that instead of trying to 'wrap' the standard scipts, that you simply alter the existing scripts to do what you want and offer them that way. That will make things both easier for you, and more transparent to potential users.
I have scripts which I modified for use with bootsplash -even with animation in them at both startup and shutdown. It's a lot cleaner to just write in the extra lines needed in copies of the originals. I do have some code (functions) in a separate file which get sourced -again that keeps things cleaner and easier to carry your mods forward when the init scripts get changed, which is not often.
 
Old 09-11-2010, 09:39 PM   #48
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
ok, I've stumbled upon something which could be the cause(I think..) does it matter if I use huge kernel instead of generic one? I made initrd-tree after reading in the article(wiki), and I am currently not able to boot with generic kernel(some raid issue, and I don't have raid!), hence am unable to test wrapper scripts to conclude...
 
Old 11-28-2010, 09:30 AM   #49
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
Resurrection!

Alright guys I've decided to give this one more go as I am missing boot-screen.

I am now able to boot with generic kernel w/o any problem. I can test the ppm images successfully with command:
/boot/initrd-tree/bin/busybox fbsplash -s /home/kapz/Pictures/shutsplash.ppm. This means busybox is present.

Now after creating wrapper scripts and modifying inittab to use wrapper scripts the system hangs at boot time at the same message:
init X: respawning too fast disabling it for 5 minutes....and now if I press ctl+alt+del I get a message in 'green text' saying:
/ect/rc.6 line 49: /boot/initrd-tree/bin/busybox no such file or directory ..(!!??!)
/etc/rc.6 line51: /boot/GSplash/fifo no such file or directory (but it is, please refer attached screenshot)
*Edit* It also says that there is nothing left in the run level to do anymore, and I have to hard reboot *Edit*

[weird] If I boot with live dvd and mount my root in /mnt, I can't see /boot/initrd-tree/bin/busybox! but can see /boot/fbfifo[/weird]

Also this one time I saw the image and progressbar while shutting down, but it again hung while booting.

Last thing, the /boot/GSplash/fbfifo looks like /boot/GSplash/fbfifo| (refer screenshot)

Thanks guys
Attached Images
File Type: png snapshot2.png (172.2 KB, 40 views)

Last edited by kapz; 11-28-2010 at 11:20 AM.
 
Old 11-28-2010, 06:39 PM   #50
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
okay, I modified inittab to only use wrapper for rc.0-Wrap and rc.6-Wrap and it works fine.

Startup is an issue, am I missing something to add, maybe a local system variable such as initrd-tree/bin/busybox to be made differently?

Edit* I found this in rc.S-Wrap in line 36:

Quote:
#no kerenel messages
setterm -msg off -cursor off -foreground green
tput clear

/boot/initrd-tree/bin/busybox fbsplash -i /boot/GSplash/fb.config -f /boot/GSplash/fbfifo -s /boot/GSplash/startup.ppm &

"$STARTUP" &> /boot/GSplash/fifo &
is my fbfifo and fifo broken or something? *Edit (does it have anything to do with en_us.utf-8 support?)

Thnx

Last edited by kapz; 11-28-2010 at 08:25 PM.
 
Old 11-29-2010, 01:51 AM   #51
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,755

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
You may need to call fbsplash explicitly -with the full path, I mean, unless the PATH already includes the path to where fbsplash is installed.
 
Old 11-29-2010, 02:44 AM   #52
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
Quote:
You may need to call fbsplash explicitly -with the full path, I mean, unless the PATH already includes the path to where fbsplash is installed.
you mean like this:

/boot/initrd-tree/bin/busybox /boot/initrd-tree/sbin/fbsplash -i /boot/GSplash/fb.config -f /boot/GSplash/fbfifo -s /boot/GSplash/startup.ppm &

*Edit* Never mind I tried the above line and it still slags at boot..

The message I get is: init: ID "x1" respawning too fast: disabled for 5 minutes...

and then the same thing happens....Am I missing any package or library required by the wrapper script?

Either that or there might be something in rc.M-Wrap that's causing problem...coz I tried booting with all wrapper enabled except rc.S-Wrap and the system booted and freezed at going multiuser... thats it, stays there, however here the ctl alt del works and system reboots normally...

grrr..how did others managed to get it to work..

Last edited by kapz; 11-29-2010 at 03:45 AM.
 
Old 11-29-2010, 05:18 AM   #53
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
Does it matter if /boot is a seperate partition?
 
Old 11-29-2010, 07:32 AM   #54
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
Glad to see you around. Better still you are using slackware ).
Well as far as /boot being a different partition is concerned it should not be an issue (else you would not be able to even boot).
-vaibhav-
 
Old 11-29-2010, 07:54 AM   #55
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
Hey there mate! it's been long! you hav deb logo on your FB account? if yes then I'll add you.

well am asking coz I dont know why it won't find the thing that exists on the same place..it says not found when screenshot clearly shows that it's there!
 
Old 11-29-2010, 08:20 AM   #56
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
Yup the debian icon on FB is me - please add me. As far as the issue is concerned - well it is 4 pages long and I did not read all of it apart from your post that said graphical bootup is for wimps .
BTW:- Did you know that we have documents for linux called linux documentation project. It may have something for you.
I still am a die hard fan of debian and so I am not sure how you can get this configured in slackware.
 
Old 11-29-2010, 08:31 AM   #57
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
Quote:
graphical bootup is for wimps
Wow, new def, console = macho! Yess!!!

Last edited by kapz; 11-29-2010 at 08:34 AM.
 
Old 11-29-2010, 11:02 AM   #58
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,755

Rep: Reputation: 466Reputation: 466Reputation: 466Reputation: 466Reputation: 466
"freezed at going multiuser" -this means there is a problem in /etc/rc.d/rc.M
Sorry I can't be more helpful -the use of wrappers to the normal scripts complicates things considerably. Here's a thought though: rc.S explicitly calls rc.M, so if you are supposed to be using an rc.M wrapper, then rc.S would need to call that explicitly instead of the real rc.M.
If it were me, I'd try to get it all working by modifying the normal startup scripts. You'd want to back them up to be able to restore them after any upgrades to the sysvinit-scripts package, though.
I have a working bootsplash, including animations, but that is with the real bootsplash with patched kernel and directly modded init scripts. So my system wouldn't work directly for you.
Another thing I'd look at is to make sure that /boot is not mounted separately. If /boot is a separate partition it will not be mounted when the init scripts start running -that only happens once the 'mount -a ...' command is run (about halfway through rc.S). If you are using a separate boot partition and want to keep it that way, then you'll need to copy all programs you are calling (busybox, fbsplash, etc) into either /bin or /sbin so that they are available when just / is mounted.
 
Old 11-29-2010, 12:10 PM   #59
kapz
Member
 
Registered: Mar 2009
Location: kernel space
Distribution: Slackware_x64
Posts: 191

Rep: Reputation: 16
Quote:
"freezed at going multiuser" -this means there is a problem in /etc/rc.d/rc.M
Problem only when wrapper is used, else all works as expected.

Quote:
Here's a thought though: rc.S explicitly calls rc.M, so if you are supposed to be using an rc.M wrapper, then rc.S would need to call that explicitly instead of the real rc.M.
That's a good advice actually. Thanks!
 
Old 11-29-2010, 12:52 PM   #60
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 836

Original Poster
Rep: Reputation: 167Reputation: 167
Quote:
Originally Posted by gnashley View Post
... Here's a thought though: rc.S explicitly calls rc.M, so if you are supposed to be using an rc.M wrapper, then rc.S would need to call that explicitly instead of the real rc.M...
rc.S does not call rc.M explicitly at least not in my rc.S script rc.M is called from inittab hence changing the innitab to call rc.M-Wrap
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor man's graphical boot in Slackware 13.X... LuckyCyborg Slackware 38 05-21-2011 11:33 AM
Poor Man's VPN on smartphone - Putty Fatal error WSAEventSelect(): SOCKET_ERROR " Wildebeest2010 Linux - Software 1 02-15-2010 01:41 PM
Display a picture file as a poor-man's splash screen fudam Linux - General 1 12-01-2006 06:15 AM
Wanna do a poor man's slacktop... papa0822 Linux - Laptop and Netbook 2 10-12-2004 06:59 PM
Poor man's dual monitor (using two linux boxes)) alexferrer Linux - General 8 05-22-2003 03:02 PM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration