LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-11-2005, 05:48 PM   #1
Thanotos
Member
 
Registered: Oct 2005
Location: Nanaimo, BC. ~CANADA~
Posts: 70

Rep: Reputation: 15
Question please check that the "dcopserver" program is running


alrighty here is the thing.

As with most newb's I am curious and always trying new things.

I have been playing with ownership/permissions and in the process have lost rights to all /home folders respectively for my users.

I am getting the error:

quote:
There was an error settuping up inter-process communications for KDE.
The message returned by the system was:

Could not read Network Connection List.
//: .DCOPserver_stealth__0

Please check that DCOPserver program is running.



I have tried (as per other posts and google findings):
chmod -R +w /home/*username
removing one file: /root/.ICEauthority
su -c "chown $WHO:users /home/$WHO/.ICEauthority" exit where $WHO is the user

Currently I can login as root and have no issues with KDE.

When in a root shell and su to my main account 'thanotos' to try and view permissions that the user has, this is the return

root@stealth:/home/windows# su thanotos
bash: /home/thanotos/.bashrc: Permission denied
thanotos@stealth:/home/windows$ cd
bash: cd: /home/thanotos: Permission denied

So all that I know for sure is that I do not have permissions for any of my users other than root. Nor can I change them back.

Any suggestions would be appreciated. I really dont want to remove and readd users.
 
Old 11-11-2005, 07:19 PM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
Re: please check that the "dcopserver" program is running

Quote:
Originally posted by Thanotos
alrighty here is the thing.

As with most newb's I am curious and always trying new things.

I have been playing with ownership/permissions and in the process have lost rights to all /home folders respectively for my users.


LMAO...............


now that we got that out of the way........what are the permissions for
"/home"
???
 
Old 11-12-2005, 04:53 PM   #3
Thanotos
Member
 
Registered: Oct 2005
Location: Nanaimo, BC. ~CANADA~
Posts: 70

Original Poster
Rep: Reputation: 15
drwx--x--x 2 forlamp users 80 2005-11-04 18:40 forlamp/
drwxr-xr-x 2 root root 48 2005-07-14 05:14 ftp/
drwx--x--x 9 pickel users 400 2005-11-11 09:18 pickel/
drwx--x--x 2 test users 80 2005-11-11 13:23 test/
drwx--x--x 2 test2 users 80 2005-11-11 15:55 test2/
drwx--x--x 16 thanotos users 1024 2005-11-11 13:56 thanotos/
drwxr-xr-x 3 thanotos users 72 2005-11-04 09:57 windows/

looking at it everything looks good ...... (to me anyway)

root@stealth:/# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel),11(floppy)



Quote:
/dev/hdd2 / reiserfs defaults 1 1
/dev/hdd3 /home reiserfs defaults 1 2
/dev/hdc6 /home/windows/storage ntfs noauto,owner,rw 1 2
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0

Appreciate the help.

And I am glad that I could bring a smile to ones face with self induced suffering
 
Old 11-13-2005, 12:36 PM   #4
jameslaw
Member
 
Registered: Nov 2005
Location: Trento, Italy
Distribution: Debian:testing, Ubuntu
Posts: 33

Rep: Reputation: 15
I've had this problem recently when changing from SuSE back to Slackware. I reused a disk for /home, since I wanted to keep the files on it, and the user names and groups didn't match up, so DCOP saw ownership and group problems. I knew there was a problem when I did 'ls -al' to look at the dotfiles in my home dir and the user and group shown were numbers instead of my login and a group name.

I fixed it by chown'ing the dotdirs and dotfiles in my home dir to my login and chgrp'ing them to 'users'. I didn't know how to do only the dirs and files, but not the parent dir, so I did it in a series of commands:

chown -R my_login .a* .b* ...

then:

chgrp -R users .a* .b* ...

If I did 'chown -R .*' it would have tried to do the parent dir (..) too. Maybe someone can chime in with an easier way, but this fixed the problem for me.

Jim
 
Old 11-13-2005, 12:45 PM   #5
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
You could use find and chown the files appropriately

example for 1 user :
Code:
# cd /home/thanotos
# find . ! -user thanotos ! -group users | xargs chown thanotos:users
#
 
Old 11-13-2005, 01:29 PM   #6
Thanotos
Member
 
Registered: Oct 2005
Location: Nanaimo, BC. ~CANADA~
Posts: 70

Original Poster
Rep: Reputation: 15
appreciate the info,

I will post with the results and steps that resolved.

(might be a day before anything is posted.....need sleep)
 
Old 11-13-2005, 06:04 PM   #7
AndyCooll
LQ Newbie
 
Registered: Jun 2005
Location: Stockport, United Kingdom
Distribution: Currently trying Ubuntu and Debian
Posts: 14

Rep: Reputation: 0
I have spent the last couple of days trying to resolve this issue too. I eventually resolved it by setting my Home directory permissions to the default Home directory settings of 755 (I had other users to compare the settings with), i.e.

Owner: read, write, execute
Group: read, execute
Others: read, execute

Hope this helps

 
Old 11-14-2005, 08:06 PM   #8
Thanotos
Member
 
Registered: Oct 2005
Location: Nanaimo, BC. ~CANADA~
Posts: 70

Original Poster
Rep: Reputation: 15
So here be a bit of an update.

keefaz = appreciate the solution, however it did not seem to work - whether I was not applying the info correctly or it just wants to be difficult.

Here is an update:
Code:
root@stealth:/# ls -l
total 90
drwxr-xr-x   2 root     bin    2512 2005-11-06 17:48 bin
drwxr-xr-x   2 root     root    464 2005-11-05 02:59 boot
drwxr-xr-x  15 root     root  62592 2005-11-14 07:16 dev
drwxr-xr-x  45 root     root   4704 2005-11-14 07:17 etc
drw-rw-rw-  11      777 root    240 2005-11-11 15:55 home

Code:
root@stealth:/# su thanotos
bash: /home/thanotos/.bashrc: Permission denied
thanotos@stealth:/$ cd /home
bash: cd: /home: Permission denied
Patience is appreciated ... I am about to believe that I have FUBAR my users and may find it easier just to create 'a-new'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE - please check that the "DCOPserver" program is running Thanotos Linux - Newbie 2 11-27-2006 06:11 PM
Warning on running "make check", 2nd time satimis Linux From Scratch 8 07-11-2005 03:46 AM
Warning on running "make check" satimis Linux From Scratch 1 07-09-2005 09:21 PM
I can't log in as root! I get a "dcopserver" error! bublebboy Linux - Newbie 4 06-15-2004 04:43 AM
"Check if running" Script... bfloeagle Linux - Software 2 05-23-2002 08:12 AM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration