LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2005, 03:17 PM   #1
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Playing music CDs


Hello,

I've got my sound card working, I can play streaming videos with sound from CNET.com.
I'd like to play some music CDs, but, get an error. I think I need permission to access the cd rom drive. I have two questions.
1. Do I need to mount the music cd to play it? If so, what command would I use as a regular user "hitest"?
2. How should I change my fstab to allow me, a regular user "hitest", to play cds?

Here's my fstab:

/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

I'm surprised by how good my streaming videos sound.
Thank you for your replies.
 
Old 09-23-2005, 03:42 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,014

Rep: Reputation: 115Reputation: 115
two problems.
1. You don't mount audio CD-ROMS
2. normal users ar not given permision to mount cdroms or floppies
to play audio cds, just goto xmms and open files from /mnt/cdrom. A plugin in xmms will figure out that you want to play a cd and list out the tracks.
for the mounting problem, add "user" to the options in fstab, where "owner" is. It is also a good idea to make add the "showexec" option to the floppy entry. It makes sure that the permissions are sane when you mount vfat floppies.
 
Old 09-23-2005, 03:53 PM   #3
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Original Poster
Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Thanks for the reply, tuxdev!
Okay I've opened up xmms in XFce and click play, then select mnt/cdrom.
But, I can't get it to list the tracks or play music yet.
Do I need to edit fstab before I do this?
Thanks, I think I'm close.
 
Old 09-23-2005, 03:59 PM   #4
uopjohnson
Member
 
Registered: Jun 2004
Location: San Francisco
Distribution: Slackware, Ubuntu, RHEL, OS X
Posts: 159

Rep: Reputation: 30
Yes the fstab edit needs to come first. You might also want to reboot, at least I always do when I make fstab changes.
 
Old 09-23-2005, 04:14 PM   #5
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Original Poster
Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Okay, I changed my fstab so that it reads user where owner once was.
But, when I open up xmms and go to mnt/cdrom I can't get a track listing or play music. I must be clicking the wrong buttons in the player. Do I highlight cdrom and then click add files or add all files in directory?
Thank you.

Last edited by hitest; 09-23-2005 at 04:29 PM.
 
Old 09-23-2005, 06:36 PM   #6
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
I believe you need to add your "user" to the "wheel group".........

.....my users have no problems mount/umount data CD's or playing music CD's
 
Old 09-23-2005, 07:31 PM   #7
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
You need to configure xmms to play your audio devices. goto the pref >> Audio I/O Plugins and check that you have the CD player plugin then use configure so it points to the correct dev and mnt points. then:

xmms /mnt/cdrom

KC
 
Old 09-23-2005, 07:59 PM   #8
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Quote:
Originally posted by uopjohnson
Yes the fstab edit needs to come first. You might also want to reboot, at least I always do when I make fstab changes.


you are not using windoze man!! you could reboot until some months are past and only if you really really want to!
 
Old 09-23-2005, 09:48 PM   #9
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Original Poster
Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Okay, thank you for your replies, gentlemen! I'll try adding my user to the wheel group and change my preferences in Xmms.
I appreciate your help.
 
Old 09-24-2005, 01:18 AM   #10
thenkoder
LQ Newbie
 
Registered: Sep 2005
Distribution: Gentoo
Posts: 5

Rep: Reputation: 0
As a side note, I was having similar problems.

First off, putting user instead of owner in the fstab makes a difference.
Second off, you may have to add yourself to the 'disk' group, but don't know if it is absolutely necessary.

Then I had another issue. It would load the cd, but I wouldn't get any sound!

$> su
$> chmod -R 755 /dev/cdrom

That seemed to fix my problem. Just giving my input is all.
 
Old 09-24-2005, 03:11 AM   #11
Yalla-One
Member
 
Registered: Oct 2004
Location: Norway
Distribution: Slackware, CentOS
Posts: 635

Rep: Reputation: 35
Quote:
Originally posted by thenkoder
$> su
$> chmod -R 755 /dev/cdrom

That seemed to fix my problem. Just giving my input is all.
As an additional side-note, instead of having to chmod /dev/cdrom each time you reboot, you can do this automagically with udev (that is, if you're using udev already) by adding a custom rule for you CD player:

1. create a custom udev rules file : /etc/udev/rules.d/10-local.rules

2. Add your CDROM (your information will certainly differ):
(Check out : http://www.reactivated.net/writing_udev_rules.html before starting your own)

Code:
BUS="scsi", KERNEL="s[grt][0-9]*", SYSFS{manufacturer}="Sony", SYSFS{serial}="DRX-510ULK_CXD083739", S
YSFS_type="5", NAME="%k", GROUP="cdrom", MODE="0666", SYMLINK="cdrom dvd"
3. run udevstart

Then you'll get a /dev/cdrom with all the correct permissions, and where you can set the group yourself. I use k3b a lot and thus want it to be 666, and thus don't really need the cdrom group, but for others it's good to know exactly which group is used for which device...

Just my $.02
 
Old 09-24-2005, 11:10 PM   #12
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Original Poster
Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Thank you, gentlemen for your answers. I've book marked this thread. I haven't solved my problem yet, but, had a n00b thought. I haven't checked to see if my CD ROM drive is plugged into my sound card. Heh-heh, time to pop my case, have a look.

I need to get off of my computer as my wife says I'm spending too much time here.
What does she know? I'll post back here:-)
 
Old 09-25-2005, 01:18 AM   #13
Talavis
LQ Newbie
 
Registered: May 2005
Location: Stockholm, Sweden
Distribution: Slackware-current
Posts: 22

Rep: Reputation: 15
I borrow this thread a little: I solved this problem by changing the permissions as k3b asked me to: i. e. I enabled users read and write acces to /dev/hda and /dev/hdb (got two drives). But you guys think it's a bad solution?

Also, I use xine to play my cds, didn't know I could use xmms.
 
Old 09-25-2005, 01:29 AM   #14
gescom
LQ Newbie
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware 12.1
Posts: 25

Rep: Reputation: 15
The easiest way to play a cd is to open a terminal and with root permissions type:

cdda2wav -D /dev/cdrom -t 1 -eN

Press ctrl-c to quit playing.

This will play track 1, if the KDE sound system isn't keeping /dev/dsp busy. The -eN options cause cdda2wav to echo the data to the soundcard and not write the ripped data to a file.

Its digital audio via your ide cable. Unfortunatly no seek control though

I think Xmms requires a seperate cd player plugin if you want to play via a digital cable, sound card to cdrom. Connected with an analogue cable it should work however it won't sound as good.
 
Old 09-25-2005, 02:21 PM   #15
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,190

Original Poster
Rep: Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548Reputation: 548
Quote:
Originally posted by gescom
The easiest way to play a cd is to open a terminal and with root permissions type:

cdda2wav -D /dev/cdrom -t 1 -eN

Press ctrl-c to quit playing.

This will play track 1, if the KDE sound system isn't keeping /dev/dsp busy. The -eN options cause cdda2wav to echo the data to the soundcard and not write the ripped data to a file.

Its digital audio via your ide cable. Unfortunatly no seek control though

I think Xmms requires a seperate cd player plugin if you want to play via a digital cable, sound card to cdrom. Connected with an analogue cable it should work however it won't sound as good.
Okay, I've determined that it isn't a physical connecton problem. I opened up a terminal and used su to root. I ran your command and it partially worked, that is, the first track ran a bit, stopped, ran again, then stopped, ran again, knid of weird, but I was getting some sound from the speakers from the cd albeit sporadic. I've added myself to wheel and cd rom. I'm going to check my fstab again.
btw where is the file that I give a regualr user permission to access devices besides fstab? I knew this before, but, I've forgotten. Thank you, I'm getting closer:-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
music cds... kurrupt Debian 2 08-11-2004 08:39 PM
Music cds vapebait Slackware 14 12-11-2003 05:03 PM
playing music cds through scsi emulation ergo_sum Linux - Newbie 3 11-05-2003 11:06 AM
CDs not playing music thom Linux - Distributions 4 10-30-2003 10:53 PM
playing music cds ergo_sum Linux - Newbie 3 10-21-2003 10:41 AM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration