LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-22-2013, 08:12 AM   #1
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Rep: Reputation: 2
Plasma crashing in -current


Hi,

I've searched the forum but I couldn't find anything related to this problem.
The fact it is eventual makes it hard to debug I believe.

So eventually plasma crashes in -current and the only thing that I could find so far is this message at .xsession-errors

--- 8< ---
KCrash: Attempting to start /usr/bin/plasma-desktop from kdeinit
KCrash: Application 'plasma-desktop' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusObjectPath: invalid path ""
This is the current thread id for Activities 139708742424320 QThread(0x190f4f0)
plasma-desktop(4366)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
plasma-desktop(4366)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
static bool QDeclarativeMetaType::isModule(const QByteArray&, int, int) Qt 4.7 import detected; please note that Qt 4.7 is directly reusable as QtQuick 1.x with no code changes. Continuing, but startup time will be slower.
plasma-desktop(4366)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
CLIENT: Task: Task::done()
CLIENT: Task: emitting finished

--- 8< ---

I though that with the lastest Xorg/kernel that wouldn't happen, but it did.

This is my system: uname -a

Linux odin 3.8.8 #2 SMP Thu Apr 18 22:48:10 CDT 2013 x86_64 Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz GenuineIntel GNU/Linux
 
Old 04-22-2013, 08:40 AM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Kde in -current use qt 4.8 not 4.7
 
Old 04-22-2013, 09:04 AM   #3
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 2
Thanks for noticing that.

I google this problem and end up on this kde bug: https://bugs.kde.org/show_bug.cgi?id=310647

It seems that we need to recompile qt-core with -Os instead of -O2.

Now I just need to know how to ask Volkerdi to do that
 
1 members found this post helpful.
Old 04-22-2013, 11:44 AM   #4
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Quote:
Originally Posted by isaque View Post
Thanks for noticing that.

I google this problem and end up on this kde bug: https://bugs.kde.org/show_bug.cgi?id=310647

It seems that we need to recompile qt-core with -Os instead of -O2.

Now I just need to know how to ask Volkerdi to do that
Just grab the source http://slackware.osuosl.org/slackwar...t/source/l/qt/ and edit SlackBuild and compile qt
Please post this command here
Code:
 qmake -v

Last edited by tuxbg; 04-22-2013 at 11:48 AM.
 
Old 04-22-2013, 12:02 PM   #5
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 2
Right, but I believe that fix should be done at the slackware tree, don't you think?
 
Old 04-22-2013, 02:27 PM   #6
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Quote:
Originally Posted by isaque View Post
Right, but I believe that fix should be done at the slackware tree, don't you think?
Please provide the output from
Code:
qmake -v
 
Old 04-22-2013, 04:20 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,175

Rep: Reputation: Disabled
I have that crash on my Slackware ARM Chromebook. I just started a rebuild of qt with "-Os" to see if that cures the plasma crash.
Don't stay up to wait for the outcome... compiling Qt on a wee ARM computer takes much longer than on my quad-core Athlon build server...

Eric
 
1 members found this post helpful.
Old 04-22-2013, 10:30 PM   #8
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 2
$ qmake -v
QMake version 2.01a
Using Qt version 4.8.4 in /usr/lib64/qt/lib

I have rebuild Qt and I'll let you know if that is fixed or not.

Thanks.

PS. Eric, can't wait to have Slackware in my Chromebook
 
Old 04-23-2013, 07:39 AM   #9
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 2
I have rebuild qt with -Os option but it crashed yesterday.

Let's see how it is going to behave today. BTW, after I upgraded (?!?) to this new version I've reboot my system to make sure I was not running any old stuff.

Perhaps I missed something. Feel free to check the changed qt.SlackBuild and if you find anything wrong, please let me know.

Thanks.
 
Old 04-23-2013, 08:02 AM   #10
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Quote:
Originally Posted by isaque View Post
Thanks for noticing that.

I google this problem and end up on this kde bug: https://bugs.kde.org/show_bug.cgi?id=310647

It seems that we need to recompile qt-core with -Os instead of -O2.

Now I just need to know how to ask Volkerdi to do that
Compiling with -Os isn't the answer. The bug report you found isn't the end of the trail. You'll notice it is closed as a duplicate. If you follow the link to the original, you'll find another kde bug report that is closed as "fixed upstream", and a link to this: https://bugreports.qt-project.org/browse/QTBUG-29082 which contains a patch.


No idea whether it works... I'm not a KDE user, and was just reading the bug reports out of curiosity.

Last edited by GazL; 04-23-2013 at 08:07 AM.
 
Old 04-23-2013, 01:01 PM   #11
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,175

Rep: Reputation: Disabled
How the fsck does one get a proper patch out of https://codereview.qt-project.org ???

Eric
 
Old 04-23-2013, 02:42 PM   #12
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 2
Ha, so, it's not just me. I still couldn't figure it out.
Please let me know if you do.

Thx.
 
Old 04-23-2013, 02:55 PM   #13
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 353

Rep: Reputation: 89
Run

Code:
git fetch https://codereview.qt-project.org/p/qt/qt refs/changes/28/46228/3 && git format-patch -1 --stdout FETCH_HEAD > /tmp/qt-crash.patch
within a clone of the qt git repo
 
Old 04-23-2013, 09:15 PM   #14
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,493

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
Please verify whether the updated qt in current fixed this problem or not
 
Old 04-23-2013, 09:43 PM   #15
isaque
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 2
That just make my life much easier. I've updated, so let's see how it will behave.
Thanks Willy.
 
  


Reply

Tags
crash, current, plasma


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Kmail crashing in Slackware current with KDE 4.7.3 saivnoba Slackware 2 11-12-2011 07:05 PM
homebank crashing on current / kde 4.4 zvzi Slackware 4 02-27-2010 04:20 AM
kde4 on karmic: plasma-desktop doesn't start by itself after removing plasma-netbook eantoranz Linux - Software 8 10-10-2009 09:57 AM
kde 4.2 from -current plasma crash hemp4fuel Slackware 16 04-11-2009 09:23 PM
X 4.4.0 keeps crashing with -current Angelo Slackware 10 04-07-2004 10:25 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration