LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   pkg request libarchive-3.1.2.tar.gz (http://www.linuxquestions.org/questions/slackware-14/pkg-request-libarchive-3-1-2-tar-gz-4175478935/)

gmgf 09-29-2013 03:23 AM

pkg request libarchive-3.1.2.tar.gz
 
Hi, Pat, libarchive-3.1.2.tar.gz, contain more improvement.

need probably rebuilt ark and gvfs

Thanks.

gmgf 10-03-2013 10:20 AM

Another reason for update this package gvfs-3.10.0 , doesn't build with the old current version.

bartgymnast 10-04-2013 03:45 AM

Hi gmgf,

I support this request.
BTW, its gvfs-1.18.x (belongs to the 3.10 series of gnome tho)

you can build gvfs with --disable-archive

gmgf 10-04-2013 08:39 AM

Yes i agree but i prefer gvfs with libarchive support ;)

yes a little error it's gvfs-1.18 for gnome-3.10.0 who no build with the old libarchive current package.

BrZ 10-04-2013 02:14 PM

Hi gmgf,
You can spice things up an add this two commits from upstream:

Fix overflow checking in archive_entry_sparse_add_entry()
and
Fix CVE-2013-0211 - Limit write requests to at most INT_MAX

gmgf 10-15-2013 03:11 AM

Thanks, for this Update, Pat.


All times are GMT -5. The time now is 01:29 PM.