LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   pkg-config can't find installed package (http://www.linuxquestions.org/questions/slackware-14/pkg-config-cant-find-installed-package-523914/)

JAKK 01-29-2007 10:15 PM

pkg-config can't find installed package
 
Hi. I am trying to install geany. When I do ./configure,I get the following message
Code:

which: no svn in (/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)
checking for pkg-config... /usr/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for PACKAGE... configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

The thing is,I have gtk+ 2.8.x installed. I'm not sure why it can't find it.

H_TeXMeX_H 01-29-2007 10:35 PM

It compiles fine for me. Where do you have that gtk+-2.8.x installed ? Did you compile it yourself ?

I have 'gtk+2-2.8.20-i486-1.tgz' that came with slackware, and it configures and compiles just fine using that.

Also, are you using the svn or release version of geany ? (I used release)

EDIT: I didn't even know about geany until now. Glad you brought it up, seems to be a very nice IDE ... just what I was looking for :)

JAKK 01-29-2007 10:57 PM

Hi. I also have the gtk+ 2.0 slack version. It's in /etc/gtk-2.0. I'm trying to compile geany from source since the most recent slack package I could find was .7. I really want to use geany because it seems so light which is what I need since I run on a 300mhz celly.

H_TeXMeX_H 01-29-2007 11:16 PM

I would reinstall that package ('gtk+2-2.8.20-i486-1.tgz') just to make sure.

If that doesn't work then try what it suggests and set 'PKG_CONFIG_PATH' to wherever gtk is installed.

Code:

export PKG_CONFIG_PATH=gtk-path-goes-here

JAKK 01-30-2007 12:18 AM

Hi. I tried both of those options,and the same thing still happens. I have gtk+2 installed to /etc/gtk-2.0. I did
Code:

export PKG_CONFIG_PATH=/etc/gtk-2.0
then ./configure.

H_TeXMeX_H 01-30-2007 12:30 AM

Are you sure that's where it is installed ?

That would be a very odd place for it to be installed, a place it doesn't belong. (some files from the package exist in /etc, but that's not where it is installed)

It's installed in /usr

To check if the package is installed look in your /var/log/packages for it. Also check that the file /usr/lib/gtk+-2.0.pc exists.

JAKK 01-30-2007 07:58 PM

Hi. I do have that file in /usr/lib. Where exactly should I be pointing pkg-config.

H_TeXMeX_H 01-30-2007 08:00 PM

I think to /usr

Did you reinstall 'gtk+2-2.8.20-i486-1.tgz' ?

JAKK 01-30-2007 08:49 PM

Hi. I did reinstall the package. Right now I am doing

Code:

export PKG_CONFIG_PATH=/usr
And then running ./configure. It still comes up with the same message. I also noticed that at the end of the error it say something about being able to turn the call off for pkg-config,but I'm not sure if that would fix it. Also,at the end of the info for the package it says

Code:

FILE LIST:
./
etc/
etc/gtk-2.0/

EDIT:I made some progress. If I change the variable to /usr/lib/pkgconfig. I get
Code:

checking for PACKAGE... configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met:

Package xrender was not found in the pkg-config search path.
Perhaps you should add the directory containing `xrender.pc'
to the PKG_CONFIG_PATH environment variable
Package 'xrender', required by 'cairo', not found

I'm not sure if that's better or not. Everything I could find about xrender seemed to be outdated.

H_TeXMeX_H 01-30-2007 10:06 PM

Is there a file called xrender.pc in '/usr/lib/pkgconfig' ? (there should be ... there is for me)

Also, do you have all these installed:
Quote:

For compiling Geany yourself, you will need the GTK (>= 2.6.0) libraries and header files. You will also need the Pango, Glib and ATK libraries and header files.
EDIT: If it really doesn't work I could upload a binary of it if you want me to.

JAKK 01-30-2007 11:10 PM

Hi. I do not have the xrender file. However,I'm not sure what to do since all searches showed that xrender was old and had some vulnerabilities. I could not find any xrender package for slackware. I checked,and I do have all other packages.

H_TeXMeX_H 01-31-2007 09:53 PM

xrender might be a part of x11 ? Anyone know which package it is a part of ? I don't have time to look right now. Reinstall all the packages in the x directory on the DVD/CD, it should be in one of them ... or check them one by one.

JAKK 01-31-2007 11:55 PM

Hi. I had to install x11-devel to get it to work. Thanks for your help.

H_TeXMeX_H 02-01-2007 12:08 AM

Great ... no problem :)

BCarey 02-02-2007 03:37 PM

Quote:

Anyone know which package it is a part of ?
If you want to know what package an installed file belongs to you can just

Code:

grep -r filename /var/log/packages
Slackware: The joy of simplicity:-)

Brian


All times are GMT -5. The time now is 03:22 PM.