LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   PHP 5.2.3 http wrapper issue in current (http://www.linuxquestions.org/questions/slackware-14/php-5-2-3-http-wrapper-issue-in-current-559890/)

hsrthe4th 06-07-2007 08:05 AM

PHP 5.2.3 http wrapper issue in current
 
The http wrapper class in php has stopped working after the last round of updates.

I am using Slacker current, php-5.2.3-i486-1, httpd-2.2.4-i486-3

The exact error I get is
Quote:

Unable to find the wrapper http - did you forget to enable it when you configured PHP?
I have allow_url_fopen = On in php.ini.

An example that generates the error:
PHP Code:

$file fopen ("http://www.php.net/""r"); 

If i use fopen on a local file it works fine.


I have rolled php back to php-5.2.2-i486-2 with and that fixed the problem.

hsrthe4th 07-01-2007 11:00 AM

I am having the same issue with php-5.2.3-i486-2
While running 5.2.2 when i run php -i I get:
Code:

Registered PHP Streams => php, file, data, http, ftp
After the upgrade to 5.2.3:
Code:

Registered PHP Streams => php, file, data
Is there a way to register the other two streams (http or ftp) either as a compile option or in the ini?

conandor 08-15-2008 06:28 AM

Quote:

Originally Posted by hsrthe4th (Post 2806761)
I am having the same issue with php-5.2.3-i486-2
While running 5.2.2 when i run php -i I get:
Code:

Registered PHP Streams => php, file, data, http, ftp
After the upgrade to 5.2.3:
Code:

Registered PHP Streams => php, file, data
Is there a way to register the other two streams (http or ftp) either as a compile option or in the ini?

i've similar problem. does someone ve solution for this?

keefaz 08-15-2008 07:40 AM

What is your slackware current version ?
I use slackware 12.1 stable version and:
Code:

php -v
PHP 5.2.6 (cli) (built: May  7 2008 16:16:20)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

It is php 5.2.6 here and fopen() works with URLs, I just checked it


All times are GMT -5. The time now is 11:51 AM.