LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2009, 05:58 PM   #1
danielfranca
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
Phonon: Simultaneous sound problem


Hello, I'm using Slackware 12.1 + KDE 4.1
I'm getting problems with the simultaneous sound of applications that use Phonon. Ex: If I run 2 applications that don't use Phonon like Audacious and VLC, the sound works fine. but if I run application that use Phonon like Amarok2 and SmPlayer, then the sound works only in the first application that I opened.
Here's the error that appear in SMPlayer when the sound is being used by Amarok2:
Debug: [15:32:37] MplayerProcess:arseLine: '[AO_ALSA] alsa-lib: pcm_hw.c:1099snd_pcm_hw_open) open /dev/snd/pcmC0D0p failed: Device or resource busy'
Debug: [15:32:37] MplayerProcess:arseLine: '[AO_ALSA] alsa-lib: pcm_dmix.c:866snd_pcm_dmix_open) unable to open slave'

The backend is xine

When I run one of this Phonon applications I get a message like that:
Audio Device Playback HDA VIA VT82xx (Analog) does not work
Falling back to HDA VIA VT82xx (Front speakers)

A ordem de preferencia dos output devices ta a seguinte:
My preference order output devices is that:
HDA VIA VT82xx(ALC861 Analog)
ESound(ESD)
aRts

This starts to happen after I try to optimize my boot time, So I get some hints from internet, I take off some scripts from startup and put my modules at rc.modules.
Here's the scrips active and inactive (the active have a '*' )
lrwxrwxrwx 1 root root 4 2008-10-22 21:03 rc.0 -> rc.6*
-rwxr-xr-x 1 root root 1282 2007-03-26 22:12 rc.4*
-rwxr-xr-x 1 root root 7358 2007-06-13 01:27 rc.6*
-rwxr-xr-x 1 root root 2322 2007-05-02 18:29 rc.K*
-rwxr-xr-x 1 root root 10758 2009-01-02 11:35 rc.M*
-rwxr-xr-x 1 root root 13949 2008-03-08 05:01 rc.S*
-rw-r--r-- 1 root root 466 2004-11-05 06:20 rc.acpid
-rwxr-xr-x 1 root root 2671 2008-04-01 02:18 rc.alsa*
-rw-r--r-- 1 root root 1032 2003-02-02 01:47 rc.atalk
-rw-r--r-- 1 root root 3116 2008-04-13 18:48 rc.bind
-rw-r--r-- 1 root root 3438 2008-02-22 18:50 rc.bluetooth
-rw-r--r-- 1 root root 106 2008-02-22 18:50 rc.bluetooth.conf
-rw-r--r-- 1 root root 4318 2008-04-28 23:38 rc.cups
-rw-r--r-- 1 root root 512 2008-02-28 03:11 rc.dnsmasq
-rw-r--r-- 1 root root 119 2004-05-30 01:19 rc.font.new
-rw-r--r-- 1 root root 1893 2008-03-07 22:52 rc.fuse
-rw-r--r-- 1 root root 1156 2008-10-22 21:15 rc.gpm
-rw-r--r-- 1 root root 906 2008-04-01 19:07 rc.hald
-rw-r--r-- 1 root root 703 2008-02-14 19:39 rc.httpd
-rwxr-xr-x 1 root root 9237 2007-06-30 23:04 rc.inet1*
-rw-r--r-- 1 root root 3579 2008-10-22 21:16 rc.inet1.conf
-rwxr-xr-x 1 root root 4847 2007-09-17 19:07 rc.inet2*
-rw-r--r-- 1 root root 497 2003-09-12 00:27 rc.inetd
-rw-r--r-- 1 root root 1924 2003-09-13 20:10 rc.ip_forward
-rwxr-xr-x 1 root root 146 2008-10-22 21:11 rc.keymap*
-rwxr-xr-x 1 root root 272 2006-08-11 23:07 rc.local*
-rw-r--r-- 1 root root 1560 2008-03-15 03:26 rc.messagebus
lrwxrwxrwx 1 root root 23 2008-10-22 21:03 rc.modules -> rc.modules-2.6.24.5-smp*
-rwxr-xr-x 1 root root 31891 2008-04-30 16:10 rc.modules-2.6.24.5*
-rwxr-xr-x 1 root root 33772 2009-01-02 12:05 rc.modules-2.6.24.5-smp*
-rw-r--r-- 1 root root 2585 2008-04-28 18:54 rc.mysqld
-rw-r--r-- 1 root root 2457 2008-04-01 00:09 rc.nfsd
-rw-r--r-- 1 root root 561 2007-05-07 02:15 rc.ntpd
-rw-r--r-- 1 root root 1722 2007-03-16 18:09 rc.pcmcia
-rw-r--r-- 1 root root 3890 2008-05-03 14:01 rc.postgresql
-rw-r--r-- 1 root root 1402 2007-05-17 19:53 rc.rpc
-rw-r--r-- 1 root root 791 2008-03-15 17:52 rc.samba
-rw-r--r-- 1 root root 1169 2006-05-27 17:24 rc.saslauthd
-rw-r--r-- 1 root root 687 2002-06-04 18:09 rc.sendmail
-rw-r--r-- 1 root root 2895 2008-03-31 18:56 rc.serial
-rw-r--r-- 1 root root 895 2008-02-29 03:16 rc.snmpd
-rw-r--r-- 1 root root 1477 2008-04-04 13:28 rc.sshd
-rwxr-xr-x 1 root root 981 2007-04-09 20:10 rc.syslog*
-rwxr-xr-x 1 root root 1740 1999-09-11 17:48 rc.sysvinit*
-rwxr-xr-x 1 root root 3920 2007-09-24 12:38 rc.udev*
-rwxr-xr-x 1 root root 12283 2008-04-23 17:50 rc.wireless*
-rw------- 1 root root 7320 2008-04-23 17:50 rc.wireless.conf
-rwxr-xr-x 1 root root 2323 2005-07-31 20:56 rc.yp*


Here's the list of modules in rc.modules:
/sbin/modprobe snd_seq_dummy
/sbin/modprobe snd_seq_oss
/sbin/modprobe snd_seq_midi_event
/sbin/modprobe snd_seq
/sbin/modprobe snd_pcm_oss
/sbin/modprobe snd_mixer_oss
/sbin/modprobe snd_hda_intel
/sbin/modprobe snd_usb_audio
/sbin/modprobe snd_pcm
/sbin/modprobe snd_timer
/sbin/modprobe snd_page_alloc
/sbin/modprobe snd_usb_lib
/sbin/modprobe snd_rawmidi
/sbin/modprobe snd_seq_device
/sbin/modprobe snd_hwdep
/sbin/modprobe snd
/sbin/modprobe soundcore

/sbin/modprobe nvidia
/sbin/modprobe amd64_agp
/sbin/modprobe sn9c102
/sbin/modprobe videodev
/sbin/modprobe via_agp
/sbin/modprobe i2c_viapro
/sbin/modprobe agpgart
/sbin/modprobe v4l1_compat
/sbin/modprobe v4l2_common

/sbin/modprobe ipv6
/sbin/modprobe fuse
/sbin/modprobe serio_raw
/sbin/modprobe compat_ioctl32
/sbin/modprobe button
/sbin/modprobe psmouse

/sbin/modprobe thermal
/sbin/modprobe processor
/sbin/modprobe shpchp

/sbin/modprobe rtc_cmos
/sbin/modprobe rtc_core
/sbin/modprobe rtc_lib

/sbin/modprobe k8temp
/sbin/modprobe evdev
/sbin/modprobe hwmon
/sbin/modprobe sg

/sbin/modprobe mii
/sbin/modprobe via_rhine

/sbin/modprobe lp
/sbin/modprobe parport_pc
/sbin/modprobe parport

I tried to go back to state before that, but with no success.

Another informations:

daniel@daniel:/etc/rc.d$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: VT82xx [HDA VIA VT82xx], device 0: ALC861 Analog [ALC861 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

daniel@daniel:/etc/rc.d$ cat /proc/modules
fuse 45588 2 - Live 0xf9023000
ipv6 234724 8 - Live 0xf90dd000
snd_pcm_oss 40352 0 - Live 0xf9030000
snd_mixer_oss 17920 1 snd_pcm_oss, Live 0xf9002000
snd_seq_oss 32896 0 - Live 0xf9019000
snd_seq_midi_event 10112 1 snd_seq_oss, Live 0xf8ff0000
snd_seq_dummy 6660 0 - Live 0xf8ed4000
snd_seq 50256 5 snd_seq_oss,snd_seq_midi_event,snd_seq_dummy, Live 0xf900b000
lp 13348 0 - Live 0xf8ff6000
snd_usb_audio 79584 0 - Live 0xf8fa5000
snd_hda_intel 289052 3 - Live 0xf904e000
snd_pcm 72068 4 snd_pcm_oss,snd_usb_audio,snd_hda_intel, Live 0xf8fdd000
snd_timer 22532 2 snd_seq,snd_pcm, Live 0xf8f34000
snd_page_alloc 11528 2 snd_hda_intel,snd_pcm, Live 0xf8f98000
sn9c102 125444 0 - Live 0xf8fbd000
rtc_cmos 11040 0 - Live 0xf8f94000
snd_usb_lib 18432 1 snd_usb_audio, Live 0xf8f8e000
rtc_core 18696 1 rtc_cmos, Live 0xf8f88000
nvidia 6896464 36 - Live 0xf9684000 (P)
amd64_agp 13316 0 - Live 0xf8f41000
compat_ioctl32 5120 1 sn9c102, Live 0xf8ef8000
thermal 16540 0 - Live 0xf8f3b000
serio_raw 9092 0 - Live 0xf8efc000
snd_rawmidi 22560 1 snd_usb_lib, Live 0xf8f21000
rtc_lib 6528 1 rtc_core, Live 0xf8eef000
videodev 29824 1 sn9c102, Live 0xf8f2b000
button 10000 0 - Live 0xf8ef4000
via_agp 12032 1 - Live 0xf8ecb000
snd_seq_device 10380 4 snd_seq_oss,snd_seq_dummy,snd_seq,snd_rawmidi, Live 0xf8ed0000
processor 32680 1 thermal, Live 0xf8eb7000
agpgart 30664 3 nvidia,amd64_agp,via_agp, Live 0xf8ee1000
v4l1_compat 17668 1 videodev, Live 0xf8e93000
shpchp 32788 0 - Live 0xf8ed7000
evdev 12672 0 - Live 0xf8eb2000
psmouse 40336 0 - Live 0xf8ec0000
snd_hwdep 10756 2 snd_usb_audio,snd_hda_intel, Live 0xf8eae000
i2c_viapro 11156 0 - Live 0xf8e8c000
k8temp 8192 0 - Live 0xf8e90000
via_rhine 24968 0 - Live 0xf8ea6000
hwmon 6276 1 k8temp, Live 0xf8e89000
v4l2_common 19200 2 sn9c102,videodev, Live 0xf8cfa000
snd 47716 16 snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_seq,snd_usb_audio,snd_hda_intel,snd_pcm,snd_timer,snd_rawm idi,snd_seq_device,snd_hwdep, Live 0xf8e99000
soundcore 9824 1 snd, Live 0xf8cf6000
mii 8448 1 via_rhine, Live 0xf8cf2000
parport_pc 27556 1 - Live 0xf8e81000
parport 34632 2 lp,parport_pc, Live 0xf8cda000
sg 30224 0 - Live 0xf8ce5000

And I executed alsaconf and alsamixer, but it didnt solved too.
 
Old 02-27-2013, 08:32 PM   #2
Geremia
Member
 
Registered: Apr 2011
Distribution: Slackware 14.1
Posts: 219

Rep: Reputation: 5
multiple apps can't use ALSA/Phonon

I've had this problem ever since I updated to KDE 4.9; I have 4.10 now. Any solution?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Phonon and GNOME? LinuxNoob75 Linux - Desktop 1 03-16-2008 08:24 PM
LXer: Phonon: Where QT and KDE meet LXer Syndicated Linux News 0 12-28-2007 10:20 AM
Simultaneous sound red_hax0r Linux - Hardware 5 07-05-2006 01:35 AM
LXer: Phonon: Multimedia in KDE 4 LXer Syndicated Linux News 0 04-28-2006 08:33 AM
Can't play simultaneous sounds with my sound card The_Avatar Slackware 1 10-22-2004 12:46 PM


All times are GMT -5. The time now is 12:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration