LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-05-2012, 02:57 PM   #1
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Rep: Reputation: Disabled
Permissions For External HD Won't Save


Hello,

I'm trying to set the permissions for an external HD so that my main user account (and any other accounts I may create in the future) can write to it (at the moment it is read-only). I've tried everything I can figure to change them, namely running chmod as root and logging in as root and using the GUI, but as soon as the permissions change finishes the permissions themselves revert back to how they were originally. I've tried editing the permissions of the folders above and below the main one (that being mnt/external, with the one up obviously being /mnt, and the one below being a folder on the external HD), with no dice.

I've run chmod verbose by the way, and it shows each successive file on the HD having its permissions changed but once again the permissions revert.

Here's the general form of the commands I've been trying.

Code:
sudo chmod -R -v 777 /mnt/external/
 
Old 07-05-2012, 03:06 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,262

Rep: Reputation: 647Reputation: 647Reputation: 647Reputation: 647Reputation: 647Reputation: 647
If the drive is VFAT or NTFS then it ignores Linux permissions. In that case you would specify the user/group during the mount command (or in fstab). See the uid= and gid= values in `man ntfs-3g`, for example. Additionally, if it is an NTFS filesystem you will need to make sure it is being mounted using mount.ntfs-3g (eg. mount -t ntfs-3g) and not the regular ntfs driver, which can only mount read-only.

Last edited by T3slider; 07-05-2012 at 03:09 PM.
 
1 members found this post helpful.
Old 07-05-2012, 03:21 PM   #3
Malacoda93
LQ Newbie
 
Registered: Apr 2012
Distribution: Slackware 14.0
Posts: 11

Original Poster
Rep: Reputation: Disabled
It is vfat, and it isn't mounting read only, as root has full permissions.

I'll have to check to confirm (I'm on one of my other machines at the moment), but I'm around 99% sure I've given the relevant user group permissions in fstab, as I am able to mount it as my main user account, not just as root.

EDIT: As I thought, the relevant lines are as is -

From /etc/fstab:

Code:
/dev/sdb1         /mnt/external    vfat         defaults,users          0   0
and from /etc/group:

Code:
users:x:100:deadpool
where deadpool is my main user account...

EDIT: Wait, now I might be seeing it, does 'defaults' override the 'users' command? deadpool is also a member of plugdev, which if I recall correctly automounts all applicable volumes...

LAST EDIT: Bingo, I've got it working. Thanks for the push in the right direction, but it's definitely rewarding when you figure it out yourself.

Last edited by Malacoda93; 07-05-2012 at 03:37 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My external HDD is damaged; How to save my data? digitsm Linux - Hardware 6 05-31-2010 11:11 AM
How to Save Data to an External Hard Drive on SUSE10SP1 Sloppyunderfoot Linux - Hardware 0 09-23-2007 04:29 PM
Shell Script to save/restore files and dir permissions joangopan Fedora 1 09-09-2007 02:51 AM
Why cant I save a pic after changing it in gimp, permissions problem? M$ISBS Linux - Software 3 08-08-2005 12:27 AM
File Permissions/ Can't save or delete website files friendlyflier Linux - Security 4 08-07-2005 06:32 AM


All times are GMT -5. The time now is 09:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration