LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Perl - undefined symbol error since -current updates (http://www.linuxquestions.org/questions/slackware-14/perl-undefined-symbol-error-since-current-updates-4175417121/)

bg4 07-17-2012 03:15 AM

Perl - undefined symbol error since -current updates
 
G'Day,

After the updates on Friday 13th (32bit) I seem to have a broken Perl installation. The error message I get when any perl program that uses a database is:
Code:

/usr/bin/perl: symbol lookup error: /usr/lib/perl5/site_perl/5.12.3/i486-linux-thread-multi/auto/BDI/DBI.so: undefined symbol: Perl_Istack_sp_ptr
Unfortunately, I don't know where to start looking for a solution. Any pointers would be most helpful.

Thanks, BG4.

pan64 07-17-2012 03:21 AM

try a clean install instead of an update

XGizzmo 07-17-2012 06:25 AM

Something is broken DBI.so is part of the perl package, your path indicates perl-5.12.3 but -current is perl-5.16.0.
How did you update perl?

bg4 07-17-2012 05:58 PM

Thanks for the replies.

I did a "slackpkg update" "slackpkg install-new" "slackpkg upgrade-all". The mirror I used was the tds.net one.

I have tried a "slackpkg reinstall perl" which comes up with "perl-5.16.0-i482-2.txz" as the package installed. But it made no difference.

Out of desperation I have renamed the 5.12.3 directories to 5.16.0 and it seems to have solved the problem....I will test further.

Thanks for the suggestions..

BG4.

CTM 07-17-2012 06:57 PM

It looks like you've upgraded DBI and then upgraded the Perl package installed on your system (your offending DBI is in site_perl and Slackware's is in vendor_perl, with modules in site_perl taking precedence).

Ideally, you want to remove modules compiled/installed under 5.12.3 and reinstall them under 5.16.0. It doesn't matter for pure-Perl modules (assuming they'll still work with new versions of Perl's core modules, which they will, because that's how Perl rolls), but with XS modules like DBI you'll run into problems.

Code:

# cpanp -i DBI
will fix you.

bg4 07-21-2012 02:42 AM

Solved
 
Thank you CTM,

That fixed the problem. All good now, thank you.

BG4


All times are GMT -5. The time now is 12:39 PM.