LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-20-2009, 02:48 PM   #1
bonaire
Member
 
Registered: Jun 2008
Location: Bonn/Germany
Distribution: Slackware-13.37
Posts: 94

Rep: Reputation: 19
pass options to modules in mkinitrd.conf


Hello,


my /etc/mkinitrd.conf:
Code:
SOURCE_TREE="/boot/initrd-tree"
CLEAR_TREE="1"
OUTPUT_IMAGE="/boot/initrd.gz"
KERNEL_VERSION="2.6.30.2-smp"
KEYMAP="de-latin1-nodeadkeys"
MODULE_LIST="ehci_hcd:uhci_hcd:usb_storage:xfs:ext2:i915 modeset=1:intel_agp"
LUKSDEV="/dev/mapper/vg-root"
ROOTDEV="crypt-vg-root"
ROOTFS="xfs"
LVM="1"
If i call this via mkinitrd -F, i get these messages:
Code:
/sbin/mkinitrd: line 376: [: ehci_hcd:uhci_hcd:usb_storage:xfs:ext2:i915: binary operator expected
/sbin/mkinitrd: line 400: [: ehci_hcd:uhci_hcd:usb_storage:xfs:ext2:i915: binary operator expected
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/usb/host/ehci-hcd.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/usb/host/uhci-hcd.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/usb/storage/usb-storage.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/fs/exportfs/exportfs.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/fs/xfs/xfs.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/fs/ext2/ext2.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/i2c/i2c-core.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/video/output.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/hwmon/hwmon.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/thermal/thermal_sys.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/acpi/video.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/i2c/algos/i2c-algo-bit.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/char/agp/agpgart.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/gpu/drm/drm.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/gpu/drm/i915/i915.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/char/agp/agpgart.ko added.
OK: /lib/modules/2.6.30.2-smp/kernel/drivers/char/agp/intel-agp.ko added.
11484 blocks
If i don't pass the modeset option to the i915 module, all is fine. Is there something wrong with my syntax or is it a bug?
The man page man mkinitrd.conf says, that my syntax is ok:
Code:
       MODULE_LIST
            This  should  be a colon-separated list of modules you wish to be included in the initrd
            image.
            Example: MODULE_LIST="ext3:mbcache:jbd"

            If you have loadtime options that you need to specify when loading kernel modules, those
            can be added here as well.
            Example: MODULE_LIST="module1:module2 option=1:module3"
cu


Edit:
I forgot, my system is slackware-current

Last edited by bonaire; 07-20-2009 at 02:51 PM. Reason: system version added
 
Old 07-20-2009, 03:55 PM   #2
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
I think this is a bug in mkinitrd. Open /sbin/mkinitrd as root and, in lines 376 and 400, write double quotes around ${MODULE_LIST}, so it looks "${MODULE_LIST}". That should probably solve the problem. Please report success.
 
Old 07-20-2009, 04:16 PM   #3
bonaire
Member
 
Registered: Jun 2008
Location: Bonn/Germany
Distribution: Slackware-13.37
Posts: 94

Original Poster
Rep: Reputation: 19
That helped, thanks.

Shall i write an email, or is it enough, that this is written here?

cu
 
Old 07-20-2009, 04:43 PM   #4
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
I just wrote P. Volkerding an email about this.
 
Old 07-20-2009, 04:44 PM   #5
bonaire
Member
 
Registered: Jun 2008
Location: Bonn/Germany
Distribution: Slackware-13.37
Posts: 94

Original Poster
Rep: Reputation: 19
Ok, thanks again
 
Old 08-03-2009, 04:09 PM   #6
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 498

Rep: Reputation: Disabled
There have been quite a few upgrades since I wrote the email but no reply from PV and no fixed package. I'm just bumping the thread so this gets attention by any member of the Slackware team and the problem is fixed before Slackware 13.0 is released.
 
Old 08-14-2009, 09:18 PM   #7
bonaire
Member
 
Registered: Jun 2008
Location: Bonn/Germany
Distribution: Slackware-13.37
Posts: 94

Original Poster
Rep: Reputation: 19
Thanks a lot

Last edited by bonaire; 08-14-2009 at 09:21 PM.
 
Old 08-14-2009, 09:36 PM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
@bonaire: I tried to reply to your email inquiring about this, but here's what I received in reply to it:
Code:
From postmaster@goodmails.de Fri Aug  7 12:05:44 2009
Date: Fri,  7 Aug 2009 21:02:01 +0200 (CEST)
From: Mail Delivery System <postmaster@goodmails.de>
To: rworkman@slackware.com
Subject: Returned mail: see mail body for details

The original message was received at Fri, 07 Aug 2009 21:02:01 +0200 from rworkman@slackware.com by b1gMail/6.3.0.

Error: Your mail was blocked by a filter
 
Old 08-14-2009, 11:09 PM   #9
bonaire
Member
 
Registered: Jun 2008
Location: Bonn/Germany
Distribution: Slackware-13.37
Posts: 94

Original Poster
Rep: Reputation: 19
Ah, ok. The provider gets an unfriendly email

cu
 
Old 08-14-2009, 11:15 PM   #10
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,904

Rep: Reputation: Disabled
Quote:
Originally Posted by bonaire View Post
Ah, ok. The provider gets an unfriendly email
Just so you know, I'm going to laugh if it gets "blocked by a filter" too. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Example modules.conf for mkinitrd hq4ever Linux - Hardware 0 06-25-2006 06:10 AM
mkinitrd and module options rnturn Linux - Software 3 02-14-2005 10:21 PM
Conf.modules Vs Modules.conf Issue, lost eth0 initialization LinuxFreebie41 Linux - General 3 11-04-2004 06:02 AM
modules.conf question, options gpeterson1 Linux - Hardware 6 02-24-2003 04:08 PM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - Newbie 2 01-24-2002 01:40 AM


All times are GMT -5. The time now is 06:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration