LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Pandora.com / Firefox / No Sound (http://www.linuxquestions.org/questions/slackware-14/pandora-com-firefox-no-sound-469951/)

chasingmytail 08-02-2006 12:14 AM

Pandora.com / Firefox / No Sound
 
I'm pretty sure the Subject sums it up. I'm running a custom 2.6 kernel (sound works perfectly), Firefox 1.5, and Flash 7.

I just started using Pandora.com at work on my 'Doze box and want to use it at home! Nothing i've done seems to work. I also have all the latest codecs from mplayer (shouldn't make a difference ...) installed but no music!

Anyone else run into a problem with this site & found a solution???


Thanks!

simcox1 08-02-2006 02:32 AM

You could have provided a link to it. Anyway sound works fine for me. 2.4.31 kernel.

chasingmytail 08-02-2006 08:12 PM

Hmm, I was unable to obtain any benefit from that post. I guess that's one way to artificially bump up your post count so you don't look like a n00b.

Pandora Internet Radio ... or ctl-c, ctl-v for the unfingerless.

:twocents:


Anywho, for any other person who does a search for this particular problem looking for something informative and can't find a clear answer anywhere I'll answer this myself ...


The problem was with Flash & Firefox and how they communicated with ALSA-OSS ...

I was unable to find a location where I could set the FIREFOX_DSP=”aoss” parameter (apparently some version used a settings file firefoxrc, which my version/installation doesn't) as some were recommending.


It seems that once I ran firefox from "aoss firefox", the sound worked. (I only needed to do this once, wierd).

From then on I was able to run Firefox from my normal Quick Launcher icon and everything is just shiny!

frank golden 09-28-2006 12:11 AM

Quote:

Originally Posted by chasingmytail
Hmm, I was unable to obtain any benefit from that post. I guess that's one way to artificially bump up your post count so you don't look like a n00b.

Hi Chasingmytail,
Funny.

I have been looking for the answer to this vexing problem for awhile
now. In Ubuntu it was an issue with my using an external USB soundcard
with my notebook.no sound from flash (Pandora,YouTube etc.).
Fix there was to blacklist my built in sound card. No go with PCLinuxOS.
Using your info I changed the launcher application target from "/usr/bin/mozilla-firefox" to "usr/bin/aoss mozilla-firefox". Just shiny indeed!! Thank you. I posted a detailed description here a couple of days ago, got 34 hits no replys. Just stumbled across your post. The sound in
in YouTube is out of sync by about 500 milliseconds but I have learned
that it a result of Flash 7 and will be addressed by Adobe in the next
Linux flash release (early 2007).
BTW, I had discovered a work around to this. If flash sites are opened in
konqueror sound works. The lag at YouTube is a full 7 seconds though.

It amazes me that no one seemed to know the simple solution to this issue.

Again thanks I can stop chasing my tail over this one.:)

chasingmytail 09-29-2006 08:41 AM

I'm glad my post was able to help you find a solution!

Out of curiousity, what version of firefox are you running? The reason I ask that I only needed to launch Firefox ONCE from a command prompt using the "aoss firefox" command. After that first time, I never had to do it again or change any of my shortcuts to firefox (i'm using KDE by the way), it just worked!

My guess is that Firefox changes it's settings when you use that command ...

As far as YouTube, I haven't noticed that problem, although now I'm not sure if I've been on that site on that particular machine! I'll have to check now when I get home.

frank golden 09-30-2006 05:07 AM

Quote:

Originally Posted by chasingmytail
I'm glad my post was able to help you find a solution!

Out of curiousity, what version of firefox are you running? The reason I ask that I only needed to launch Firefox ONCE from a command prompt using the "aoss firefox" command. After that first time, I never had to do it again or change any of my shortcuts to firefox (i'm using KDE by the way), it just worked!

My guess is that Firefox changes it's settings when you use that command ...

As far as YouTube, I haven't noticed that problem, although now I'm not sure if I've been on that site on that particular machine! I'll have to check now when I get home.

Hi chasingmytail,
I'm using the latest version of FFox in all my distros. (1.5.7)
As far as video is concerned it starts out about 500 milliseconds out
of synch and gets worse from there. I'm hoping that v.9 of Flash for linux will fix this.


All times are GMT -5. The time now is 10:56 PM.