LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-04-2013, 02:02 AM   #1
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Skackware
Posts: 76

Rep: Reputation: 5
OpenVPN not found libpam


Slackware64 14.0
Compile openvpn (default slackbuild)
version of openvpn 2.3.0

log: ftp://ifconfig.com.ua/incoming/log/openvpnlog.txt

In Slackware not installed PAM by default.
How to disable PAM for build OpenVPN without error?
 
Old 02-04-2013, 02:54 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,410

Rep: Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853
to see the available building options, in general, extract the sources and do a
Code:
$ ./configure --help | grep -i whatever
Code:
./configure --help | grep -i pam
  --disable-plugin-auth-pam
                          disable auth-pam plugin [default=platform specific]
  --enable-pam-dlopen     dlopen libpam [default=no]
  LIBPAM_CFLAGS
              C compiler flags for libpam
  LIBPAM_LIBS linker flags for libpam
so, in this case, the answer is to add --disable-plugin-auth-pam to the configure line.
 
1 members found this post helpful.
Old 02-04-2013, 03:06 AM   #3
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Skackware
Posts: 76

Original Poster
Rep: Reputation: 5
Thanks!!!
I inconsiderate
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [CentOS] Unable to login: libpam.so.0 not found chekhov_neo Linux - Enterprise 4 04-04-2012 01:52 AM
Dovecot installation - libpam not found onik Linux - Software 4 06-24-2008 05:09 PM
OpenVPN build LZO not found libsys Linux - Software 4 07-15-2005 08:54 AM
libpam.so.0 no found! vbbjq Slackware 3 08-03-2004 08:05 AM
Help with libpam.so.0 piles Linux - Software 0 07-02-2003 08:44 AM


All times are GMT -5. The time now is 04:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration