-   Slackware (
-   -   OpenVPN not found libpam (

StreamThreader 02-04-2013 03:02 AM

OpenVPN not found libpam
Slackware64 14.0
Compile openvpn (default slackbuild)
version of openvpn 2.3.0


In Slackware not installed PAM by default.
How to disable PAM for build OpenVPN without error?

ponce 02-04-2013 03:54 AM

to see the available building options, in general, extract the sources and do a

$ ./configure --help | grep -i whatever

./configure --help | grep -i pam
                          disable auth-pam plugin [default=platform specific]
  --enable-pam-dlopen    dlopen libpam [default=no]
              C compiler flags for libpam
  LIBPAM_LIBS linker flags for libpam

so, in this case, the answer is to add --disable-plugin-auth-pam to the configure line.

StreamThreader 02-04-2013 04:06 AM

I inconsiderate :)

All times are GMT -5. The time now is 06:06 AM.