LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-13-2010, 10:27 PM   #1
greenpenguin246
LQ Newbie
 
Registered: Jan 2004
Location: Minneapolis, MN
Distribution: Slack 13
Posts: 25

Rep: Reputation: 15
Openoffice slackbuild installs but won't run


I downloaded the slackbuilds openoffice.org files, extracted them, added the original source, ran chmod +x openoffice.org.SlackBuild, ran ./openoffice.org.SlackBuild, then found the resulting .tgz and installpkg'ed it. I was able to get through all of the steps listed without any error messages and everything seemed to be going well. However, now when I navigate to opt/openoffice.org3 (the created folder) and attempt to run any of the programs from kde nothing happens. When I attempt to run them in terminal I get the following message:

root@slacktop:~# soffice
/usr/bin/soffice: line 98: /opt/openoffice.org3/program/../basis-link/program/pagein: No such file or directory
/usr/bin/soffice: line 104: /opt/openoffice.org3/program/../basis-link/ure-link/bin/javaldx: No such file or directory
/usr/bin/soffice: line 129: /opt/openoffice.org3/program/soffice.bin: No such file or directory

is there some reason these files wouldn't be in there after a normal installation? I read the howto on slackbuilds.org several times to make sure I got all the steps right, and have tried uninstalling with removepkg and reinstalling and the same thing keeps happening. I'm sure its obvious to most of you, but what am I missing?
 
Old 05-14-2010, 02:57 PM   #2
meetscott
Samhain Slackbuild Maintainer
 
Registered: Sep 2004
Location: Phoenix, AZ, USA
Distribution: Slackware
Posts: 407

Rep: Reputation: 42
Did you check the integrity of each of our downloads with the md5sums that are published? I've had plenty of corrupted downloads in my day. I'd make sure there are no other issues first. Then move onto the next thing. I've seen things exactly like this myself.

Last edited by meetscott; 05-14-2010 at 03:13 PM. Reason: typo
 
Old 05-14-2010, 03:11 PM   #3
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Are you running a 64-bit system and installing a 32-bit OpenOffice?
http://slackbuilds.org/faq/#x86_64
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot install SlackBuild OpenOffice.org 3.2.0 on Slackware 13 aes canis Slackware 6 03-09-2010 03:44 AM
[SOLVED] Need help with openoffice slackbuild damgar Slackware 8 11-17-2009 03:16 PM
SlackBuild for OpenOffice? corbis_demon Slackware 9 10-13-2009 05:43 AM
Slackbuild for OpenOffice arubin Slackware 9 01-05-2008 01:27 AM
Firefox installs but won't run BertBert Linux - Software 1 06-03-2004 04:25 PM


All times are GMT -5. The time now is 05:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration