LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-27-2005, 02:52 AM   #1
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Rep: Reputation: 45
openoffice 1.1.4 killed in gnome and xfce but not kde and fluxbox


Hi!

OpenOffice 1.1.4 always get killed in gnome 2.6. And in xfce 4.2 managed to get it up twice with multiple homicide before and after the two successful starts.

In fluxbox and kde, no problem starting at all.

Am using Slackware 10.1 beta, not everything though, most of the things.Didn't upgrade kde to the latest one.

Here is the error message I get from xfce in the terminal
Code:
root@carboncopy:/# soffice
ICE default IO error handler doing an exit(), pid = 3234, errno = 0
pure virtual method called


Fatal exception: Signal 6
Stack:
/opt/OpenOffice.org1.1.4/program/libsal.so.3[0x40bd63a8]
/opt/OpenOffice.org1.1.4/program/libsal.so.3[0x40bd6532]
/opt/OpenOffice.org1.1.4/program/libsal.so.3[0x40bd65f8]
/lib/libpthread.so.0[0x41139e65]
[0xffffe420]
/lib/libpthread.so.0(raise+0x2b)[0x4113710b]
/lib/libc.so.6(gsignal+0x44)[0x412f5c04]
/lib/libc.so.6(abort+0x16d)[0x412f74dd]
/opt/OpenOffice.org1.1.4/program/libstdc++.so.5[0x412b0424]
/opt/OpenOffice.org1.1.4/program/libstdc++.so.5[0x412b0471]
/opt/OpenOffice.org1.1.4/program/libstdc++.so.5[0x412b0927]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427da0e8]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427da1ba]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x4269d14d]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x426999cb]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x42695f88]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x426a8793]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427807aa]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x4279c935]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x4279b8ac]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427997bb]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427a7623]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427a399f]
/opt/OpenOffice.org1.1.4/program/libcfgmgr2.so[0x427c1949]
/opt/OpenOffice.org1.1.4/program/libutl645li.so(_ZN3utl10ConfigItemD2Ev+0x73)[0x408e704d]
/opt/OpenOffice.org1.1.4/program/libvcl645li.so(_ZN3vcl21DefaultFontConfigItemD0Ev+0x84)[0x40193632]
/opt/OpenOffice.org1.1.4/program/libvcl645li.so(_Z16ImplDeInitSVDatav+0x4a)[0x400ebd6e]
/opt/OpenOffice.org1.1.4/program/libvcl645li.so(_ZN11ApplicationD2Ev+0x27)[0x400e8a83]
/opt/OpenOffice.org1.1.4/program/soffice.bin(_ZN7desktop7DesktopD1Ev+0x36)[0x8060398]
/opt/OpenOffice.org1.1.4/program/soffice.bin[0x806caae]
/opt/OpenOffice.org1.1.4/program/soffice.bin[0x806caf0]
/opt/OpenOffice.org1.1.4/program/soffice.bin(_ZN6Window11RequestHelpERK9HelpEvent+0x76)[0x805ea3a]
/opt/OpenOffice.org1.1.4/program/soffice.bin[0x808a089]
/lib/libc.so.6(exit+0x62)[0x412f8632]
/usr/X11R6/lib/libICE.so.6[0x4104e0c3]
/usr/X11R6/lib/libICE.so.6(_IceRead+0xe4)[0x4104f434]
/usr/X11R6/lib/libICE.so.6(IceProcessMessages+0x57)[0x4104f947]
/opt/OpenOffice.org1.1.4/program/libvcl645li.so(ICEConnectionWorker+0x15e)[0x402c7f76]
/opt/OpenOffice.org1.1.4/program/libsal.so.3[0x40bcb64d]
/lib/libpthread.so.0[0x4113473e]
/lib/libc.so.6(__clone+0x5a)[0x4138608a]
Killed
How can I fix this?
 
Old 01-27-2005, 03:52 AM   #2
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Mind boggling me. I think it has got to do with java. Why I say this?

After further testing under xfce, I found out that it would only get killed after I have bring up Azureus. Even though Azureus have been terminated, OO still get killed.
 
Old 01-27-2005, 04:33 AM   #3
carboncopy
Senior Member
 
Registered: Jan 2003
Location: Malaysia
Distribution: Fedora Core, Slackware, Mac OS X, Debian, OpenSUSE
Posts: 1,210
Blog Entries: 4

Original Poster
Rep: Reputation: 45
Hmm looks like I am making assumption too early.

Now, please disregard the second post.

Okay, I think I know where the problem lies. GNOME!!!!

I compared ps aux for both xfce and fluxbox while OpenOffice is loading. In fluxbox, it only has 4 threads, while in xfce it has 5 soffice.bin threads and one getstyle-gnome. And I will have another thread by gconfd-2.

Actions I want to take:

Now, I want to remove gnome but not some of the application such as gedit, gkrellm etc. Can I remove gconfd-2?

How can I force OpenOffice to start without invoking getstyle-gnome in xfce?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE and Gnome applications in XFCE Fritz_Monroe Linux - Newbie 1 07-27-2005 02:26 PM
Fluxbox and KDE/gnome applications bad_andy Slackware 3 01-18-2005 12:29 PM
Poll on fluxbox, gnome, kde and blackbox Nz_Boy_2004 Linux - Software 11 09-07-2004 09:39 AM
Slack & fluxbox -> gnome/kde needed? BroX Slackware 14 01-28-2004 08:12 AM
XFCE and kde/gnome apps (launcher menu question) JimDog Linux - Newbie 2 10-11-2003 08:43 AM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration