LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-04-2004, 01:24 AM   #1
boutrosboutros
Member
 
Registered: Dec 2003
Location: SE US
Distribution: Debian Sarge/SID, Mepis
Posts: 47

Rep: Reputation: 15
Unhappy Opened Nautilus in KDE and then...:(


Hello,

As a new slack user i was doing a little "experimenting" earlier. Goto /usr/bin and run Nautilus while in KDE. Everything seemed fine but then i notice on my KDE (3.1.4) desktop i now have Gnome icons instead of my regular KDE ones and my desktop wallpaper is gone!!!

If i right click on the desktop the menu is the gnome menu and not the KDE one. The main KDE menu and the task bar operate correctly still but not the desktop. I logged out and then back on and my KDE icons reappeared then w/in 10 seconds of KDE starting and coming to the desktop, the KDE icons and wallpaper disappear and the gnome ones are there? I tried to reboot and the same thing.

I have searched the forums and can't find any info on this. Has anyone else experienced this? How can i fix it? Thanks so much for any help!

Peace,
Boutros
 
Old 01-04-2004, 01:32 AM   #2
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
I don't know how to fix except to delete you kde config's with
rm -rf .kde* But I would wait to do that because someone else may have a better solution

In the future if you want to run Nautilus in KDE

Try

nautilus --no-desktop

Last edited by darthtux; 01-04-2004 at 01:35 AM.
 
Old 01-04-2004, 08:18 AM   #3
-X-
Member
 
Registered: Oct 2003
Location: Tx,USA
Distribution: Slackware, Red Hat, CentOS
Posts: 495

Rep: Reputation: 30
IIRC, it is the ~/.kde/share/config/ksmserverrc
You could edit this file or....
mv this file to ~/.kde/share/config/ksmserverrc.old
logout and back in to create the new file. You may need some setting from the old file.
 
Old 01-04-2004, 09:48 AM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
somewhere in the nautilus preferences there is a option labeled 'use nautilus to render desktop' unselect that option, log out, log in.
 
Old 01-04-2004, 03:12 PM   #5
boutrosboutros
Member
 
Registered: Dec 2003
Location: SE US
Distribution: Debian Sarge/SID, Mepis
Posts: 47

Original Poster
Rep: Reputation: 15
Hello All,

(RShaw) I searched all over Nautilus and even started gnome and looked for the option you mentioned. I also found an old post where you had suggested this to someone else. Under the nautilus>edit>preferences .. i do not have a tab labeled desktop and trash ... only the following tabs

views|behavior|icon captions|preview ...and they do not have the checkbox mentioned???

Do you have any ideas where i could find it?

Thanks again
Boutros
 
Old 01-04-2004, 04:02 PM   #6
boutrosboutros
Member
 
Registered: Dec 2003
Location: SE US
Distribution: Debian Sarge/SID, Mepis
Posts: 47

Original Poster
Rep: Reputation: 15
Hello Again,

I tried the first 2 ideas as well. Unfortunately they did not work. Same behavior once i logged back in the normal KDE desktop for a few seconds then on to the gnome problem!

These kind of things drive me nuts! I will be glad to get it fixed.

Have blessed day,
Boutros
 
Old 01-04-2004, 04:12 PM   #7
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
applications->system->configuration editor->apps->nautilus->preferences. unselect "show desktop"
 
Old 01-04-2004, 06:04 PM   #8
boutrosboutros
Member
 
Registered: Dec 2003
Location: SE US
Distribution: Debian Sarge/SID, Mepis
Posts: 47

Original Poster
Rep: Reputation: 15
That did it, RShaw!

Thanks so much, for your help. I went into the config editor the other time i was in gnome but i didn't make it that deep into the tree.

Be blessed,
Boutros
 
Old 01-09-2004, 12:53 PM   #9
JSkalka
LQ Newbie
 
Registered: Sep 2003
Distribution: RedHat/Solaris/AIX
Posts: 6

Rep: Reputation: 0
Quote:
Originally posted by rshaw
applications->system->configuration editor->apps->nautilus->preferences. unselect "show desktop"
I don't have that off my menu...
 
Old 01-09-2004, 01:36 PM   #10
boutrosboutros
Member
 
Registered: Dec 2003
Location: SE US
Distribution: Debian Sarge/SID, Mepis
Posts: 47

Original Poster
Rep: Reputation: 15
Hello,

Make sure that you are in gnome not kde and then open the applications menu and go from there.

I had to log off. And start a new xsession.

Peace,
Boutros
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE -device/dev/dsp - can't be opened High-gain Linux - Newbie 13 12-14-2004 10:47 AM
Nautilus on KDE, now cannot restore KDE desktop paulwhalley Slackware 0 09-21-2004 06:41 PM
Disable background image in KDE only when opened in VNC arobinson74 Linux - General 0 09-01-2004 12:18 PM
Getting error message /dev/dsp can't be opened in KDE sanfran49 Linux - Software 2 02-14-2004 11:26 AM
Nautilus cannot be opened Nasser Linux - Newbie 2 05-23-2002 04:34 AM


All times are GMT -5. The time now is 05:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration