LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Open Office slow to load spreadsheets and prints (http://www.linuxquestions.org/questions/slackware-14/open-office-slow-to-load-spreadsheets-and-prints-609842/)

arubin 12-29-2007 01:25 PM

Open Office slow to load spreadsheets and prints
 
I have noticed over the last few weeks that Open Office is taking about 10 seconds to load a spreadsheet and also slow when sending to the printer. I am having difficulty puzzling out what has changed to slow things down.

I have noticed this whether running 2.0.4 which I got from linuxpackages and after I upgraded to the 2.3 slackbuild from slackbuilds.org

Disabling the java runtime environment makes no difference. Koffice loads the same files very quickly.

And another thing. Since I moved to the slackbuild of 2.3 I seem to have lost the Open Office icons. Where are they?

Any ideas gratefully received.

arubin 12-29-2007 05:08 PM

I have sorted out the icons problem. I had made the silly mistake of using the 12 slackbuild on 11. So I have gone back to the previous package. It is still slow.

H_TeXMeX_H 12-30-2007 06:23 AM

Maybe OpenOffice is just slow. I've personally found the Spreadsheet part of it to be rather crappy. I use gnumeric instead, or as you say you could use koffice.

Franklin 12-30-2007 07:35 PM

Quote:

Originally Posted by H_TeXMeX_H (Post 3005570)
Maybe OpenOffice is just slow. I've personally found the Spreadsheet part of it to be rather crappy. I use gnumeric instead, or as you say you could use koffice.

No kidding. Without question the weakest part of the suite (IMHO).

To the OP, since you installed from different sources - Slackbuilds.org and Linuxpackages.net - you might have some crud left over from the earlier package, depending on how you upgraded the package, that is buggering up the 2.3 install. Ditto if you are running both versions side by side. You would like to think that packages are of consistent quality and built on a pristine system and put things where they belong but, unless you build them yourself you never really know. (talking about packages here, not the slackbuild.org scripts)

I would try uninstalling both and then make certain all OO.o files and directories are removed from your system before reinstalling 2.3. This includes any hidden directories in your home directory and the application files in /opt. Not sure if there might be anything worth saving so back up first as always.

HTH


All times are GMT -5. The time now is 07:47 AM.