LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   oops openssl-0.9.8e over openssl-0.9.8d bad install now 2 copies? (http://www.linuxquestions.org/questions/slackware-14/oops-openssl-0-9-8e-over-openssl-0-9-8d-bad-install-now-2-copies-565000/)

rcorkum 06-27-2007 11:40 PM

oops openssl-0.9.8e over openssl-0.9.8d bad install now 2 copies?
 
okay It was DUMB but I had searched here didn't see any threads on installing openssl that showed a required prefex so I did the default config with zlib enabled and share on (I wanted to enable IDEA support for project working on) and figured might as well build the current source)
well that was a dumb idea on my part
now openssl version shows OpenSSL 0.9.8d 28 Sep 2006

but I have 9.8e installed, and there is no make uninstall, anyone know how to cleanly remove the openssl 9.8E leaving me 9.8d and what compile prefix I should use for stock 11 slack to cleanly update my system openssl package?

bathory 06-28-2007 03:07 AM

If you used a "--prefix=/some/path/ssl" in your ./configure script you can remove that directory. As for openssl-0.9.8e the package is in current, so you can upgrade your existing openssl.

rcorkum 06-28-2007 03:10 AM

but idea won't be enabled by default and thats why I was upgrading. I did ./config share zlib so I must find the default install paths but the problem is the rest of the trailings where the man and stuff went. its an old box p1 233 my main linux box or I would have burnt off a dvd or cd before doing stuff so I could restore easier.

okay opened my mouth before i looked I got the new openssl out now what is the prefix i need to replace open ssl under slackware to match the regular structure.

jong357 06-28-2007 05:42 PM

ftp://ftp.slackware.com/pub/slackwar...ssl.SlackBuild

rcorkum 06-29-2007 02:58 AM

thank you, issue resolved, openssl now updated and compiled with the options I needed. thanks very much.


All times are GMT -5. The time now is 07:08 PM.