LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-08-2008, 11:41 AM   #1
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
One user login cannot start scim, other user logins and root OK


My normal user login is unable to start scim, ( so firefox and seamonkey do not start ), yet all is OK for other user logins and root.
If I run "scim -d" in a shell window, I see:
Quote:
Smart Common Input Method 1.4.7

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Invalid entry: q 0

Invalid entry: 0

Invalid entry: 0

Invalid entry: 0

Invalid entry: 0
This problem occurred after I had a browser crash in firefox.

Any ideas on how to fix this?
 
Old 05-08-2008, 04:12 PM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 735
Blog Entries: 3

Rep: Reputation: 81
What is the LANG parameter of the user?

For SCIM to work, you need a UTF-8 language.
 
Old 05-08-2008, 07:32 PM   #3
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Original Poster
Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Hi gegechris99. For all users I have this:
Quote:
$ set | grep LANG
LANG=en_US
 
Old 05-08-2008, 08:25 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Original Poster
Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Solved!
Found that the problem was with loading the pinyin IMEngine module.
All I needed to do was delete the .scim directory in the user home directory, so that it was rebuilt on next scim start.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding root privaliges to user accounts or auto login as root Val-Ent Linux - General 15 03-02-2010 05:27 PM
Start a program for a user as root, with process belonging to user gnashley Programming 4 03-19-2007 02:58 PM
Gnome: Cannot login as default user, sends back to login, works as root Danny-T Linux - Newbie 2 05-27-2006 04:44 AM
Root & user logins : Passwords? Why not encryption keys instead? furfurdemon666 Linux - Security 4 07-02-2004 10:17 AM
the opposite command of su? can i access user logins when i am root? how? kublador Linux - Newbie 3 09-11-2003 04:43 AM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration