LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2004, 06:42 PM   #16
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124

Quote:
Originally posted by Kyl3
I meant like I'm root right... and I get that noise. Then when I logout, at the GDM screen I can still hear the noise. And yes, I did do alsactl store.
DO NOT run your Linux system as root. The Slackware-HOWTO told you to create a normal user account:
Quote:
6.4 User Accounts

You should make a user account for yourself. Using "root" as your
everyday account is dangerous, and is considered bad form (at the very
least) since you can accidently damage your system if you mistype a
command. If you're logged in as a normal user, the effects of bad
commands will be much more limited. Normally you'll only log in as root
to perform system administration tasks, such as setting or changing the
root password, installing, configuring, or removing system software, and
creating or deleting user accounts.

To make an account for yourself, use the 'adduser' program. To start it,
type 'adduser' at a prompt and follow the instructions. Going with the
default selections for user ID, group ID, and shell should be just fine
for most users.
So if you haven't created a normal user account, do so now

One step at a time, Kyle.

Next...

Quote:
Originally posted by Kyl3
I've ran alsamixer, I dunno what to change, but to test it, I muted the master volume and did alsactl store. Only lasted one bootup.
Don't mute your master volume if you want sound. :}

This has probably been said before:
Quote:
Originally posted by Chinaman
Perhaps you got a volume level peaked in alsamixer? Try turning them all to about 75% and see what happens. There are different mixers that conflict, i.e. mic and/or mic boost too high produces feedback for me...
After you've created a normal user account, login as that user - not root.
Then run "alsamixer" as that normal user, and don't let any of your volume levels
get red at the top. And leave the mic ones muted. Once that's done, hit ESC to
exit alsamixer.

Type "su" to login as root and run "alsactl store" and then exit to logout as root
and become the normal user again.

As we say in China - "man man lai" ~ little by little...
 
Old 07-01-2004, 07:16 PM   #17
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by dori
I am also having some problems with the sound. What I found was that if I turned off the sound system on KDE, the alsaconf settings would stick. Pretty bad., but I haven't found a better solution, any suggestions welcomed.
I think thats it!! I'll try it.
 
Old 07-01-2004, 07:31 PM   #18
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
I would just like to state that I have been having the same ear splitting issues with Slack 10, alsa, KDE, and SB live. I was reminded of the Star Trek episode when some alien was abusing the crew with high frequency sound - I was doing a total Captain Kirk thing while I tried to find the applet to turn down the volume.

I did notice a couple things -

Running aumix showed settings for a chipset I did not recognize as well as the SB live- I think the wrong driver or multiple drivers may have been loaded by alsa - the sound is like feed back.

Changing any of the settings in aumix regarding the channel that is being recorded from made the sound go away. This was not a permanent fix.

Commenting out the OSS lines that alsa adds to modules.conf made the problem go away as a user, but not as root.

The above action allowed sound without screeching, but caused complaining by kmix, volume control, and aumix that they could not find a mixer.

Uncommenting the lines in modules config fixed nothing and now, when I log in to kde I no longer have permissions to /dev/dsp when I did before - hmmm....

The problem is only present in KDE. Gnome never screeched.

I just wanted to share. Still searching for a solution.

By the way, Slackware 9.1 had no such issues - even when upgraded to current/10
This has just been in a clean 10 install.
 
Old 07-01-2004, 10:22 PM   #19
dori
LQ Newbie
 
Registered: Jun 2004
Posts: 13

Rep: Reputation: 0
This has nothing to do with ALSA, but might be related. Whenever I exit KDE (and thus X), my keyboard repeat rate goes way down, and I can barely type. It's fixed by using kbdrate (as root), but it's annoying as hell. I have a feelign there is something seriously messed up with KDE.
 
Old 07-01-2004, 10:36 PM   #20
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
I just wanted to post that I fixed the screeching sound problem.

I uninstalled alsa and associated packages, deleted alsa edits to modules.conf, made sure the emu10k1 line was commented out in rc.modules, rebooted to run level 3, ran lsmod to make sure no sound modules were loaded, re-installed alsa packages, ran alsaconf, ran alsamixer, ran alsactl store, started x, booted to kde as root - went to control panel and set sound to alsa etc and tested - all good, left kde and logged back in as user, konsole, su, chmod 777 /dev/dsp, control center, set sound to alsa etc, test - all good.

HTH

also, I did want to mention that I didn't notice the sound screeching till after installing the nvidia drivers - but this was very soon into the whole process so the problem may have been there allready, I just don't know.

Last edited by Franklin; 07-01-2004 at 10:41 PM.
 
Old 07-02-2004, 12:00 AM   #21
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
Thank u!
 
Old 07-02-2004, 09:31 AM   #22
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
what are the correct permission so a user can also use sound. Is chmod 777 /dev/dsp enough??
 
Old 07-02-2004, 09:48 AM   #23
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by XPediTioN
what are the correct permission so a user can also use sound. Is chmod 777 /dev/dsp enough??
I've been running Slack 9.1 since November, and have done several installs on
both my comp, and at least a dozen others. I have never needed to use
this permissions philosophy for users. Everytime, no matter what mobo or pci
card, I go to ALSA, get their latest drivers, look up the soundcard, and copy
and paste their instructions. After I insert the modules, I log out as root and
as a normal user I issue "alsamixer" and use the m key to unmute the volume
levels, turning them all up until about 72 (if there are color bars I stop before
they turn red). Then I su to root and issue "alsactl store" and this saves the
settings permanently.

This has always worked for me. I've seen people posting this chmod for
/dev/dsp but have never found the need to do that. Looking at two comps right
now, this is what I see from a standard install of Slack 10.0
Code:
lrwxrwxrwx   1 root    root          4 2004-07-02 03:57 dsp -> dsp0
crw-rw--w-   1 root    audio   14,   3 2004-07-02 03:57 dsp0
and Slack 9.1
Code:
lrwxrwxrwx   1 root    root          4 May 28 02:49 dsp -> dsp0
crw-rw--w-   1 root    sys      14,  3 May 28 02:49 dsp0
and sound works great for both of them. Yes, as a normal user. I don't login
to a *nix system as root. That is rather "er bai wu" :}

Last edited by Bruce Hill; 07-02-2004 at 09:49 AM.
 
Old 07-02-2004, 10:15 AM   #24
lyceum
Member
 
Registered: Aug 2003
Location: N.C.
Distribution: rh9, fc1, slack 9.1, 10
Posts: 229

Rep: Reputation: 30
Quote:
Originally posted by Chinaman
That is rather "er bai wu" :}
now that isn't very nice...
 
Old 07-02-2004, 10:20 AM   #25
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by lyceum
now that isn't very nice...;)
It wasn't meant to be ugly - just speaking "the truth in love." :}
 
Old 07-02-2004, 10:42 AM   #26
lyceum
Member
 
Registered: Aug 2003
Location: N.C.
Distribution: rh9, fc1, slack 9.1, 10
Posts: 229

Rep: Reputation: 30
oh, i know what you were going for. logging in as root on a *nix system IS a bit worse than generally stupid, in my humble opinion that is. i know plenty of guys who do it all the time. i've called them worse, trust me.
 
Old 07-02-2004, 11:07 AM   #27
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by lyceum
oh, i know what you were going for. logging in as root on a *nix system IS a bit worse than generally stupid, in my humble opinion that is. i know plenty of guys who do it all the time. i've called them worse, trust me.
Hey, mate - apparently you can read Pinyin. Weishenme?

After running Windoze for a couple decades, and finally finding Linux to be
friendly enough to desire to migrate, there are a few things that someone
should really appreciate about Linux. One of the greatest to me is this area
of security. If one properly sets up a *nix system, with a normal user(s) as
well as root, and logs in as a normal user (except for commands that only
su can issue) for day-to-day work, the system is far more secure than any
Windoze OS ever shipped. And just that one thing makes it more secure
than the latest - Windoze eXperiment - by far.

But, eh, it's a PC (Personal Computer), right? So one's free to use
it, break it, or whatever one wants.

To give a shining example of that...

Yesterday I put a third hd in this box - /dev/hda has Windoze and my Linux swap,
/dev/hdb is the CD-RW, /dev/hdc was my Slack-9.1 system, and /dev/hdd
is now Slack-10.0. My intention was to pull /dev/hdc soon and use it to build a
server.

So as I'm doing other things, the Slack-10.0 install happened as I ran in and out of
the office. Coming back I decided to run through it until it started installing packages
whilst I took a quick nap. However, when it came to the TARGET option I wasn't
thinking that when it scanned for Linux partitions, it would pick up /dev/hdc as well as
/dev/hdd - and off I went formatting /dev/hdc1-6 before I noticed the c instead
of d and had formatted all but the /tmp partition.

NB: Backup - period. I last did it on 2004/05/22 so I do have a considerable amount
of that data left. However, there are some things that I won't be able to replace. I'm
still counting on some of these smart Chinese fellers being able to work a miracle and
recover that drive.

And I guess one doesn't have to be "er bai wu" to run their shiny new Linux system as
su on a daily basis ~ but it sure seems that way IMO.

Chinaman mumbles as he tries to get the M$ IntelliMouse Exploder to work again...
 
Old 07-02-2004, 11:36 AM   #28
lyceum
Member
 
Registered: Aug 2003
Location: N.C.
Distribution: rh9, fc1, slack 9.1, 10
Posts: 229

Rep: Reputation: 30
Quote:
Originally posted by Chinaman
Hey, mate - apparently you can read Pinyin. Weishenme?
i had a chinese roommate in college. i can't read much, but i picked up some here and there. seeing "er bai wu" in your post was pretty nostalgic, as this was what he most often affectionately called his mother.
Quote:
But, eh, it's a PC (Personal Computer), right? So one's free to use it, break it, or whatever one wants.
that's what i do best.

regards
 
Old 07-02-2004, 11:36 AM   #29
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
Quote:
Originally posted by Chinaman
I have never needed to use
this permissions philosophy for users. [/B]
I have noticed that once I add more than one user to the system, one user seems to have ownership of the /dev/dsp symlink and the others complain about permissions untill I chmod it.. I'll admit I'm not in complete understanding of why I need permission to use the sound in the first place. I'll also admit that some things are (to me anyway) not important enough to fully explore once you have found a fix that seems to work.

I think perhaps I got into the habit because I have seemed to have issues with getting alsa to work in the past and, as such, have been (stuck) with OSS. Not having the alsaconf capability in this situation, the chmod approach was the best for me and it became habit.

Oh well, back to work

 
Old 07-02-2004, 03:14 PM   #30
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
Here's question for someone;

Why is it that when I (as user, not root) log into KDE from kdm (started as root from runlevel3) do I get this error:

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Permission denied)
The sound server will continue, using the null output device.

But when I log into KDE from gdm (started the same way) I get proper sound setup.

Hmmm.

These are my device permissions:

lrwxrwxrwx 1 root root 4 2004-07-02 15:39 dsp -> dsp0
crw------- 1 root root 14, 3 2003-08-29 03:47 dsp0


I know gdm allows a sound event when it starts, this must have something to do with it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa question BinaryLinux Slackware 6 05-10-2004 07:07 AM
Alsa question Harp00 Slackware 16 04-05-2004 06:18 AM
Alsa question... CryptDragoon Slackware 1 02-20-2004 10:51 AM
Little Alsa question jazzyjazz Slackware 33 12-11-2003 04:46 PM
ALSA question dhrivnak Slackware 5 10-28-2003 08:19 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration