LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-29-2004, 09:04 PM   #1
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Rep: Reputation: 15
One last question: ALSA!


YAYAY! My Slack Server is up and running!!!!!!! But, when I start KDE I get an EAR SPLITTING high pitched noise. So now I have to run alsaconf on every bootup to make it go away... Any ideas?

And I need help with fstab, I have a DVD-ROM drive that Slack reads as a CD-ROM drive. And it doesn't read my CD-RW at all.

One more thing, for duel-booters: You know how WinXP hibernates? It shuts off but when you turn it on it has all your stuff the way you left it before you shut down? Can Slack do that, if so, how?
 
Old 06-29-2004, 09:27 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
ALSA:
After configuring ALSA, run as normal user "alsamixer" and use the m key to unmute your channels. Then run as root "alsactl store" to save your settings.

For the CD-RW you must have generic scsi in the kernel. If you've got the standard bare.i install it's there. Now you need to add "hdx=ide-scsi" to lilo.conf for your drive, where x is the drive letter for the CD-RW.

My DVD+-RW is recognized by the 2.4.26 kernel and read appropriately. Issue as root "cdrecord -scanbus" and post what it shows your drives to be in there.

Can't help much with hibernate, as I disable that in Windoze and avoid it in Slack; but I think that's part of ACPI. Can you be more specific in that question? Are you trying to get your Slack box to hibernate or does it already hibernate but return with different settings?

EDIT: Your thread said one question but you asked four... ;-)

Last edited by Bruce Hill; 06-29-2004 at 09:28 PM.
 
Old 06-29-2004, 09:42 PM   #3
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
No I'm trying to GET IT to hibernate
 
Old 06-29-2004, 09:48 PM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by Kyl3
No I'm trying to GET IT to hibernate
Can't help you there. You might try looking in these Linux doc HOWTO's as they have one for ACPI, amongst many others.
 
Old 06-30-2004, 01:39 AM   #5
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
Found out the hibernate thing. BUT:

root@kyl3whatoneone:~# apmsleep
apmsleep: missing argument.
Usage:

apmsleep [+]hh:mm

Example:
apmsleep +1:15 will suspend for one hour and 15 minutes
apmsleep 8:00 will suspend until 8:00 am

Bugs: Daylight saving jumps are not taken into account.
Modem ring detection may trigger early wake-up.
Does not work with Suspend to Disk.
Bug reports to author Peter Englmaier <ppe@mpe.mpg.de>.
root@kyl3whatoneone:~# apmsleep 8:00
apmsleep: Your kernel does not support APM.
apmsleep: Recompile kernel with APM and /dev/rtc support
root@kyl3whatoneone:~#

Can I do this without a format? If yes, how?
 
Old 06-30-2004, 02:14 AM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Yes, you can do it without reformatting, but you will have to recompile your kernel for APM support. I don't know for sure, but I thought that ACPI was newer and better. I really wish somebody with this experience would post and help you. However...

These are the two guides I recommend for compiling your kernel.

Kernel-Build-HOWTO

Newbie Guide To Compiling A Kernel!

Before you start, you are required to read these guides all the way through, and to print them for reference. You are also required to backup your present kernel so that if you make a mistake, you can still boot your system. You can use the same kernel you're running now, but just add the APM support. Since you've install Slackware 10.0 you have kernel 2.4.26. If you're not sure, just issue "uname -r" as user. I would recommend that you stick with that kernel, and do not get a 2.6.x series kernel if you're not running one now. There are other issues which might jump up and bite you. ;-)

Btw - how are your other three problems - ALSA, CD-RW, DVD?

Last edited by Bruce Hill; 06-30-2004 at 10:32 AM.
 
Old 06-30-2004, 11:28 AM   #7
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
Aftwer toying with it ALSA and the dvd rom are better. cdrw is ok i dont mind... thanks! But like what do i put into my kernel? I know how to compile one, its what I have to select I have issues with.


Edit: I guess my toyed alsamixer setting only lasted one bootup.

Edit AGAIN: That earsplitting noise that wont go away till alsaconf is run will even stay there when I logout (runlevel 4)

Last edited by Kyl3; 06-30-2004 at 02:44 PM.
 
Old 06-30-2004, 06:10 PM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by Kyl3
Aftwer toying with it ALSA and the dvd rom are better.
How did you toy with it? What did you do? You want "better" or "correct?"
Quote:
Originally posted by Kyl3
cdrw is ok i dont mind... thanks!
What do you mean by it's okay? Issue as root "cdrecord -scanbus" and post what it shows...
Quote:
Originally posted by Kyl3
But like what do i put into my kernel? I know how to compile one, its what I have to select I have issues with.
Put in the kernel for the CD-RW, for APM, or what?
Quote:
Originally posted by Kyl3
Edit: I guess my toyed alsamixer setting only lasted one bootup.
Did you run "alsactl store" as root? That saves them.
Quote:
Originally posted by Kyl3 Edit AGAIN: That earsplitting noise that wont go away till alsaconf is run will even stay there when I logout (runlevel 4)
What do you mean by "logout?" As the current user? Runlevel 4 throws init into a loop that keeps your load avg at least 1 all the time. So I guess the current user logging out isn't going to shutdown your procs.

Perhaps you got a volume level peaked in alsamixer? Try turning them all to about 75% and see what happens. There are different mixers that conflict, i.e. mic and/or mic boost too high produces feedback for me...
 
Old 06-30-2004, 06:20 PM   #9
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
Oops! I'm sorry I meant my cdrw DOESN't work and I dont mind. And the APM thing is what I meant by put in the kernel. AND CD-RW also. And about the runlevel thing.... I meant like I'm root right... and I get that noise. Then when I logout, at the GDM screen I can still hear the noise. And yes, I did do alsactl store.


And:

root@kyl3whatoneone:~# cdrecord -scanbus
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Last edited by Kyl3; 06-30-2004 at 06:29 PM.
 
Old 06-30-2004, 07:11 PM   #10
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
I installed my old ALSA stuff from my 9.1 discs (cause thats when everything was good, and now, ALSA can't find my SB: Live! And it is compiled as a module in my kernel!
 
Old 07-01-2004, 01:56 PM   #11
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
I d/led and installed ALSA from the website, all went fine, except now, even AFTER I run alsaconf the noise is there...
 
Old 07-01-2004, 03:15 PM   #12
whishkah
Member
 
Registered: Mar 2004
Location: PA
Distribution: SuSE 10 OSS
Posts: 83

Rep: Reputation: 15
Did you run alsaconf then alsamixer and then alsactl store. If you don't save the changes, it may cause that sound to keep coming back. -It sound like you are getting to much feedback, as well.
 
Old 07-01-2004, 06:03 PM   #13
Kyl3
Member
 
Registered: Apr 2004
Distribution: SUSE 9.3 Pro
Posts: 110

Original Poster
Rep: Reputation: 15
I've ran alsamixer, I dunno what to change, but to test it, I muted the master volume and did alsactl store. Only lasted one bootup.
 
Old 07-01-2004, 06:55 PM   #14
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
How do I check if I am running Alsa?
 
Old 07-01-2004, 07:05 PM   #15
dori
LQ Newbie
 
Registered: Jun 2004
Posts: 13

Rep: Reputation: 0
I am also having some problems with the sound. What I found was that if I turned off the sound system on KDE, the alsaconf settings would stick. Pretty bad., but I haven't found a better solution, any suggestions welcomed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa question BinaryLinux Slackware 6 05-10-2004 08:07 AM
Alsa question Harp00 Slackware 16 04-05-2004 07:18 AM
Alsa question... CryptDragoon Slackware 1 02-20-2004 11:51 AM
Little Alsa question jazzyjazz Slackware 33 12-11-2003 05:46 PM
ALSA question dhrivnak Slackware 5 10-28-2003 09:19 PM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration