LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-16-2013, 12:46 AM   #1
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Rep: Reputation: 1
Onboard ethernet won't connect on t42 laptop running slackware 14


The error I'm getting when I try to ping anything is:
Code:
connect: Network is unreachable
And this is the output of lspci for my ethernet controller:
Code:
02:01.0 Ethernet controller: Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
Fresh install, used netconfig to set up dhcp, and dhcpcd gives the message:
Code:
dhcpcd[2026]: version 5.5.6 starting
dhcpcd[2026]: wlan0: up_interface: No such file or directory
dhcpcd[2026]: no interfaces have a carrier
dhcpcd[2026]: forked to background, child pid 2063
ifconfig doesn't show a connection on eth0 even though eth0 is up, but does have the loopback connecting to 127.0.0.0 like it should.

Contents of /etc/rc.d/rc.inet1.conf

Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""
 
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
 
# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""
 
# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""
 
# Default gateway IP address:
GATEWAY=""
 
# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
The rest of the file is commented out examples and explanations.

Not sure where to go from here.

EDIT: Turns out it was the ethernet cable I was using. I tested the cable on another computer and was able to connect with it, so I figured the cable was fine, but I thought I should test a new cable anyway. I ran a new line from the junction switch to my laptop and it works, so it had to be something with the old cable.

Thanks for all the help

Last edited by slacker_; 09-16-2013 at 09:11 PM. Reason: Edit #1: Had to add rc.inet1.conf info. Edit #2: Solved thread
 
Old 09-16-2013, 02:31 AM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Please post your /etc/rc.d/rc.inet1.conf
 
Old 09-16-2013, 03:19 AM   #3
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by guanx View Post
Please post your /etc/rc.d/rc.inet1.conf
I thought I had everything, but I had a feeling I forgot something. Thanks for reminding me. It's added to original post now.
 
Old 09-16-2013, 08:35 AM   #4
slacktroll
Member
 
Registered: May 2011
Distribution: Slackware 13.37
Posts: 50

Rep: Reputation: 3
what about

killall -9 dhcpcd
dhcpcd eth0

i've had what you describe myself
 
Old 09-16-2013, 08:49 AM   #5
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware current(32) (started with 13.37(32))
Posts: 86

Rep: Reputation: 17
What appears if you run "ifconfig -a" to show all interfaces.
This controller is a wired card, isn't it? Would appear as eth0.
 
Old 09-16-2013, 03:48 PM   #6
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Paulo2 View Post
What appears if you run "ifconfig -a" to show all interfaces.
This controller is a wired card, isn't it? Would appear as eth0.
It shows all my interfaces all right. But eth0 doesn't have any connection at all. I see the hardware address, and the device is up, but it's not connecting.

Quote:
Originally Posted by slacktroll View Post
what about

killall -9 dhcpcd
dhcpcd eth0

i've had what you describe myself
This returns the following:
Code:
dhcpcd[3351]: open_control: Connection refused
dhcpcd[3351]: version 5.5.6 starting
dhcpcd[3351]: eth0: waiting for carrier
dhcpcd[3351]: timed out
dhcpcd[3351]: allowing 8 seconds for IPv4LL timeout
dhcpcd[3351]: timed out
 
Old 09-16-2013, 05:37 PM   #7
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware current(32) (started with 13.37(32))
Posts: 86

Rep: Reputation: 17
I think that if "ifconfig" doesn't show eth0 and "ifconfig -a" shows, eth0 isn't up.
Code:
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
Code:
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
There is an UP if interface is up (this is my wireless card, I'm not using it right now)

Try "ifconfig eth0 up", then slacktroll's commands.

There is Wicd in X too, I use it to setup my connections.

Last edited by Paulo2; 09-16-2013 at 05:40 PM. Reason: edited to correct some mistakes
 
Old 09-16-2013, 05:41 PM   #8
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Paulo2 View Post
I think that if "ifconfig" doesn't show eth0 and "ifconfig -a" shows, eth0 isn't up.
Code:
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
Code:
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
There is an UP if interface is up (this is my wireless card, I'm not using it right now)

Try "ifconfig eth0 up", then slacktroll's commands.

There is Wicd in X, I use it to setup my connections.
ifconfig and ifconfig -a both show eth0, they both show the device as up. How did you get that it didn't show in ifconfig?

The device is UP, the rc.inet.conf is set up for dhcp, dhcpcd command is timing out. That is where I'm at right now.

Also, I'm using primarily cli right now until I get the networking fixed. Wireless is an entirely different problem I'm having (go back through my threads if you'd like to see that), currently I'm just worried about getting my wired connection working.

Last edited by slacker_; 09-16-2013 at 05:45 PM.
 
Old 09-16-2013, 06:20 PM   #9
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware current(32) (started with 13.37(32))
Posts: 86

Rep: Reputation: 17
Since the card is up, doesn't look like a driver problem.
Try to set ip manually, an ip from dhcp network not in use.
I think that this is the command
Code:
ip addr add ip/mask dev eth0
See if ip was assigned "ifconfig" or "ip addr show"
 
Old 09-16-2013, 06:55 PM   #10
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Paulo2 View Post
Since the card is up, doesn't look like a driver problem.
Try to set ip manually, an ip from dhcp network not in use.
I think that this is the command
Code:
ip addr add ip/mask dev eth0
See if ip was assigned "ifconfig" or "ip addr show"
Set to 192.168.1.245, ifconfig shows it as 192.168.1.245. Now how do I take this info and use it to connect to my network? I'm not network admin, but the network is setup to accept any new connection and assign it an address with dhcp so it's definitely not network side.
 
Old 09-16-2013, 07:34 PM   #11
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware current(32) (started with 13.37(32))
Posts: 86

Rep: Reputation: 17
Try to ping the gateway (maybe 192.168.1.1), if all packets reach the gateway then ok,
you must be connected to the machine that has the dhcp server.

If not, try adding a route. It would be done with "ip" command, but I don't know how,
so I will paste the "route" command.
Code:
route add -net 192.168.1.0/24 gw 192.168.1.1
(is mask 255.255.255.0 ?)

The fact that there is a dhcp server doesn't exclude manual setup, it will accept connections
if you put an ip from the same network. The only care is not use someone's ip.


Is this your thread about wireless?
http://www.linuxquestions.org/questi...hy-4175474924/
I have an HP Compaq with Broadcom onboard, but unfortunately video chipset has died.
I installed Slackware 13.37 and it worked with b43 driver, but this was a year and a half ago,
I don't remember if it worked right out of the box or with some tweak.

Last edited by Paulo2; 09-16-2013 at 07:38 PM. Reason: make some phrases more clear ( and excuse me my English :)
 
Old 09-16-2013, 07:49 PM   #12
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Paulo2 View Post
Try to ping the gateway (maybe 192.168.1.1), if all packets reach the gateway then ok,
you must be connected to the machine that has the dhcp server.

If not, try adding a route. It would be done with "ip" command, but I don't know how,
so I will paste the "route" command.
Code:
route add -net 192.168.1.0/24 gw 192.168.1.1
(is mask 255.255.255.0 ?)

The fact that there is a dhcp server doesn't exclude manual setup, it will accept connections
if you put an ip from the same network. The only care is not use someone's ip.


Is this your thread about wireless?
http://www.linuxquestions.org/questi...hy-4175474924/
I have an HP Compaq with Broadcom onboard, but unfortunately video chipset has died.
I installed Slackware 13.37 and it worked with b43 driver, but this was a year and a half ago,
I don't remember if it worked right out of the box or with some tweak.

I'm still getting this:
Code:
connect: Network is unreachable
Yes, that's my wifi thread. I was really hoping to get 14 working, but I could probably try 13.37 and see if it works.

EDIT: Issue solved I tested the ethernet cable on another computer and it worked fine so I figured it couldn't be the cable, but I ran a new cable for my laptop and it I can now connect to the network. So it's something to do with the old cable. Thread marked solved. Thanks for all the help!

Last edited by slacker_; 09-16-2013 at 09:08 PM.
 
Old 09-16-2013, 11:06 PM   #13
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware current(32) (started with 13.37(32))
Posts: 86

Rep: Reputation: 17
Maybe a straight cable instead of crossover one?


Code:
Yes, that's my wifi thread. I was really hoping to get 14 working, but I could probably try 13.37 and see if it works.
About the wireless problem, I just remembered of something about pcmcia cards
being configured by another script, and searching I found that actually this
is only for 16-bit pcmcia, not 32-bit.

13.37 worked for me, but the notebook broke before I could upgrade to 14.
I saw that you tested some other kernel versions, maybe upgrading
to -current bring some results.
 
Old 09-16-2013, 11:20 PM   #14
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware, openSUSE, CentOS
Posts: 169

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Paulo2 View Post
Maybe a straight cable instead of crossover one?
Both are crossover, so I think one of the wires in the old cable might've pinched off or something.

Quote:
Originally Posted by Paulo2 View Post
About the wireless problem, I just remembered of something about pcmcia cards
being configured by another script, and searching I found that actually this
is only for 16-bit pcmcia, not 32-bit.
What do you mean "This is only for 16bit pcmcia" ?

Quote:
Originally Posted by Paulo2 View Post
13.37 worked for me, but the notebook broke before I could upgrade to 14.
I saw that you tested some other kernel versions, maybe upgrading
to -current bring some results.
The kernel I'm trying to use is 3.10.11 (currently having to compile it). Is 'current' beyond 3.10*?
 
Old 09-16-2013, 11:50 PM   #15
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware current(32) (started with 13.37(32))
Posts: 86

Rep: Reputation: 17
Quote:
What do you mean "This is only for 16bit pcmcia" ?
I mean the different place for configuration.
This is from /etc/rc.d/rc.wireless
Quote:
#!/bin/sh
# /etc/rc.d/rc.wireless
# $Id: rc.wireless,v 1.13 2007/04/13 14:14:43 eha Exp eha $
#
# Wireless network card setup.
#
# This script sets up PCI, USB, and 32-bit Cardbus wireless devices
# NOT 16-bit PCMCIA cards! Those are configured in /etc/pcmcia/.
# Single parameter to this script is the name of a network interface.
# Normally this script is called from rc.inet1 rather than run
# directly.
That configuration for 16-bit pcmcia is too old I think, makes reference
to ISA bus and interrupts (maybe those ISA cards that are not plug and play,
you have to configure interrupt and IO ports manually).




Quote:
The kernel I'm trying to use is 3.10.11 (currently having to compile it). Is 'current' beyond 3.10*?
According to log, it is the same version you are trying.
http://www.slackware.com/changelog/current.php?cpu=i386
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel D915GAV onboard ethernet not working in slackware 12 gopi.d Slackware 14 09-20-2007 12:21 PM
Intel PRO 100VE onboard ethernet card problem in Slackware 12 gopi.d Linux - Networking 2 09-05-2007 05:43 AM
New to Slackware/Problem with onboard ethernet card Slack Noob Linux - Newbie 4 10-23-2006 02:07 AM
Intel Pro wireless 2100 on IBM T42 laptop running FC3 tvmaly Linux - Software 1 02-25-2005 09:00 AM
Onboard 3com ethernet [a7n8x deluxe] on slackware 9.0 problems xen Linux - Hardware 3 06-07-2003 02:15 AM


All times are GMT -5. The time now is 12:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration