LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   On Slackware current wicd can't connect to wired network (http://www.linuxquestions.org/questions/slackware-14/on-slackware-current-wicd-cant-connect-to-wired-network-4175426511/)

Didier Spaier 09-10-2012 09:07 AM

On Slackware current wicd can't connect to wired network
 
3 Attachment(s)
Hello all,

On Slackware current (32 bit) last updated
Mon Sep 10 02:55:29 UTC 2012.

"lspci -k| grep -3 Eth" says:
Code:

00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
        Subsystem: Lenovo ThinkPad T61
        Kernel driver in use: e1000e
        Kernel modules: e1000e

"ifconfig -a|grep -A10 eth" says:
Code:

eth0      Link encap:Ethernet  HWaddr 00:1F:E2:1A:EA:C0 
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: 2a01:e35:2e5b:6270:21f:e2ff:fe1a:eac0/64 Scope:Global
          inet6 addr: fe80::21f:e2ff:fe1a:eac0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2923 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3120 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1572170 (1.4 Mb)  TX bytes:473468 (462.3 Kb)
          Interrupt:20 Memory:fe200000-fe220000

I tried to get a wired connection with wicd-cli, wicd-client and wicd-curses, to no avail.

It seems that the connection be acquired but immediately lost.

I am a member of the netdev group and do not have wicd-kde installed.

I get a connection instantly in typing "dhcpcd eth0".

Guess I am missing something obvious, but what?

I append the relevant config files and the log file.

willysr 09-10-2012 10:15 AM

what is your /etc/rc.d/rc.inet1.conf looks like?

escaflown 09-10-2012 10:18 AM

When I had that issue, it was because networkmanager was running at the same time as wicd.

Didier Spaier 09-10-2012 10:26 AM

1 Attachment(s)
Quote:

Originally Posted by willysr (Post 4776878)
what is your /etc/rc.d/rc.inet1.conf looks like?

It looks like it did when the network-scripts-14.0 package was installed, i.e. I didn't edit it and didn't run "netconfig". I append it though so you can check.

Didier Spaier 09-10-2012 10:28 AM

Quote:

Originally Posted by escaflown (Post 4776883)
When I had that issue, it was because networkmanager was running at the same time as wicd.

Here /etc/rc.d/rc.networkmanager is not executable, so /etc/rc.d/rc.M don't start it.

PS /etc/rc.d/rc.M in Slackware-current at time of writing won't start Network Manager if /etc/rc.d/rc.wicd is executable:
Code:

# Start wicd or networkmanager:
if [ -x /etc/rc.d/rc.wicd ]; then
  sh /etc/rc.d/rc.wicd start
elif [ -x /etc/rc.d/rc.networkmanager ]; then
  sh /etc/rc.d/rc.networkmanager start
fi


willysr 09-10-2012 10:46 AM

Quote:

Originally Posted by Didier Spaier (Post 4776890)
It looks like it did when the network-scripts-14.0 package was installed, i.e. I didn't edit it and didn't run "netconfig". I append it though so you can check.

Hm... looking at the file, it looks fine to me

I never had problems with WICD since it's included in Slackware some time ago. I used it on my desktop and laptops and they were all just fine.

brobr 09-10-2012 03:47 PM

Hi, maybe you need to strip some lines from your manager-settings.conf as similar preferences but with opposite settings are shown (indicated with <===========[delete?]):

Quote:

[Settings]
dhcp_client = 2
sudo_app = 2
wired-interface = eth0
always-show-wired-interface = True <===========
wired-connect_mode = 0
prefer-wired = true <===========
auto-reconnect = true
debug-mode = 1
backend = external
wireless_interface = wlan0
wired_interface = eth0 <===========[delete?]
wpa_driver = wext
always_show_wired_interface = False <===========[delete?]
use_global_dns = False
global_dns_1 = None
global_dns_2 = None
global_dns_3 = None
global_dns_dom = None
global_search_dom = None
auto_reconnect = True
debug_mode = False
wired_connect_mode = 1
signal_display_type = 0
should_verify_ap = 1
link_detect_tool = 0
flush_tool = 0
prefer_wired = False <===========[delete?]
show_never_connect = True



All times are GMT -5. The time now is 11:07 AM.