LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-10-2012, 08:07 AM   #1
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,181

Rep: Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018
On Slackware current wicd can't connect to wired network


Hello all,

On Slackware current (32 bit) last updated
Mon Sep 10 02:55:29 UTC 2012.

"lspci -k| grep -3 Eth" says:
Code:
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
	Subsystem: Lenovo ThinkPad T61
	Kernel driver in use: e1000e
	Kernel modules: e1000e
"ifconfig -a|grep -A10 eth" says:
Code:
eth0      Link encap:Ethernet  HWaddr 00:1F:E2:1A:EA:C0  
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: 2a01:e35:2e5b:6270:21f:e2ff:fe1a:eac0/64 Scope:Global
          inet6 addr: fe80::21f:e2ff:fe1a:eac0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2923 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3120 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1572170 (1.4 Mb)  TX bytes:473468 (462.3 Kb)
          Interrupt:20 Memory:fe200000-fe220000
I tried to get a wired connection with wicd-cli, wicd-client and wicd-curses, to no avail.

It seems that the connection be acquired but immediately lost.

I am a member of the netdev group and do not have wicd-kde installed.

I get a connection instantly in typing "dhcpcd eth0".

Guess I am missing something obvious, but what?

I append the relevant config files and the log file.
Attached Files
File Type: txt wired-settings.conf.txt (396 Bytes, 5 views)
File Type: txt manager-settings.conf.txt (624 Bytes, 3 views)
File Type: txt wicd.log.txt (8.2 KB, 2 views)

Last edited by Didier Spaier; 09-10-2012 at 08:13 AM. Reason: Output of lspci added
 
Old 09-10-2012, 09:15 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
what is your /etc/rc.d/rc.inet1.conf looks like?
 
Old 09-10-2012, 09:18 AM   #3
escaflown
Member
 
Registered: Apr 2009
Location: Canada
Distribution: Slackware
Posts: 237

Rep: Reputation: 30
When I had that issue, it was because networkmanager was running at the same time as wicd.
 
Old 09-10-2012, 09:26 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,181

Original Poster
Rep: Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018
Quote:
Originally Posted by willysr View Post
what is your /etc/rc.d/rc.inet1.conf looks like?
It looks like it did when the network-scripts-14.0 package was installed, i.e. I didn't edit it and didn't run "netconfig". I append it though so you can check.
Attached Files
File Type: txt rc.inet1.conf.txt (4.9 KB, 6 views)
 
Old 09-10-2012, 09:28 AM   #5
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,181

Original Poster
Rep: Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018Reputation: 1018
Quote:
Originally Posted by escaflown View Post
When I had that issue, it was because networkmanager was running at the same time as wicd.
Here /etc/rc.d/rc.networkmanager is not executable, so /etc/rc.d/rc.M don't start it.

PS /etc/rc.d/rc.M in Slackware-current at time of writing won't start Network Manager if /etc/rc.d/rc.wicd is executable:
Code:
# Start wicd or networkmanager:
if [ -x /etc/rc.d/rc.wicd ]; then
  sh /etc/rc.d/rc.wicd start
elif [ -x /etc/rc.d/rc.networkmanager ]; then
  sh /etc/rc.d/rc.networkmanager start
fi

Last edited by Didier Spaier; 09-10-2012 at 09:36 AM. Reason: PS added
 
Old 09-10-2012, 09:46 AM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,548

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Quote:
Originally Posted by Didier Spaier View Post
It looks like it did when the network-scripts-14.0 package was installed, i.e. I didn't edit it and didn't run "netconfig". I append it though so you can check.
Hm... looking at the file, it looks fine to me

I never had problems with WICD since it's included in Slackware some time ago. I used it on my desktop and laptops and they were all just fine.
 
Old 09-10-2012, 02:47 PM   #7
brobr
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 44

Rep: Reputation: 15
Hi, maybe you need to strip some lines from your manager-settings.conf as similar preferences but with opposite settings are shown (indicated with <===========[delete?]):

Quote:
[Settings]
dhcp_client = 2
sudo_app = 2
wired-interface = eth0
always-show-wired-interface = True <===========
wired-connect_mode = 0
prefer-wired = true <===========
auto-reconnect = true
debug-mode = 1
backend = external
wireless_interface = wlan0
wired_interface = eth0 <===========[delete?]
wpa_driver = wext
always_show_wired_interface = False <===========[delete?]
use_global_dns = False
global_dns_1 = None
global_dns_2 = None
global_dns_3 = None
global_dns_dom = None
global_search_dom = None
auto_reconnect = True
debug_mode = False
wired_connect_mode = 1
signal_display_type = 0
should_verify_ap = 1
link_detect_tool = 0
flush_tool = 0
prefer_wired = False <===========[delete?]
show_never_connect = True
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to auto internet with wicd in slackware current on USB? linus72 Linux - General 1 04-02-2010 10:50 PM
Wicd in current won't connect to wireless network. Fixed it with rebuilding grissiom Slackware 6 03-06-2010 12:16 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-14-2009 11:58 PM
Cannot connect to wireless network with wicd on Zenwalk Kenny_C Linux - Wireless Networking 1 04-07-2009 02:11 PM


All times are GMT -5. The time now is 08:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration