LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-10-2010, 10:34 AM   #1
Emor
LQ Newbie
 
Registered: Oct 2010
Distribution: Slackware 13.1
Posts: 22

Rep: Reputation: 1
Unhappy On KDE log-in screen mouse pointer and keyboard input not acknowledged.


Hey, 'name's Emor. I just recently installed Slackware onto a virtual machine(I'm planning on buying a new disc drive and 1 TB HDD with-in the next couple of months and plan on Slackware being my primary OS[right now Mac OS X 10.6 is]), and everything went great.
I then went onto edit the /etc/inittab file in emacs and changed the run-level to 4. I don't know why it's decided that I'd want to boot into KDE when XFCE is installed and in the configuration I selected XFCE but it's not really relevant(I have a WM guide thing open in another tab and will probably be able to change it).
The problem is, as the vague title may suggest, is that it basically freezes when I'm at the log-in screen. The input field for the username is highlighted and blinking, and the cursor it self is visible in the centre of the screen, but it simply doesn't pick up on any input from my keyboard or mouse.
I tried booting up the install CD and logging in as root, mounting sda4(which is the root partition) and editing said file but sudo isn't installed(to my knowledge) on the install disc and when I do the command,
Code:
emacs /mnt/hdd/etc/inittab
I'm just told permission is denied.
So I don't really know what to do at this point. It'd be okay if I had the command line but I don't.
I'm a bit of a newbie, I read the first 100 pages of the slackware tutorial book but after that thought it'd be a bit redundant, I've googled about my problem and there's been no results, and skim read through all of the book in hope to see if there's a solution, so please don't flame me.
Thank you for any help .
EMZ=]
EDIT: I don't think it's relevant really since in the command line it recognised input from my trackpad when highlighting text, etc. but in the installation I selected PS/2 input 'cause I wasn't sure whether a trackpad would be PS/2 or USB. In the install it said most laptops and desktops fell under this(I thought serial ports were obsolete but it's the latest install and I'm an idiot with computers so meh).

Last edited by Emor; 10-10-2010 at 10:36 AM.
 
Old 10-10-2010, 01:32 PM   #2
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Rep: Reputation: 36
you need to install the latest sudo--use whatever package manager is supplied with slackware to install/upgrade it...also you should be able to get back to a terminal by pressing ctrl+alt+f1 at the login window---otherwise boot into recovery mode.
 
1 members found this post helpful.
Old 10-10-2010, 05:38 PM   #3
Emor
LQ Newbie
 
Registered: Oct 2010
Distribution: Slackware 13.1
Posts: 22

Original Poster
Rep: Reputation: 1
Thank you for the reply .
The problem is though that neither of these solutions(to my, limited, knowledge) could work.
At the log-in screen I can't go back to the console/shell because it doesn't acknowledge any input from my keyboard, which includes hotkeys.
And for the package installer, afaik you can't install packages onto install DVDs and even if you could I doubt I'd be able to configure the internet, prior to installing the actual OS(which obviously I don't want to do), on the install DVD.
EMZ >_<
 
Old 10-10-2010, 07:26 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,252

Rep: Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631
I am not sure why the keyboard isn't working in KDM (I don't use it, and know very little about it) -- but if you boot with the install CD and mount your partition, you should be able to edit your inittab file -- sudo is completely irrelevant when you're logged in as root. I don't believe emacs is available on the install CD, so unless you chroot into your installation you'd be better off using vi or nano to modify inittab from the install CD, since I believe both are available. Otherwise you would have to issue
Code:
# chroot /mnt/hdd
# emacs /etc/inittab
# exit
 
1 members found this post helpful.
Old 10-10-2010, 11:35 PM   #5
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Rep: Reputation: 36
the exact same problem was mentioned here- http://www.linuxquestions.org/questi...e-in-x-832223/
and the problem was resolved with the latest installation of sudo--- boot into the rescue shell and disable kdm, then go into the actual OS and install sudo and re-enable kdm at boot
 
1 members found this post helpful.
Old 10-10-2010, 11:47 PM   #6
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,252

Rep: Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631Reputation: 631
Unless the OP is very late in posting or is using a very out-of-date mirror to upgrade packages, I doubt that is the problem...the problematic sudo package shouldn't even exist on any remotely current mirror. The output of
Code:
# ls -ld /var
would give the definitive answer (or `ls -ld /mnt/hdd/var`, assuming you boot from the install CD and mount your root partition at /mnt/hdd). Regardless, when modifying inittab as root from the install CD, even if the permissions were incorrect on /var (which was the problem introduced with the flawed sudo package), it would still work -- sudo itself isn't doing anything and /var (or more specifically /mnt/hdd/var) doesn't need to be touched to edit the inittab file.
 
1 members found this post helpful.
Old 10-11-2010, 01:51 PM   #7
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
Wasn't there a similar problem a while back where the keyboard/mouse
stopped working (for some people) at the kdm login screen after
some updates in current (before 13.1)?

I know on my other machine (with an old legacy nvidia card)
I have to use an xorg.conf and after updating my keyboard/mouse
stopped working at the kdm login screen.

The fix for me was to comment out all the InputDevice
sections in xorg.conf and let hald autodetect the keyboard/mouse.

Just a thought...
 
1 members found this post helpful.
Old 10-11-2010, 05:57 PM   #8
Emor
LQ Newbie
 
Registered: Oct 2010
Distribution: Slackware 13.1
Posts: 22

Original Poster
Rep: Reputation: 1
Honestly, I don't know what exactly I did really.
T3Slider was correct and I managed to get command line access.
And from thereon I just edited so many files I can't be sure what exactly did it.
Though I think it might have been me typing this:
/usr/sbin/hald --daemon=yes
I did a lot of Googling too.
http://forum.soft32.com/linux/ve-bro...ict514910.html
Thanks guys .
I don't know if I should label the thread as solved because I doubt anyone in the future will find this of any use, but for the short-term I'll just mark it that anyway :P.
EMZ=]
 
Old 10-11-2010, 10:25 PM   #9
mf93
Member
 
Registered: Jun 2009
Distribution: Debian Squeeze, centOS
Posts: 229

Rep: Reputation: 36
disabling hald will definitely stop the functioning of mouse and keyboard: that happened to me when i first installed freeBSD. that is definitely the solution to your problem.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse/Keyboard don't work at log in screen with Fedora 11 preview HamScott Fedora 2 07-12-2009 07:49 AM
Is there a way to move the mouse pointer with the keyboard? Oakems DamnSmallLinux 2 03-17-2009 08:16 AM
Blank Log in Screen with working mouse pointer ed163126 Linux - Newbie 3 09-20-2007 11:25 PM
Mouse pointer freezes, keyboard still works MikeZila Slackware 2 10-03-2004 10:50 AM
my mouse input is takes as keyboard input in BASH e1000 Slackware 5 12-08-2003 03:00 PM


All times are GMT -5. The time now is 09:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration