LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2005, 09:20 AM   #1
K@rl`
Member
 
Registered: Feb 2004
Posts: 70

Rep: Reputation: 15
Question On a Fresh install of 10.1, the Nforce sound drivers refuse to install..


Hi All,

I want a fresh install of Slackware 10.1, to try out the nvidia nforce sound drivers and see if I can get them working.

But it throughs up an error about the /usr/src/linux not being the source that compiled my kernel. It also says that maybe the link is wrong, but I know that isn't for sure..

Is there any way around this ? Or will I have to re-compile the Kernel to get them to work ?


Many Thanks

Karl.

Last edited by K@rl`; 02-25-2005 at 07:25 AM.
 
Old 02-24-2005, 09:50 AM   #2
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
What it is asking for is the link which goes to the kernel souce code. This is stored in /usr/src/<kernel-source-version.version>

There should be a symlink called /usr/src/linux which points to the source of your current kernel.

Eg if you have kernel 2.6.10, you should have (a) the kernel source in /usr/src/linux-2.6.10 and, (b) a symlink called /usr/src/linux pointing to /usr/src/linux-2.6.10

If the kernel source isn't there, go to kernel.org and download it. then untar it into this directory.

If the symlink isn't there, make it
# ln -s /usr/src/linux-2.6.10 /usr/src/linux

see if that works now
hamish
 
Old 02-25-2005, 02:55 AM   #3
K@rl`
Member
 
Registered: Feb 2004
Posts: 70

Original Poster
Rep: Reputation: 15
Hmm, it appears it is only the sound drivers.


The network went in perfect but the sound reports a problem, 'can't insert nvsound.o' or simular.

I still have wierd sound problems. Only one app can use it at a time, running esd in the console doesn't seem to have an effect ?

Cheers.

Karl.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Audio: Can't install Nforce drivers summ0n3r Linux - Hardware 1 03-20-2005 02:44 PM
LILO refuse to install on slackware 10 jazzaddict Linux - Newbie 1 01-16-2005 10:55 AM
fresh install, slack 10 - no win drives? useless as they have the modem drivers on... jollyjoice Slackware 4 07-19-2004 01:16 PM
Nforce2 Drivers On fresh Redhat9 install jdmar Linux - Newbie 2 04-24-2004 03:42 AM
Fresh RH9 install - oops I forgot to install something blaint Linux - Newbie 5 10-25-2003 12:29 PM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration