LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Old soft installing on Slack64 14.0 ? (http://www.linuxquestions.org/questions/slackware-14/old-soft-installing-on-slack64-14-0-a-4175486247/)

WiseDraco 11-29-2013 08:43 AM

Old soft installing on Slack64 14.0 ?
 
Hello!
Try to install old soft on slackware64 14.0 with Alienbobs multilib32 installed.



pcsc-lite-1.2.0-3.i386.rpm
compat-libstdc++-296-2.96-132.fc4.i386.rpm
aksrte-3-15.84p3.i386.rpm

when i try install pcsc-lite :
rpm -i pcsc-lite-1.2.0-3.i386.rpm
error: Failed dependencies:
/bin/sh is needed by pcsc-lite-1.2.0-3.i386
libc.so.6 is needed by pcsc-lite-1.2.0-3.i386
libc.so.6(GLIBC_2.0) is needed by pcsc-lite-1.2.0-3.i386
libc.so.6(GLIBC_2.1) is needed by pcsc-lite-1.2.0-3.i386
libc.so.6(GLIBC_2.1.3) is needed by pcsc-lite-1.2.0-3.i386
libdl.so.2 is needed by pcsc-lite-1.2.0-3.i386
libdl.so.2(GLIBC_2.0) is needed by pcsc-lite-1.2.0-3.i386
libdl.so.2(GLIBC_2.1) is needed by pcsc-lite-1.2.0-3.i386
libpthread.so.0 is needed by pcsc-lite-1.2.0-3.i386
libpthread.so.0(GLIBC_2.0) is needed by pcsc-lite-1.2.0-3.i386
libpthread.so.0(GLIBC_2.1) is needed by pcsc-lite-1.2.0-3.i386
libusb-0.1.so.4 is needed by pcsc-lite-1.2.0-3.i386


it is very strange, especial of /bin/sh
sure, i see in /bin, and there is sh symlink to bash.

these packages is for usb key working to decode stream. it is designed to ancient versions of redhat 9 or so on and debian. i try to install that and get work on slackware basis - maybe someone can help me?
P.S. i get info, i can use pcsc-lite for slackware too, but not higher than version 1.2.0, because after that version something changes, and it not work with that hardware as that usb-key.
cannot imagine, where i can found pcsc-lite 1.2.0 for slack 14 - look around internet and most old as i found is 1.5.x...

there is also problems with another packages:

rpm -i compat-libstdc++-296-2.96-132.fc4.i386.rpm
warning: compat-libstdc++-296-2.96-132.fc4.i386.rpm: Header V3 DSA/SHA1 Signature, key ID 4f2a6fd2: NOKEY
error: Failed dependencies:
/sbin/ldconfig is needed by compat-libstdc++-296-2.96-132.fc4.i386
libc.so.6 is needed by compat-libstdc++-296-2.96-132.fc4.i386
libc.so.6(GLIBC_2.0) is needed by compat-libstdc++-296-2.96-132.fc4.i386
libc.so.6(GLIBC_2.1) is needed by compat-libstdc++-296-2.96-132.fc4.i386
libc.so.6(GLIBC_2.1.3) is needed by compat-libstdc++-296-2.96-132.fc4.i386
libc.so.6(GLIBC_2.3) is needed by compat-libstdc++-296-2.96-132.fc4.i386
libgcc_s.so.1 is needed by compat-libstdc++-296-2.96-132.fc4.i386
libgcc_s.so.1(GLIBC_2.0) is needed by compat-libstdc++-296-2.96-132.fc4.i386
libm.so.6 is needed by compat-libstdc++-296-2.96-132.fc4.i386
libm.so.6(GLIBC_2.0) is needed by compat-libstdc++-296-2.96-132.fc4.i386

and

rpm -i aksrte-3-15.84p3.i386.rpm
error: Failed dependencies:
/bin/sh is needed by aksrte-3-15.84p3.i386
/usr/bin/perl is needed by aksrte-3-15.84p3.i386
libc.so.6 is needed by aksrte-3-15.84p3.i386
libc.so.6(GLIBC_2.0) is needed by aksrte-3-15.84p3.i386
libc.so.6(GLIBC_2.1) is needed by aksrte-3-15.84p3.i386
libc.so.6(GLIBC_2.1.3) is needed by aksrte-3-15.84p3.i386
libm.so.6 is needed by aksrte-3-15.84p3.i386
libpthread.so.0 is needed by aksrte-3-15.84p3.i386
libpthread.so.0(GLIBC_2.0) is needed by aksrte-3-15.84p3.i386
libpthread.so.0(GLIBC_2.1) is needed by aksrte-3-15.84p3.i386
libstdc++-libc6.2-2.so.3 is needed by aksrte-3-15.84p3.i386
pcsc-lite is needed by aksrte-3-15.84p3.i386
perl(File::Copy) is needed by aksrte-3-15.84p3.i386
perl(Socket) is needed by aksrte-3-15.84p3.i386

business_kid 11-29-2013 04:15 PM

Everything is compiled using kernel headers, gcc, and glibc. They all change over time. You have 3 options

1. Install an older slackware - one that shipped with the appropriate glibc and use it for those programs. Perhaps a VM?
2. Install versions of those older programs like glibc hidden in a strange sub directory which you pass to the compiler instead of standard stuff. This is error prone, as the gcc of today usually barfs on old code. If they are all binaries, you would need a subsystem or chroot which is messy.
3. If you can get old source code for the programs, recompile using that. There's clever ways of stripping off the updates to git.

ruario 11-29-2013 04:32 PM

The problem is that you are trying to install an rpm directly on Slackware, however RPM is not the package manager for Slackware and hence there is no database of dependencies, meaning any rpm package you try to install this way will give you such an error. In theory you could use --nodeps to force the install but this would be a mistake. Convert all the rpms with rpm2tgz (or src2pkg) and install them with installpkg.

ruario 11-29-2013 05:05 PM

Just to add, if you have correctly installed AlienBob's multilib32 (as you state above) the dependencies should be satisfied. I checked on my own Slackware64 14.0 with multilib32 and find all of these libs are available.

Code:

$ (cd /var/log/scripts/; for f in *; do sed -n "s,^( *cd \([^ ;][^ ;]*\) *; *rm -rf \([^ )][^ )]*\) *) *$,\1/\2 found in $f,p" $f; done | grep -Fe lib/libc.so.6 -e lib/libdl.so.2 -e lib/libpthread.so.0 -e lib/libpthread.so.0 -e lib/libusb-0.1.so.4 | sort)
lib/libc.so.6 found in glibc-2.15_multilib-x86_64-8alien
lib/libc.so.6 found in glibc-solibs-2.15_multilib-x86_64-8alien
lib/libdl.so.2 found in glibc-2.15_multilib-x86_64-8alien
lib/libdl.so.2 found in glibc-solibs-2.15_multilib-x86_64-8alien
lib/libpthread.so.0 found in glibc-2.15_multilib-x86_64-8alien
lib/libpthread.so.0 found in glibc-solibs-2.15_multilib-x86_64-8alien
usr/lib/libusb-0.1.so.4 found in aaa_elflibs-compat32-14.0-x86_64-4compat32



All times are GMT -5. The time now is 08:06 AM.