LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-08-2004, 07:19 AM   #1
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Rep: Reputation: 15
Old installation of GRUB prevents me from using LILO and booting into Slackware!


Ok, I have a friend who installed Fedora Core 3.. Fedora Core's boot loader is GRUB. I believe Fedora Core installed the boot loader in the MBR (Master Boot Record). He has since then reformatted the hdd and now he has 2 partitions. HDA1 is the swap drive, and HDA2 is where he has Slackware installed, and HDA2 has the boot flag. Everything installed fine, Slackware's boot loader is LILO. Now when he boots his computer GRUB still comes up, and he can't do anything from there. How can I clear the MBR?
 
Old 12-08-2004, 07:39 AM   #2
cythrawll
Member
 
Registered: Nov 2004
Location: IL, USA
Distribution: Slackware 10
Posts: 167

Rep: Reputation: 31
I hate to say this: but the easiest way is to get a ms boot disk and run this command: fdisk /mbr

ok guys don't hurt me (hides)

other wise you can use a dd in linux (boot disk or knoppix etc) command like so:

dd if=/dev/zero of=/dev/hda bs=446 count=1

you'll prolly have to recreate and reinstall your partitions after that though

goodluck!

p.s., it might be a good idea to backup the mbr first on a floppy disk just in case:

dd if=/dev/hda of=/floppy/MBR bs=512 count=1

Last edited by cythrawll; 12-08-2004 at 07:45 AM.
 
Old 12-08-2004, 07:40 AM   #3
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
Boot from some bootdisk (slackware install cd, add root=/dev/hda2 ro as a kernel boot option) and edit /etc/lilo.conf to install lilo in the MBR. There will be a line in it boot=/dev/hd<something> probably /dev/hda2 . Change that to boot=/dev/hda , save the file and rerun lilo. That should do the trick
 
Old 12-08-2004, 08:06 AM   #4
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Original Poster
Rep: Reputation: 15
Thanks for such a quick reply!!! I will look into this and try it tonight... I'll let you all know how it goes!
 
Old 12-12-2004, 10:28 AM   #5
mark alan
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Rep: Reputation: 0
Hey guys,

Thanks for the help getting my MBR strait. Now that that's fixed, I have another problem:

I can get to the darkstar prompt (I forgot to name my domain) and when I type in startx this is what I get:

IO error

Code:
(EE) vf860pen Serical: cannot open input device /dev/mouse
(EE) mouse1: cannot open input device
(EE) reinit failed for input device "mouse 1)
        No core pointer

Fatal Server Error:
Failed to initialize core devices
I went into xorgconfig to set the settings for the monitor, vid card & mouse/keyboard. I got the monitor set as well as the vid card and keyboard, but my mouse seems to be the problem.

I have a logitech wireless mouse/keyboard. The only numbers I can get from the mouse are:

"m/n: M-RP67" on the back of the mouse. The mouse/keyboard is a usb connect and I did enable "hotshot" or something like that in the initial setup for Slackware.

In xorgconfig I tried automatic (opt 1) as well as PS/2 and Microsoft. I think Microsoft prompted me with a question of is this a Logitech, if so it's recommened to enable another feature. I did that, but each time I come out of xorgconfig, I keep getting the same error.

I also edited the string: /dev/mouse to /dev/input/mice to no avail.

Any hints or clues to this other than junking the keyboard/mouse for a "name brand"?

Thanks

Mark
 
Old 12-12-2004, 10:31 AM   #6
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
try editing xorg.conf to use /dev/psaux as the mouse device.
 
Old 12-12-2004, 12:07 PM   #7
mark alan
LQ Newbie
 
Registered: Nov 2004
Posts: 15

Rep: Reputation: 0
Thumbs up

Quick reply! Thanks!

I will give that a try when I get home.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting of raw ISO from GRUB/LILO (though preferably GRUB) Orkie Linux - Software 28 12-15-2013 09:37 PM
lilo vs grub, dual-booting binkgle Ubuntu 6 05-16-2005 01:39 AM
Booting problems: grub and lilo neri Linux - Newbie 10 05-17-2004 10:17 AM
Booting Options with lilo or grub RancidWannaRiot Mandriva 2 12-05-2003 09:37 AM
Booting GRUB through LILO? TheOneAndOnlySM Linux - Newbie 5 08-01-2003 08:50 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration