LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-02-2002, 12:09 PM   #1
ZombieChan
LQ Newbie
 
Registered: Dec 2002
Location: Ogden, UT
Distribution: Slackware, Debian
Posts: 9

Rep: Reputation: 0
Odd USB Mouse Problem


I was hoping someone can give me a hand.

I'm using a Logitech USB Mouse. I have UHCI USB support compiled into my kernel. (I'm using a VIA board.)

If I run a dmesg, I can see that my mouse is detected as input0.

but... if I cat /dev/input/mice. I fail to find the device.

So, I rm /dev/input/mice and redid it as per the devices.txt in /usr/src/linux/Documents. mknod /dev/input/mice c 13 63.

To no avail, though, I can't get my mouse to work.

Can anyone offer any ideas or suggestions on how to fix this? I've been able to use a usb mouse before, but I'm new to slackware. Last time, I set it up on Debian just fine.

You help is greatly appreciated.
 
Old 12-02-2002, 01:07 PM   #2
LNXman
Member
 
Registered: Jul 2002
Location: California (USA)
Distribution: Slackware
Posts: 97

Rep: Reputation: 15
Do you have the hid module loaded? Read your /usr/src/linux/Documentation/input/input.txt file (especially section 3.2.2 regarding mice) for more info.

GL
 
Old 12-03-2002, 12:48 AM   #3
ZombieChan
LQ Newbie
 
Registered: Dec 2002
Location: Ogden, UT
Distribution: Slackware, Debian
Posts: 9

Original Poster
Rep: Reputation: 0
Hid was compiled into the kernel. As was device input. I ended up going back through and redoing those parts of the kernel to just act as modules. After I modprobed hid, input, and mousedevice everything worked just fine. A friend of mine helped with making it run those commands at boot. So, Problem solved!

Thanks for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
odd mouse action on kernel upgrade rosslaird Debian 2 07-26-2004 12:27 PM
new nvidia driver & mouse problems - odd errors produced, no mouse detected. UrbanSlayer Debian 4 07-03-2004 08:13 PM
Problem with Mandrake 10.0 Community, Sagem usb modem and logitech usb mouse. al370601 Mandriva 4 04-29-2004 06:48 PM
Odd solution to Mouse scroll wheel issues. WhiteChedda Mandriva 0 09-30-2003 09:56 AM
odd problem with mouse ozak Slackware 1 03-19-2003 09:37 PM


All times are GMT -5. The time now is 10:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration