LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-09-2007, 01:47 PM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,118

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
Odd Alsamixer Problem


I had a SATA drive eat itself a week or so ago and had to instal Slackware 11.0 on a new SATA drive (you can imagine the fun that was). I install test26.s, which is 2.6.18, then upgradepkg all the *.tgz files in the testing directory, then using the config file from the test26 directory compile and install the kernel (because I have to turn off i82365 in the kernel -- blacklisting will not stop the thing from constantly respawning on this particular hardware combination).

I have a Soundblaster Live! 24 sound card. It worked just fine with the previous installation (same as above). It's set up with alsaconf, followed by alsamixer, followed by alsactl store.

After that, displaying alsamixer shows "OO" in the left most control (which is Card: CA0106, View: Playback, Item: IEC956. The sound will not work with "OO," but it will with "MM" in that position.

Now, here's the problem - I set that to "MM," use alsactl store to save it, and every time I startx, no matter "who" I am, it's "OO" and there is no sound.

I start alsamixer, set that to MM (with upper case M) and sound works but, no matter what I try, that setting will not, ever, under an circumstances remain as "MM" it always goes back to "OO" and there's no sound.

I'm thinking that somewhere, buried where nobody can find it (and I have looked!) there is a setting that causes that.

Does anybody have any idea what the heck to do so this blasted thing will just work the way it's supposed to?

Thanks.
 
Old 06-09-2007, 02:01 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
You run 'alsactl store' as root, right ?
 
Old 06-09-2007, 02:09 PM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,118

Original Poster
Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
Oh, yes, many, many, many times.

As root I have removed asound.state, executed alsaconf, executed alsamixer, etc., etc., etc.. Again and again and again with no change whatsoever.
 
Old 06-09-2007, 02:20 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
I guess you're using KDE. KDE stores it's own mixer settings. Use KMix to set the volume or make KDE not to load it own mixer settings on the control panel.
 
Old 06-09-2007, 06:12 PM   #5
mobilemonkey
Member
 
Registered: May 2007
Distribution: slackware 11
Posts: 81

Rep: Reputation: 15
Quote:
Originally Posted by gbonvehi
I guess you're using KDE. KDE stores it's own mixer settings. Use KMix to set the volume or make KDE not to load it own mixer settings on the control panel.
that is exactly why i cant be bothered using a desktop environment like KDE, the more sophisticated something gets, the more hassel it becomes, and the more it seems to want to take over EVERYTHING. ive got a soundblaster live card and it does that reverse thing with the '00' and 'MM', but once ive set it to 'MM' and got sound, i simply do 'alsactl store' as root, and thats it, fluxbox doesnt touch it
 
Old 06-10-2007, 06:34 AM   #6
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,118

Original Poster
Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
Quote:
Originally Posted by gbonvehi
I guess you're using KDE. KDE stores it's own mixer settings. Use KMix to set the volume or make KDE not to load it own mixer settings on the control panel.
Well, yes, I am using KDE and no, I had not touched KMix (never have, had to dig for it). So, open up KMix, fiddle for a while, sound, no sound, sound, quit KMix, quit KDE, startx, sound; sound without fooling with alsamixer. Gnash teeth.

So, problem solved? Probably, thing thing make noise when it's supposed to and I don't have to fool around with opening, setting, and closing anything to make that happen.

But, well, you kind of have to wonder -- far too many of the subject lines in this and other forums contain something about sound problems. This particular one is not earth-shaking (one can live without KDE's little start up and shut down tune after all) but it just seems that this kind of problem may be one of the things that prevent some folks that might otherwise adopt the platform from doing so. I realize that hardware is complex, software even more so and that getting things to play nice with each other may not be the easiest task (I have been doing this on and off since 1962, believe me, I've seen some weird things in that time) but you do have to wonder sometimes.

Anyway, thanks to all for the advice. I'm still not completely sure just what I actually did to get the thing going, but it is and all is well that ends.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsamixer problem GuLRs Linux - Hardware 11 02-06-2006 05:02 AM
Sound Problem! Alsamixer! glaz Linux - Newbie 20 02-14-2005 07:42 AM
Help!!!!! : alsamixer Problem .. har5ha Linux - Software 4 07-26-2004 09:08 AM
alsamixer problem, snd_ctl_open?!? Punkduplo Linux - Laptop and Netbook 14 12-09-2003 09:19 AM
alsamixer problem kvikki Linux - Hardware 1 07-13-2003 07:47 PM


All times are GMT -5. The time now is 10:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration