LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-02-2009, 12:24 PM   #1
densebeast
LQ Newbie
 
Registered: Nov 2009
Posts: 4

Rep: Reputation: 0
nvidia-settings


Hi

new to slackware, trying to set up dual monitors (separate x screens) using nvidia-settings. I have used this utility before with Fedora and it worked fine. My graphics card is a GeForce 8800 GTS. Below is my xorg.conf file. Monitor 0 is my desktop monitor, monitor 1 is my TV set. After applying nvidia-settings adjustment monitor 0 is fine. The problem is that everything on monitor 1 is HUGE! Icons, terminal, web browser, everything. Has anyone else gone thru this?

thanks,
m

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Tue Oct 20 21:26:01 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Tue Oct 20 21:25:04 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "SAMSUNG"
    HorizSync       26.0 - 76.0
    VertRefresh     23.0 - 60.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS"
    BusID          "PCI:3:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS"
    BusID          "PCI:3:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 
Old 12-02-2009, 05:04 PM   #2
code933k
Member
 
Registered: Aug 2007
Location: Bogotá, Colombia. South America
Distribution: ArchLinux / Source Mage GNU Linux (test branch) / openSUSE
Posts: 130

Rep: Reputation: Disabled
1.You don't have specific monitor resolutions inside xorg.conf so
2.you should select them from what nvidia-settings wants to provide automatically (you should be able to select resolutions and modes from that utility.

If you can't solve any of both. Try playing with xrandr from terminal (and don't panic if your refresh rate appears lower in xrandr, it is a NVidia bug)

Last edited by code933k; 12-02-2009 at 05:06 PM.
 
Old 12-03-2009, 02:00 PM   #3
densebeast
LQ Newbie
 
Registered: Nov 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks, I have tried working inside nvidia-settings. I have used the 'auto' setting, and I have tried setting the specific resolution (1920x1080). Neither seems to work. It seems like different distros have different quirks with nvidia-settings. I'll take a look at xrandr but I don't want to, you know, blow up my TV
 
Old 12-03-2009, 03:09 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I doubt the TV could blow up (at least not LCD), I've been messing with mine for a while, even editing the EDID stuff and using xrandr and nvidia-settings ... it has yet to blow up ... it also has yet to work properly at the right resolution and without cropping (it works fine as a TV tho)
 
Old 12-04-2009, 07:01 PM   #5
code933k
Member
 
Registered: Aug 2007
Location: Bogotá, Colombia. South America
Distribution: ArchLinux / Source Mage GNU Linux (test branch) / openSUSE
Posts: 130

Rep: Reputation: Disabled
This is my own /etc/X11/Xorg.conf file for your own reference:

Code:
Section "ServerFlags"
    Option "DontZoom" "True"
    Option "DontZap"  "False"
    Option "Pixmap" "32bpp"
    Option "DRI2" "True"
EndSection

Section "Monitor"
    Identifier  "Monitor0"
    VendorName  "Asus"
    ModelName   "G50"
    Modeline "1368x768_60.00"   85.25  1366 1440 1576 1784  768 771 781 798 -hsync +vsync
    Option  "DPMS" "True"
EndSection

Section "Device"
    Identifier  "Device0"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
#    Option "NoLogo" "True"
    Option "HWCursor"
    Option "DisableGLXRootClipping" "False"
#    Option "RenderAccel" "True"
    Option "UseDisplayDevice" "DFP-0"
##  Option "UseDisplayDevice" "CRT-0, DFP-1"
#    Option "ConnectedMonitor" "DFP-0"
#    Option "TripleBuffer" "True"
#   Option "SyncToVBlank" "True"
#    Option "BackingStore" "True"
#    Option "DamageEvents" "True"
#    Option "UseEvents"  "False"
#   Option "PixmapCacheSize" "70000"
#   Option "Coolbits" "1"
#    Option "NoPowerConnectorCheck" "True"
#   Option "OnDemandVBlankInterrupts" "True"
#    Option "AddARGBGLXVisuals" "True"
#    Option "AllowGLXWithComposite" "True"
#    Option "RandRRotation" "False"
#   Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3333;"
#    Option "EnablePageFlip" "True"
#    Option "AccelMethod" "EXA"
#    Option "DynamicTwinView" "0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option "DAMAGE" "Enable"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection
There are no input sections and so forth because they are handled by HAL (hardware daemon) automatically. However, nvidia proprietary drivers (yeah, it is a shame we have to use them right now) seem to need xorg.conf settings. This is how xorg.conf "should look today" if you have Xorg server version 1.5 or superior (That sounded like Windows babble ).

Well, we'll start counting your three options:
(ALWAYS BACKUP YOUR WORKING FILES)


1.) Copy my configuration to the letter or modify it depending on your expertise, except for:
Code:
    Modeline "1368x768_60.00"   85.25  1366 1440 1576 1784  768 771 781 798 -hsync +vsync
section. Which is suited for my own monitor, of course.

For finding out your own monitor "modelines" issue:
Code:
gtf 1280 768 60 -x
where 1280 768 is the intended native resolution (1280x768).

Single comments in my config are what my personal options/hardware are. You can try uncommenting them for speeding up your card one by one once it is working properly. Be very careful with powermizer and coolbits!!!

2.) Use nvidia-xconfig and let it write what it thinks your Xorg defaults are.

3.) For more info on NVidia quirks: http://bbs.archlinux.org/viewtopic.php?id=59192

Last edited by code933k; 12-04-2009 at 07:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia-settings errors tombomb300 Linux - Hardware 4 01-18-2008 01:36 PM
NVidia settings not applied shermanramni Fedora 3 05-20-2007 07:36 PM
"nvidia-settings" OC settings and SuSE 10 NetRAVEN5000 Linux - Hardware 4 01-12-2007 06:23 PM
nvidia-settings vs nvidia-glx POWERade Linux - Games 2 07-18-2006 12:40 AM
nvidia settings cragwolf Linux - Software 2 12-13-2005 06:29 PM


All times are GMT -5. The time now is 06:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration