LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-22-2013, 08:40 AM   #1
lonestar_italy
Member
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware
Posts: 62

Rep: Reputation: 0
NVIDIA Proprietary drivers - XOrg 1.13.2 - Mesa 9


Hi,
After updating to the new bundle of updates on -current, I have a strange issue.

OpenGL is somehow working, but some of KDE's effects complain that they cannot find OpenGL libs (wobbly windows, etc.)

At first I had forgotten to install the new glu- package. But even after installing it, and reinstalling NVIDIA 310.32 the issue is still present.

I've also tried NVIDIA 313.18 but no change.

What could it be??
 
Old 02-22-2013, 09:55 AM   #2
Darth Vader
Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 619

Rep: Reputation: 114Reputation: 114
Well, nvidia-switch not work properly now, because the GL version is changed.

In the nvidia-switch script:

Code:
GL_VERSION="1.2"
should be:

Code:
GL_VERSION="1.2.0"
Then, execute:

Code:
nvidia-switch --remove && nvidia-switch --install
Reboot and enjoy!

Last edited by Darth Vader; 02-22-2013 at 09:56 AM.
 
Old 02-22-2013, 12:04 PM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,394

Rep: Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922
Hmmm, something doesn't feel right here either. After turning off the GL "sync to vblank option" in nvidia-settings I'm getting around 2900fps from glxgears when I usually expect to see around 17000. Also, moving an openGL app window around ("/usr/libexec/xscreensaver/glknots -window") is excruciatingly slow under dwm (a no-frills basic window manager) and I'm seeing CPU SYS Time > 90%.

I'm using NVIDIA-Linux-x86_64-310.32.run, on 3.7.9 kernel, reinstalled after applying today's current updates.


update:

Well, I'm getting 17500fps again now from glxgears. Really don't know what was upsetting it earlier as I haven't changed anything and it just started working again (haven't even logged out of X11). Unless it happens again I'll write it off as a one-off weirdness.

Last edited by GazL; 02-22-2013 at 12:23 PM.
 
Old 02-22-2013, 12:50 PM   #4
lonestar_italy
Member
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware
Posts: 62

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Darth Vader View Post
Well, nvidia-switch not work properly now, because the GL version is changed.
hmm well, I've never used nvidia-switch nor the drivers package from SBo. I've always just downloaded the drivers from nvidia's website and run it as is. It moves the GL files that it has to move and everything works.

But this time something seems to be broken. Is is because Nvidia's drivers still don't support Mesa 9 ? Should I go back to mesa 8.0.4 ?

I've tried to run just nvidia-switch on top of manually installed drivers but nothing changed.
 
Old 02-22-2013, 03:48 PM   #5
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Nvidia moves mesa out of the way so it doesn't matter which mesa is installed.
 
Old 02-22-2013, 04:09 PM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
Quote:
Originally Posted by wildwizard View Post
Nvidia moves mesa out of the way so it doesn't matter which mesa is installed.
That's not entirely true. The libGL library gets replaced by an accelerated version coming from the binary driver package, but there are other libraries in mesa that do make a difference. For instance the newly added libglapi.so. And the mesa application programming interface in /usr/include/GL is not removed either.

Eric
 
Old 02-22-2013, 04:22 PM   #7
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 161

Rep: Reputation: 20
and after today's x86-64 update, I get black screen and unresponsive keyboard as X tries to start, curiously I also cannot start the machine in either run level 3 or 1 from a LILO prompt...the machine always shows INIT: entering runlevel 4...so I'm not able to get to a console to sort this out as it is...maybe I missed the memo...
 
Old 02-22-2013, 04:28 PM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
Quote:
Originally Posted by the_penguinator View Post
and after today's x86-64 update, I get black screen and unresponsive keyboard as X tries to start, curiously I also cannot start the machine in either run level 3 or 1 from a LILO prompt...the machine always shows INIT: entering runlevel 4...so I'm not able to get to a console to sort this out as it is...maybe I missed the memo...
How did you upgrade? Check http://docs.slackware.com/howtos:sla...:systemupgrade to see what you missed (did you install the new "glu" package? Did you re-install your binary Nvidia/Ati graphics driver if you had installed that before?)

Eric
 
Old 02-22-2013, 04:36 PM   #9
GazL
Senior Member
 
Registered: May 2008
Posts: 3,394

Rep: Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922Reputation: 922
Assuming your lilo label for slackware is "linux" then linux nomodeset vga=normal 3 at the lilo boot prompt should put you into runlevel 3 without any graphical entanglements.

If it's still running rc.4 even when you do that, then you must have broken your inittab.
 
Old 02-22-2013, 04:53 PM   #10
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 161

Rep: Reputation: 20
Quote:
Originally Posted by Alien Bob View Post
How did you upgrade? Check http://docs.slackware.com/howtos:sla...:systemupgrade to see what you missed (did you install the new "glu" package? Did you re-install your binary Nvidia/Ati graphics driver if you had installed that before?)

Eric
Hi Eric, the upgrade was done in the correct slackpkg order/fashion and I wasn't using a proprietary ATI driver
cheers
 
Old 02-22-2013, 05:01 PM   #11
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware -current, OpenBSD, OSX
Posts: 161

Rep: Reputation: 20
Quote:
Originally Posted by GazL View Post
Assuming your lilo label for slackware is "linux" then linux nomodeset vga=normal 3 at the lilo boot prompt should put you into runlevel 3 without any graphical entanglements.

If it's still running rc.4 even when you do that, then you must have broken your inittab.
then I must have broken inittab somehow because it still goes direct to runlevel 4...meh...I should be able to start the machine from an install disk and see what extra voodoo I might have typed into /etc/inittab when all I needed to do was erase a 3 and insert a 4...but all the same, I could start the machine manually to another runlevel prior to the upgrade to the 3.7.1 kernel...interesting....
 
Old 02-22-2013, 05:08 PM   #12
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
Quote:
Originally Posted by Alien Bob View Post
That's not entirely true. The libGL library gets replaced by an accelerated version coming from the binary driver package, but there are other libraries in mesa that do make a difference. For instance the newly added libglapi.so. And the mesa application programming interface in /usr/include/GL is not removed either.

Eric
libglapi is used internally and once the libGL is replaced by nvidia's version there is no longer a link to it
Also I haven't yet got the Slackware version so I can't see why it would have this extra lib as it is only required if you have enabled GL ES and can be disabled if that is not the case.

The includes are standardized as OpenGL is a standard so there is not much point in replacing them as only the copyright notice at the top would change.
 
Old 02-22-2013, 05:23 PM   #13
lonestar_italy
Member
 
Registered: Nov 2010
Location: Italy
Distribution: Slackware
Posts: 62

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lonestar_italy View Post
But this time something seems to be broken. Is is because Nvidia's drivers still don't support Mesa 9 ? Should I go back to mesa 8.0.4 ?
I've tried to reinstall mesa 8.0.4 but the issue is still present, so I guess it's not about Mesa but maybe XOrg 1.13.2 itself.

But before getting too far I would like to know if any other can confirm the same issue, with nvidia drivers and the new set of XOrg/Mesa packages?

If it's just me, then it would be my fault.
 
Old 02-22-2013, 05:40 PM   #14
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
Quote:
Originally Posted by wildwizard View Post
libglapi is used internally and once the libGL is replaced by nvidia's version there is no longer a link to it
There is no need for mesa libraties to link to it. The need is with the applications that dynamically link to it. I play a game which requires the presence of libglapi.so.

Quote:
Also I haven't yet got the Slackware version so I can't see why it would have this extra lib as it is only required if you have enabled GL ES and can be disabled if that is not the case.
I asked Pat to build and add it (earlier versions of the mesa package did not enable it in the build configuration). Quoting:

[CODE]
[--enable-shared-glapi

By default, libGL has its own copy of libglapi. This options makes libGL use the shared libglapi. This is required if applications mix OpenGL and OpenGL ES.
/CODE]

Eric
 
Old 02-22-2013, 10:40 PM   #15
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current & "True Multilib." PC-BSD.
Posts: 2,237

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by lonestar_italy View Post
...But before getting too far I would like to know if any other can confirm the same issue, with nvidia drivers and the new set of XOrg/Mesa packages?...
No problems here.
I'm running all the latest packages posted last night, my time, and the Nvidia 310.19 drivers, in Slackware64-current with Xfce, and everything is working flawlessly... so far.
:-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver (proprietary) + xorg/KDM = some games freeze sometimes kevinbenko Linux - General 4 04-23-2011 08:55 PM
[SOLVED] -current updates Mesa/Xorg + Legacy nVidia + X -configure = Problems linus72 Slackware 5 11-23-2010 01:38 AM
Need help with Nvidia proprietary drivers Dugon143 Linux - Hardware 8 10-30-2007 02:05 PM
nvidia 66.29 driver-xorg-x11-Mesa-libGL conflict yellowtail Linux - Software 3 02-28-2005 08:34 PM
Proprietary nvidia drivers vs. generic intel sound and ethernet drivers vharishankar Linux - Hardware 2 02-22-2005 05:32 AM


All times are GMT -5. The time now is 11:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration