LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-09-2005, 07:09 AM   #1
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Rep: Reputation: 30
Angry nvidia permissions always restored


dear all,

when i run something with openGL such as the atlantis screensaver, i get the error:

"/dev/nvidiactl: permissions to restrictive".

therefore i follow the suggested instructions and:

1. modified the /etc/security/console.perms to comment all references to <dri>.

2. i changed the permissions back to 0666 and chown root.

this works perfectly, until i restart x. when i do so, permissions are back again to restricted.

what can i do?
 
Old 03-09-2005, 07:13 AM   #2
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
found an answer, i guess i post it here for anyone in need.

the way to fix it is to edit the file :

/etc/udev/permissions.d/50-udev.permissions


Scroll down to you find the section on [dri divices] and change :

code:nvidia* :root:root 0660
To
nvidia* :root:root :0666


Then re-boot the system.

Also make sure you have all the nvidia drivers copied from /dev to /etc/udev/devices by using the command

cp -a /dev/nvidia* /etc/udev/devices




__________________
 
Old 03-12-2005, 06:10 AM   #3
sys7em
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Slackware
Posts: 158

Rep: Reputation: 30
thanksfor the explanation I was searchin for the same thing ...
 
Old 03-13-2005, 12:56 PM   #4
acidjuice
Member
 
Registered: Jan 2005
Location: a tiny spot on the iceberg
Distribution: Slackware 10.1 (dropline 2.10, kernel 2.6.11.6)
Posts: 320

Original Poster
Rep: Reputation: 30
that's what forums are made of
 
Old 03-15-2005, 11:22 AM   #5
sys7em
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Slackware
Posts: 158

Rep: Reputation: 30
after upgrading to udev 54 from slackware current .... the /etc/udev/permissions.d/50-udev.permissions file just disappeared .. don't know why but now my nvidia perm. keep reseting again ...any ideas ?
 
Old 03-15-2005, 11:45 AM   #6
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
From recent version of udev, the rules are in: /etc/udev/rules.d/udev.rules
Look for a line that says:
Code:
KERNEL="nvidia*",       NAME="%k", GROUP="video"
and change it to
Code:
KERNEL="nvidia*",       NAME="%k", GROUP="video", MODE="0666"
PS: I forgot to remember that udev 054 problems were fixed so i'd recommend upgrading to it.

Last edited by gbonvehi; 03-15-2005 at 12:34 PM.
 
Old 03-15-2005, 11:58 AM   #7
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
I downgraded to the previous release, but others posted a solution somewhere in the Slackware forums, so do a search.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mysql dropped database.... can it be restored? figmentium Linux - General 2 08-11-2005 04:13 PM
Troubles with Nvidia permissions crud Slackware 4 05-26-2005 03:16 PM
alsamixer settings not restored in FC3 makuz Fedora 6 12-25-2004 04:57 PM
Sound restored--at least one time jonr LinuxQuestions.org Member Success Stories 0 05-18-2003 05:00 PM
hosts.deny and other files are restored when I don't want them to be LinuxHaven Linux - General 2 08-13-2002 12:46 AM


All times are GMT -5. The time now is 08:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration