LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-29-2004, 03:07 AM   #1
abs
Member
 
Registered: Oct 2003
Posts: 203

Rep: Reputation: 30
Thumbs up nvidia logo


hi
i installed the nvidia drivers today. and WOW! for me, nv was the default thing but full sreen movies sucked. i had to change the modeline to get the screen in the middle too. reverted back to the original values when i installed the driver and everything looks crisper too.

just one thing, the logo. i can't get it to go away! in the /usr/share/doc/NVIDIA...README file, there's a section on options (app D). it says
Quote:
Option "NoLogo" "boolean"
Disable drawing of the NVIDIA logo splash screen at
X startup. Default: the logo is drawn.
so what's boolean? i've tried "1", "TRUE", "True", "on". what else? (NoLogo = 1 means Logo = 0, right?) :P
 
Old 02-29-2004, 09:07 AM   #2
At0mic_PC
Member
 
Registered: Jul 2003
Location: Mississippi
Distribution: Slack9.1
Posts: 159

Rep: Reputation: 30
1 means true.
0 means false.

I assume 0 would mean off.
 
Old 02-29-2004, 11:08 AM   #3
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Give "enable" a try and see if that works.

Edit: I searched around and saw a couple of examples like that. Don't know if they actually work though.

Good luck

Last edited by itsjustme; 02-29-2004 at 11:12 AM.
 
Old 02-29-2004, 12:09 PM   #4
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
Just give:

Option "nologo"
 
Old 02-29-2004, 01:37 PM   #5
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 216

Rep: Reputation: 30
What they said should work, but I usually like to keep the logo because that way I know the driver is working. It doesn't really hurt to have it pop up.
 
Old 02-29-2004, 03:16 PM   #6
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by vinay_s_s
Just give:

Option "nologo"
doesn't work.

@At0mic_PC: i know the booleans of 1 and 0. the word/variable here is "NoLogo". unless this was stupidly named, 1 shoulg be NoLogo (and 0 would be NoLogo = FALSE hence Logo = TRUE)

@Atmchicago: once it's up and running, i'd rather not keep seeing it. coz i switch X on and off quite frequently. if i set runlevel to 4 and i see the logo just once, then it's fine.
 
Old 02-29-2004, 03:22 PM   #7
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Did you try:

Option "NoLogo" "enable" ?
 
Old 02-29-2004, 04:52 PM   #8
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
The manual says to use the following:

Code:
Option "NoLogo" "on"
make sure that you have it inserted in the right spot in the file, though, or it might not work well....
 
Old 02-29-2004, 05:02 PM   #9
notAslacker
LQ Newbie
 
Registered: Jul 2003
Posts: 16

Rep: Reputation: 0
no logo

abs,

Nvidia drivers are great but that logo screen is evil.

I tested the following driver options, running slack 9.1, 2.6.1 kernel, and nvidia 5336 stuff:

Option "NOLOGO" "1"
Option "NoLogo" "True"
Option "nOlOgO" "TRUE"

Each one prevented the logo. Option "NoLogo" "True", of all choices should have stopped the screen from showing. So maybe there is a typo or error somewhere else in your config file. Or you might try reinstalling the drivers. If you can't get the logo to go away, post XF86Config.

Quote:
so what's boolean?
"Boolean" gets its name from George Boole, the grandpa of modern logic; predicate calculus around 1850. In general boolean means something with two exclusively possible values.

Quote:
i've tried "1", "TRUE", "True", "on". what else? (NoLogo = 1 means Logo = 0, right?)
Looks good. Bools usually get (true or false) and (0 or 1+); where a value=0 means false and a value >=1 means true.

--notaslacker

Last edited by notAslacker; 02-29-2004 at 05:04 PM.
 
Old 02-29-2004, 06:43 PM   #10
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by itsjustme
Did you try:

Option "NoLogo" "enable" ?
yup. doesn't work.

Quote:
Originally posted by r_jensen11
The manual says to use the following:

Code:
Option "NoLogo" "on"
make sure that you have it inserted in the right spot in the file, though, or it might not work well....
doesn't work either. i found that in the man page too. i've put it in the "ServerFlags" section.

Quote:
Originally posted by notAslacker
abs,

Nvidia drivers are great but that logo screen is evil.
...
"Boolean" gets its name from George Boole, the grandpa of modern logic; predicate calculus around 1850. In general boolean means something with two exclusively possible values.

Looks good. Bools usually get (true or false) and (0 or 1+); where a value=0 means false and a value >=1 means true.
lol i know what a boolean is. i meant what does it need to be in that file so it's understood. and yes, the logo is quite a pain.

also, <= -1 is also true. in most programming languages that i know of, true is NOT false i.e. non-zero. dunno about how fractions type-cast to int/bool.

Last edited by abs; 02-29-2004 at 06:50 PM.
 
Old 02-29-2004, 07:01 PM   #11
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Quote:
Originally posted by abs
i've put it in the "ServerFlags" section.
It seems like that is not good.
I saw in another forum that it should go in the nvidia device section and it also said:
Option "NoLogo" "on"

Try moving to just below the - Driver "nvidia" - line, maybe.

Good luck...

Last edited by itsjustme; 02-29-2004 at 07:02 PM.
 
Old 02-29-2004, 07:17 PM   #12
Wynd
Member
 
Registered: Jul 2001
Distribution: Slackware 12
Posts: 511

Rep: Reputation: 32
I have

Section "Device"
# ...
Option "NoLogo" "True"
# ...
EndSection
 
Old 02-29-2004, 07:22 PM   #13
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
I got it to work. I put it right underneath the line that reads
Code:
Driver "nvidia"
and it works.
 
Old 02-29-2004, 07:30 PM   #14
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by itsjustme
I saw in another forum that it should go in the nvidia device section and it also said:
Option "NoLogo" "on"

Try moving to just below the - Driver "nvidia" - line, maybe.

Good luck...
yup, worked. thanks.

the Device section appears twice. in the first, there's a Driver "vga" line and it's Driver "nv" in the repeat of the section. i changed the nv line as per the nvidia docs and added nologo line below the VideoRam line.

just changed the "vga" to "nvidia" also to see if there's a diff.

edit:
no apparent diff.

Last edited by abs; 02-29-2004 at 07:31 PM.
 
Old 03-01-2004, 12:54 PM   #15
itsjustme
Senior Member
 
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Quote:
Originally posted by abs
just changed the "vga" to "nvidia" also to see if there's a diff.

edit:
no apparent diff.
I think you'll see a change if you run glxgears with each driver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to change the nvidia logo splash screen Furlinastis Linux - Software 4 11-24-2006 08:20 PM
Change Suse Logo to KDE Logo little_penguin Suse/Novell 2 04-05-2005 05:35 PM
Delay between Nvidia logo and display manager denzo74 Mandriva 6 12-06-2004 03:48 PM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 09:45 AM
nvidia logo NFS Linux - Newbie 9 01-13-2004 08:00 PM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration